Just installed openSUSE V 11.3 ... no internet

Hey everyone, I am brand new to linux so this is all very new to me. I bought a book, Beginning SUSE Linux, and am trying to learn Linux. The book came with SUSE V 10.1 but I could not get it to install on my computer. I downloaded open SUSE V 11.3 and it installed fine and runs great. Only problem, I can’t connect to the internet while running it. I have been flipping between Vista and SUSE so I could get on the internet in Vista and see if I could find any answers and after 5 hours of no success, I’m almost ready to give up. I tried to follow the directions in the book I bought but it seems very different since it is an older version of SUSE. My internet connection setup is as follows:

Desktop computer, no wireless capability

Ethernet cord from desktop to wireless router (D-Link AirPlus Xtreme G Wireless router)

Ethernet cord from wireless router to AT&T DSL Modem

I know there is nothing wrong with the setup because the internet works fine when I am in Vista, I have opened Yastat and messed endlessly with the DSL and Network configuration options… any advice or thoughts would be greatly appreciated, I am in the process of downloading ubuntu and giving it a whirl but I’d rather just try and get SUSE to work.

Thanks in advance.

Did you try Yast>Network Devices>Network settings? there you have to check for your network card presence and settings. If you use DHCP to obtain an IP address, you should be connected automatically. Check also in Vista the working settings.

Had a little trouble with this myself yesterday…no fewer than nine settings filled in for wifi card to work,
the ethernet connection worked from the start.

Copy all settings on Vista for the card, write them down, ethernet or wireless, duplicate them all on suse, blank settings
and everything. Should work then. Post back when they work. Using the network manager applet was easiest for


Most likely you’re using the DHCP server in the router to assign an IP address to the wired ethernet card. Sometimes in Linux you have to add settings into the config for the card to tell it the IP address of the router (called the gateway) and the IP addresses on the internet where the Name Servers for websites are located.

So you should add in the IP addresses of the gateway and the Name Servers. Here’s a pictorial on how to do that: Configure a network card in Suse/openSUSE 11.x for Internet Access & wifi. Keep focus on DHCP in your mind, skipping the “fixed IP” options and the “wireless” options, not relevant to your case.


e.g. Name Servers: http://opensuse.swerdna.org/nicifup/nic11.png
e.g. gateway: http://opensuse.swerdna.org/nicifup/nic12.png