Just Installed New Kernel 27th Oct 08

Just thought some would like to know I have installed the New Kernel

And for me it’s working fine. No issues yet. Just had to rebuild VBox.lol!

Ok, I came from kernel-2-6-25-18-0-1-a, but I didn’t get any problems with it, because I only use the graphical ‘nv’ driver, because I want to be productive, instead of constantly getting confronted with kernel update issues concerning proprietary (ugly word!) drivers. Both VMWarePlayer and VirtuaslBox run perfectly under the ‘faulty’ kernel. Now I’ve just updated to kernel-2-6-25-18-0-2 and I only needed to allow VMWarePlayer to recompile the kernel modules upon clicking the desktop-icon for my Ubuntu test virtual machine under VMWarePlayer and doing a ‘sudo /etc/init.d/vboxdrv setup’ to get VirtualBox also working. Although VMWarePlayer is also proprietary, VMWare has made recompiling kernel modules a lot more user-friendly since VMWare 6.5. Kudos to VMWare. NVidia should learn from VMWare to also include an automatic script for recompiling kernel modules just in case of a kernel upgrade instead of bailing out to a DOS-like screen.

I think I may have spoken too soon. It looks like suspend is borked on my Laptop. Could be worse. Now to see what can be done about it?

Changed suspend to disk and not ram and it works
so just suspend to RAM an issue at this time for me

I updated to the on my openSUSE-11.0 test PC. Its hardware:

  • apollo kt266/a/333 motherobard
  • nvidia gforce2 mx/mx400
  • Dlink wireless card with Atheros (AR5212/AR5213) wireless
  • Via 8233/A/8235/8237 AC97 audio controller
  • Phillps PCVC740K ToVca Pro webcam

Motherboard, graphics, and wireless worked ok.

Sound did not. Running neither yast nor alsaconf restored sound. The sound card simply was not recognized. I then updated alsa to 1.0.18RC3. Restarted. The sound card is then recognized. But the sound still does not work. Its the first time this has happened to me (with 1 exception, where there was a bug in alsa that the packager eventually fixed).

Its late, I’ll take a look at this later, and if necessary raise a bug report.

I’m currently suspicious of hardware.

This test PC was moved a couple of days ago. Sound was working then in both openSUSE-11.0 and 11.1 beta3. Yesterday dozens of boxes and various pieces of furniture were moved close to the PC, with various movers running around. I did not retest the sound after that. In hindsight, the chances of a static discharge were large.

I note now neither openSUSE-11.0 (which just had a kernel update) nor openSUSE-11.1 beta3 (with no update having been done by me) are working with sound.

Later this week I’ll try knoppix or kanotix (or sidux) for sound, but I am suspicious of hardware and finding about the sound problem now was a co-incidence.

I now have sound working with the updated kernel.

I booted to knoppix live DVD, and sound initially did NOT work. I ran alsaconf from knoppix and it configured the sound card, loaded kernel modules for sound, and sound still did not work.

I then rechecked the hardware (cabling and such), as I noted we had moved a day previous and I had not yet rechecked the cables after the move. I noted the audio cable for the speakers was plugged in one of 3 jacks, the colour on all 3 was faded such that only the red (mic) could be clearly seen. I could not tell the “blue” from the “green” jack. Shining a bright light on the jacks (which are on the BACK of this old PC) give a faint glimmer of green on the jack not in use. That suggested bad wiring. I changed the jacks, ran the sound test from konsole, and sound worked in Knoppix.

I then rebooted to openSUSE-11.0 with the latest kernel. Sound still did not work. I ran alsaconf and finally the test sound worked. I rebooted as a test. Sound still did not work after the reboot. I then ran “rcalsasound restart” and sound worked. So I put “rcalsasound restart” in the /etc/init.d/boot.local file, and sound now works repeatedly upon reboot.

But its really strange that I had to do that edit to the /etc/modprobe.d/sound. I’ve NEVER (as far as I can recall) had to do this before. I think this is a combination of the madwifi version I am using, and the new kernel. I suspect the madwifi is causing some problems with the sound (wild speculation on my part) and I may try to custom build the madwifi driver for this pc, install the custom build, and see if sound starts ok without the “rcalsasound restart”.

Still, its good to get sound back. :slight_smile:

So now I am really confused about upgrade now to p, li { white-space: pre-wrap; }, or wait for the next kernel update.

I am afraid especially in regards to my nvidia driver 173.14.12 (I am using GeForce Go 6150), which could fails to work, but after reading latest complains, also to the sound system.
To do or not to do?..This is the dilem

I take it you had some fun installing nVidia. Did you install the driver for that from the repo or manually using the nVidia installer?
It’s usually nothing to worry about and even if it does break the driver, just re-install it. Chances are, if you have the nVidia repo and use that, you will be OK.
If you installed manually from runlevel 3, you will certainly need to re-build the driver to the new kernel.

Updating to a new kernel always gives me pause, and before accepting a new kernel update I always ensure first I have everything in order (such as drivers for new kernel, if applicable, for sound, video, webcam, wireless, etc … ).

In my case (slight hiccup with sound) I sort of broke a cardinal rule, which was to change 3 things at once, instead of just one thing at a time. What I did was simultaneous:
a. moved PC from one apartment to another (and had sound cables re-connected wrong by either myself, the wife, or one of the movers < blush > ),
b. added wireless card and madwifi driver (where ndiswrapper/madwifi on Linux is known on occasion to interfer with audio),
c. updated kernel.
If I had done only one of those at a time, then the troubleshooting would have been easier. Sometimes one needs an experience like this to add some humility to one’s Linux experience. :slight_smile:

HI all.
I really don’t know if this is related to new kernell installation (i did it yesterday) or with other upgrades done, but it is sure that after i rebooted my laptop with new kernel, my kde 4.1.1 desktop stuck… Right click is not working, tray bar also broken…

All click on menu or other stuff in the panel does not work and i can start apps only using alt+f2 and switch them using alt+tab…

Does any one has an idea of what can be happened to my installation or has some suggestion? I already deleted .kde* folders on my home, but nothing changed…

Please, help me!
thank you!

Your kde4 you say is 4.1.1??

Most of us are on 4.1.2

The repo’s you need are

KDE4.1.2 Factory OS11

Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.0

Index of /repositories/KDE:/KDE4:/Factory:/Extra-Apps/openSUSE_11.0

Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.0_KDE4_Factory_Desktop

Index of /repositories/KDE:/Qt/openSUSE_11.0

suggest you remove whatever repo’s you have and replace as above and update

first of all, thank you for you’re reply.

Second: you’re right, i’m on 4.1.2, BTW i removed all KDE repo from yast and configured what you suggest (even if I’mpretty sure that i already had them).

During my check, I found a “strange” compiz installation, due to some unsupported plugin that i tryed… because off i can’t remember if i did that yesterday and i suspect that this could be part of the problem, i downgraded compiz and removed the unsupported plugin.

Now I’ll try the reboot and I cross my finger… I’ll let you know :slight_smile:

grrrr… didn’t work…
all packages are updated to thelast version… i do not have any unsupported package…
I’ve tryed to reinstall KDE4 using one click install but nothing…

Really don’t know what should i do to get back my desktop…

do you have kde3 installed?

is it the same?

if you don’t have it, install and try it
yast - software management - patterns

I do not have kde3, but i’m working right now using IceWM that works fine…

I guess that i also need to add KDE3 repo before installing it, correct?

Insatlling kde3…

Hi oldcpu, well in your case you really defied the Murphy law :), since you put several variables “on the same plate”.
In my case I have nothing of different on my configuration or environment, so I think that I should expect that, after running the kernel upgrade, my system would restarts working perfectly, but by reading the last reports on this matter, I am no more so confident.
I am tempted to run the upgrade but at the same time, I am worrying about possible failures on some apps.

By answering to caf4926: I am using the nvidia repo so, I should stay quiet enough, but probably I became a lazy linux user, that when everything works perfectly, doesn’t like too much to make changes.
But at same time I like to update and enhance the system, for this I am very doubtful in this moment :.
Thank you for your comments and enjoy the green chameleon!

Installed the update yesterday (and restarted of course), everything works fine. Vmware recompiled its modules, no problem with nvidia driver (from nvidia repo) either.

Hi Simico, fine to hear that; can you tell me a bit more about your HW/SW:

Video card
Sound card
nvidia driver versions

I checked onto nvidia repo, but I have not seen any updates for the current drivers I am using with kernel x86_64.


Well…I couldn’t resist, so I upgraded to latest kernel and…
Everything seems to work flawlessly; I have not yet checked kde4 however…
By the way I am happy that all is working at least in Gnome; sound as well :stuck_out_tongue: