Just installed 12.2, and it says i'm out of disk space when I'm not. How can I resize lvm partition?

New to openSUSE and lvm. I installed it with all the defaults, except I told it to use LVM. I have a 1tb disk, but it says I’m out of disk space, even though I haven’t used all the space. I’m not familiar with openSUSE or lvm, can anyone help resize the partitions? I want the home partition to have the majority of the space. Here is some info about my disk:

df -h
Filesystem               Size  Used Avail Use% Mounted on
rootfs                    20G  7.9G   11G  43% /
devtmpfs                 2.0G   44K  2.0G   1% /dev
tmpfs                    2.0G  288K  2.0G   1% /dev/shm
tmpfs                    2.0G  636K  2.0G   1% /run
/dev/mapper/system-root   20G  7.9G   11G  43% /
tmpfs                    2.0G     0  2.0G   0% /sys/fs/cgroup
tmpfs                    2.0G  636K  2.0G   1% /var/run
tmpfs                    2.0G  636K  2.0G   1% /var/lock
tmpfs                    2.0G     0  2.0G   0% /media
/dev/sda6                153M   43M  102M  30% /boot

http://i.imgur.com/YDRuQ.jpg

ingramproductions wrote:
> New to openSUSE and lvm. I installed it with all the defaults, except I
> told it to use LVM. I have a 1tb disk, but it says I’m out of disk
> space, even though I haven’t used all the space. I’m not familiar with
> openSUSE or lvm, can anyone help resize the partitions? I want the home
> partition to have the majority of the space. Here is some info about my
> disk:
>
> Code:
> --------------------
> df -h
> Filesystem Size Used Avail Use% Mounted on
> rootfs 20G 7.9G 11G 43% /
> devtmpfs 2.0G 44K 2.0G 1% /dev
> tmpfs 2.0G 288K 2.0G 1% /dev/shm
> tmpfs 2.0G 636K 2.0G 1% /run
> /dev/mapper/system-root 20G 7.9G 11G 43% /
> tmpfs 2.0G 0 2.0G 0% /sys/fs/cgroup
> tmpfs 2.0G 636K 2.0G 1% /var/run
> tmpfs 2.0G 636K 2.0G 1% /var/lock
> tmpfs 2.0G 0 2.0G 0% /media
> /dev/sda6 153M 43M 102M 30% /boot
>
> --------------------
>
> [image: http://i.imgur.com/YDRuQ.jpg]

That’s good information, and well done for using Code tags, but it would
be helpful to have some more. Could you also please show the output from:

fdisk -l
pvscan
vgscan
lvscan

FWIW, you don’t presently seem to have a /home filesystem. I would guess
you need to create one inside your /dev/system LVM volume, but the extra
output will make it easier to be sure.

While I strongly suppprt dhj-novell’ question for more information, I am still not sure about your problem.

… but it says I’m out of disk space, …

Who is the “it” there? Where do you see this and what are you doing at that moment?

fdisk -l

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x23529722


   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048       14335        6144   8e  Linux LVM
/dev/sda2   *       16065  1953520064   976752000    5  Extended
/dev/sda5           16128   664336007   332159940    7  HPFS/NTFS/exFAT
/dev/sda6       664336384   664657919      160768   83  Linux
/dev/sda7       664659968  1953519615   644429824   8e  Linux LVM


Disk /dev/mapper/system-root: 21.5 GB, 21474836480 bytes
255 heads, 63 sectors/track, 2610 cylinders, total 41943040 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes




Disk /dev/mapper/system-swap: 2147 MB, 2147483648 bytes
255 heads, 63 sectors/track, 261 cylinders, total 4194304 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes




Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00012c83


   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *        2048  1945139199   972568576   83  Linux
/dev/sdb2      1945141246  1953523711     4191233    5  Extended
/dev/sdb5      1945141248  1953523711     4191232   82  Linux swap / Solaris
pvscan
  PV /dev/sda1   VG system   lvm2 [4.00 MiB / 4.00 MiB free]
  PV /dev/sda7   VG system   lvm2 [614.57 GiB / 592.57 GiB free]
  Total: 2 [614.58 GiB] / in use: 2 [614.58 GiB] / in no VG: 0 [0   ]
vgscan
  Reading all physical volumes.  This may take a while...
  Found volume group "system" using metadata type lvm2
lvscan
  ACTIVE            '/dev/system/root' [20.00 GiB] inherit
  ACTIVE            '/dev/system/swap' [2.00 GiB] inherit

I got an error message saying there was no disk space when I tried to copy stuff from an external hard drive to my documents directory. It was about 50GB of data, and the error came up really soon after I started the copy.

That is indeed more informative. Now you posted in your df -h output. It shows that you have no swparate /home file system. Which means that your Documents directory, being insidde your home directory, that being inside the /home directory, is on the root file system. The output also shows
CODE]rootfs 20G 7.9G 11G 43%


IMHO this means that your have 20GB voor your root file system, of which there is still 7.6 GB free. My conclusion is that whenyou try to add 50 GB there, the system ahas no other choice then telling you that that does not fit.

You may have a 1 TB disk, but ass long as you do not more then 20 GB of it .......

And as you can see in your pvscan ouput, you have 590 GB :4  GB of the VG unused.

It is you that decided to use LVM for a resaon you did not explain. It is you that only used 20GB of it.

You could explain what you try to do so we could advise you how to achieve it.

I thought I told the installer to use the entire disk and it gave me the option to use lvm (which I think it said makes it easier to resize partitions). I didn’t mean for it to get setup the way it is currently, I thought I just clicked through on everything and checked use lvm.
Do I just need to reinstall? or is there an easy way to make the home partition with all the remaining disk space? I only installed the OS yesterday, but I’ve already got everything setup on it, so I’d rather not reinstall if I don’t have to.

To late. I just reinstalled the os

On 2013-01-16 23:36, ingramproductions wrote:
> I thought I told the installer to use the entire disk and it gave me the
> option to use lvm (which I think it said makes it easier to resize
> partitions). I didn’t mean for it to get setup the way it is currently, I
> thought I just clicked through on everything and checked use lvm.

I have seen other people doing what you did and get the same problematic
situation, so it is the system defaults when you choose LVM that work
that way. I think that when you choose LVM you get a minimal setup,
because you can expand it anytime as you wish.


Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

I am not sure how a combination of “use the whole disk” and LVM would work out.

In any case the whole disk wasn’t used either, because there still is (in the situation you showed. not as you have it now, because you did not tell) sda5 with an NTFS file system on it. And that is of course never spontaniously made by the installer.

There are also reports of the “use the whole disk” functionality not doing what I (and may be you) would expect from it. My advise would be to eiter create an empty partition table before you start the install and use the “use whole disk”, or during the install, when the proposals are shown, change the disk partition (custom partitioning or so), and delete there all and everything and then create the three partitions you probably want (something like a Swap about the same size of your memory, to accomodate hybernation), / (20 Gb ext4) and /home (the rest on ext4).

Only use LVM when you know how it functions and how to manage it.