Just installed 11.0 RC1

Still has a few little bugs and quirks, but OMG! We finally have a world class Package Management System.

Thank you! Thank you! Thank you!

I like 11.0RC1, … as you note, zypper is finally world class, finally bringing to SuSE users what 10.1 was hoped to do.

Some other things about 11.0 that I like:

  • build service is now integral to 11.0 (more than 10.3)
  • KDE-4 is available for those who want to play (“play” being my words, I’m staying with 3.5.9 for now)
  • YaST is faster than before, but with no loss of functionality
  • I’ve read the liveCD has been significantly improved
  • installation is more simple. I’ve read from 9.3 to 10.3 there were no installer changes … so this was the first big change in a while…
  • and the typical newer libraries, new apps, etc come with 11.0… so by updating to 11.0, one saves the effort of having to spend a long time trying selectively bringing their 10.3 up to the same level of libraries/apps as 11.0.

I still have a few bugs reports (that I raised) that I’d like to see fixed. One is automatic hotplug mounting of external NTFS drives with Read/write. The other is my athlon-1100 dislikes the 11.0 kernel, and requires many boot attempts, before a successful boot. I don’t expect this to be fixed, so I may put 11.0 on my main PC (as I don’t think that PC will have the boot problem), and revert back to 10.3 on my test PC. Rather a bizarre reversal.


Good to see you up:) It’s been a while; glad you are here:)


That’s actually the biggest surprise (that your Athy 1100 hates the 11.0 kernel) as my P4 2.6 (Northwood-C, hence not only Socket 478 but no PAE support) likes the latest update ( better than the vanilla RC1 kernel (or even Ubuntu 8.04’s kernel). The shock is only compounded by my not only not having PAE support, but only a mere 1.5 GB of RAM (hence the 2 GB swap partition, which I have used none of). I’m used to not using much swap (even under severe CPU loading), but using no swap at all with, technically, the “wrong kernel”, is unprecedented. RC1’s kernel also includes PAE support; however, they obviously found some tweaks somewhere.

For anyone on RC1, update from factory and you’ll be 11.0. Factory was frozen a couple of days ago in preparation for 11.0.

Get it before the masses do… :wink:

The zypper/Yast-PM updates are phenomenal. It seems that there is even an experimental version for Fedora, now. Good stuff all around.


I wanna play with Plasma! I’ve been doing it in VirtualBox, but it is really Greek to me. I hope someone puts up a how-to.

That aside, I have been running RC1 without Plasma and it behaves very nicely. I will take your tip on updating it!

From what I’ve read Plasma is really going to rock starting KDE 4.1. Also compiz fusion integration will be much tighter and more optimized.

I have been using openSUSE 11 as my main desktop starting beta2. There are some quirks here and there but overall it’s already an amazing release. There have also been many impressive under the hood modifications as well as updates to make existing apps much richer and easy to use. 11.0 won’t be 100% perfect but it’s going a long way in that direction… And it is already caught the attention of many!

Love that happy fuzzy feeling when seeing things come together,


Hoping that the main repo gets put up soon. I’m updated on factory but want to switch my package source soon.

The live-cd failed to correctly recognize a lot of hardware on my first generation Macbook but I’m willing to believe that this incident is limited to my particular configuration (bugs filed, of course). I’d also wish that the openSUSE developers take some hints from the Ubuntu live-cd and add some examplary content (pictures, videos, documents, presentations, etc.) as it helps with discoverability of the various applications which are included. This, of course, would mean less space for applications but it’s my impression that a lot of people evaluate distributions with live-cds so they leave a very good impression to the curious.

If you have Internet connectivity (from the live CD) you can take a look at the various Sneak Peeks posted in openSuSE news (there’s a link to it included with Firefox, on both the installation DVD and both live CDs). In fact, because it’s a live CD, you can take a look at the screens now (as the live CDs for 11.0 haven’t become available yet) from any live CD (such as that for 10.3).

RC1 is the only distro of linux to have actually completely worked on my laptop out of the box (except for ndiswrapper-ing the wifi), so I am VERY impressed. Especially as a) I have tried many many distros recently, and b) lots of live cd’s don’t even boot on this hardware.

And the package management is AWESOME fast.

I have Factory, 11.0/Updates (which went live Saturday) and Packman among my repos (started with 11.0 RC1). However, I likely will do a Complete Blanking once the GM ISO becomes available (since I’ve managed to figure out how to get my X1650PRO AGP to play nice with Compiz-fusion; now, I need to fix the game issues) and reinstall.

My boot problem is solved. It was a hardware problem.

Specifically an intermittent problem with the MBR in my 80GByte hard drive.

Having a hunch it “might” be the MBR on the hard drive, I swapped out the 80GB boot drive, with an old spare 40GB drive I had lying around. I installed openSUSE-11.0 GM and did 10xreboots. No problems at all.

Now I need a new hard drive. This 40GB is simply too small for me to live with. :rolleyes:

Reminds me of my old one, Window kept crashing (no longer on this computer), suse10.1 kept having strange problems, turned out the pins on the hard drive cable were broken :stuck_out_tongue: (this was after months of suffering :p)