Just coming back to the KDE world. RME HDSP MADI problems.

I’ve been having the worst luck coming back to openSUSE. I used it a few years back and went back to Ubuntu Gnome. I saw how Leap was turning out and had to switch. I have an RME HDSP MADI sound card. Under Gnome I was using Pulse audio and module-jack-sink to get system sounds, skype, firefox ect. to work. It worked like a champ.

Phonon has Jack as an option for sound and the systems sounds. Vlc with jack backend, amarok and other KDE programs worked great. However, I got no sound in firefox, skype, or steam. So I tried pulse again. Aparently all of these sound servers and APIs don’t work well together, because the pulse audio module-jack-sink won’t allow pulse to start.

I would like to remove pulse and just use phonon, but again, I won’t have sound for firefox, skype, or steam. I have a recording studio and have the jack server running 24/7. I used to be able to patch any software using pulse into any jack program. I’m just not familiar enough with phonon to make it do the same thing. Right now I have the vlc backend enabled for phonon.

How do I get sound for firefox, skype, and steam? If I go into the options for skype it shows “virtual device” and nothing else under sound devices.

I’m still trying my best to get this working. Bump

Confused at what you have done???

If I understand you want to use jack with pulse audio??

First have you gotten sound to work in Yast-sound and not stopped PA??? It must work in yast or it will not work.

Are you a meber of audio group??

Next have you installed pulse-modula-jack and jack of course??

As to your first question, I just want audio for everything to work through jack.

Since I’ve installed Leap, pulse has failed to start due to module-jack-sink, for some reason.

I am a member of the audio group.

I have installed pulseaudio-module-jack

System sounds in KDE work through jack using the vlc backend. Firefox, Steam, Kodi, and all other non-kde software has no sound, except VLC, because it’s using jack.

When I have jack running and try to start pulseaudio I get this error:

ben@core:~> pulseaudio
E: [pulseaudio] module-jack-sink.c: Failed to parse channels= argument.
E: [pulseaudio] module.c: Failed to load module "module-jack-sink" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.


have you done a vendor change to packman to pick up the proprietary codecs??. It sounds like you don’t have all the codecs you need to support those various programs. You do apparently have some sound

Now that you mention it, one of my other problems has to do with repositories.

I used the repository gui to install the packman repository, but my VLC won’t play mpeg flv files, after installing the codecs per this website: http://opensuse-guide.org/codecs.php

Right now my software gui in yast crashes after refreshing repositories, I either have to use zypper of yast2 from command line to install software. I also can’t update using the gui in the panel. I have to use zypper up.

I have no idea which repository is messing things up.

I finally got libdvdcss installed, which was something I was missing. However, still no luck with pulse.

I had some held packages, shown by zypper up, that I had to manually install to get it from the new vendor. After I did that I restarted my computer and jack showed only two inputs and outputs, which was odd, because my sound card has 64 channels. I ran pulseaudio and it attempted to connect to jack, which is closer than I have been getting. It ended up failing though. So I restarted jack and got my 64 channels back. I ran pulseaudio and it gives me the same error from my previous post.

You have to change vendor to packman not just add the repo. If you show zypper lr -d I can give you precise instructions

ben@core:~> sudo zypper lr -d
root's password:
#  | Alias                               | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                              | Service
---+-------------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------------+--------
 1 | dvd                                 | dvd                                     | No      | ----      | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.1/                               |        
 2 | ftp.gwdg.de-suse                    | Packman Repository                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.1/                    |        
 3 | http-download.opensuse.org-b5c26dd3 | home:giordanoboschetti                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/giordanoboschetti/openSUSE_13.2/ |        
 4 | http-download.opensuse.org-b67cfa33 | home:Nemton                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/Nemton/openSUSE_Leap_42.1/       |        
 5 | opensuse-guide.org-repo             | Libdvdcss Repository                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.1/                               |        
 6 | repo-debug                          | openSUSE-Leap-42.1-Debug                | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/              |        
 7 | repo-debug-non-oss                  | openSUSE-Leap-42.1-Debug-Non-Oss        | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/non-oss/          |        
 8 | repo-debug-update                   | openSUSE-Leap-42.1-Update-Debug         | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/oss                          |        
 9 | repo-debug-update-non-oss           | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/non-oss/                     |        
10 | repo-non-oss                        | openSUSE-Leap-42.1-Non-Oss              | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/                |        
11 | repo-oss                            | openSUSE-Leap-42.1-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/                    |        
12 | repo-source                         | openSUSE-Leap-42.1-Source               | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/             |        
13 | repo-update                         | openSUSE-Leap-42.1-Update               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/                               |        
14 | repo-update-non-oss                 | openSUSE-Leap-42.1-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/   

You have a 13.2 repo active this could cause you problems

I recommend you remove repo 3

zypper rr 3

then do a change vendor to packman by

zypper dup --from 2

Thanks for that. I got that part squared away and I can watch mpeg videos now, but pulse audio still won’t start. If I remove the module-jack-sink it will start, so the problem must either be with that or with the jack configuration.

Since everything in the KDE environment seems to have sound, how come Firefox, kodi, and skype are excluded? Why can’t they run in phonon, using the vlc backend?

LMAO, I can play html5 in Konqueror, but not Firefox…What’s the deal? Is KDE such a closed knit system that it won’t accept audio input from anything that doesn’t have a K in front of it?

Can anyone help me get sound working for non KDE apps?

Not all apps use phonon

So you may be missing codecs for those other programs but you need to say which other programs for detailed help. Skype should work with Pulse but if you use Jack then I don’t know???

Be sure you have the 32 bit stuff for Skype start from command line to see what is missing

If that be the case, then my problem is that pulseaudio won’t start when I have module-jack-sink enabled. My soundcard isn’t a normal soundcard. It’s a 64 channel RME hDSP MADI card attached to a 24 channel outboard converter. I have to use jack in order to hear anything. RIght now phonon seems to be playing very well with jack, because, like I said, I can hear sound just fine through KDE software. I also have the VLC backend installed and removed gstreamer. I can also hear fine through VLC, because I have VLC’s sound pointing to jack. The software I can’t hear sound through is Firefox, Skype, Kodi, and Steam. If Pulseaudio would start with the module-jack-sink enabled, It would work just fine. That’s how I did it in Ubuntu and in Opensuse when I used it a few years back. I assumed it was a bug, so I filed bug report 965478. I’m not sure if I did it right, but I tried to include all of the info I knew how to get.

When Jack is running, trying to connect pulseaudio via module-jack-sink fails.

ben@core:~> pulseaudio
E: [pulseaudio] module-jack-sink.c: Failed to parse channels= argument.
E: [pulseaudio] module.c: Failed to load module "module-jack-sink" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.

------------------------------------------------------------------------

I created a log file:

(   0.000|   0.000) I: [pulseaudio] main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
(   0.000|   0.000) D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
(   0.002|   0.002) D: [pulseaudio] core-util.c: RealtimeKit worked.
(   0.002|   0.000) I: [pulseaudio] core-util.c: Successfully gained nice level -11.
(   0.002|   0.000) I: [pulseaudio] main.c: This is PulseAudio 7.0
(   0.002|   0.000) D: [pulseaudio] main.c: Compilation host: x86_64-suse-linux-gnu
(   0.002|   0.000) D: [pulseaudio] main.c: Compilation CFLAGS: -fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -g -fPIE -W -Wextra -pipe -Wno-long-long -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -fno-common -fdiagnostics-show-option
(   0.002|   0.000) D: [pulseaudio] main.c: Running on host: Linux x86_64 4.1.15-8-default #1 SMP PREEMPT Wed Jan 20 16:41:00 UTC 2016 (0e3b3ab)
(   0.002|   0.000) D: [pulseaudio] main.c: Found 8 CPUs.
(   0.002|   0.000) I: [pulseaudio] main.c: Page size is 4096 bytes
(   0.002|   0.000) D: [pulseaudio] main.c: Compiled with Valgrind support: no
(   0.002|   0.000) D: [pulseaudio] main.c: Running in valgrind mode: no
(   0.002|   0.000) D: [pulseaudio] main.c: Running in VM: no
(   0.002|   0.000) D: [pulseaudio] main.c: Optimized build: yes
(   0.002|   0.000) D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
(   0.002|   0.000) I: [pulseaudio] main.c: Machine ID is a0848146a8854c519ce698d28901e824.
(   0.002|   0.000) I: [pulseaudio] main.c: Session ID is 2.
(   0.002|   0.000) I: [pulseaudio] main.c: Using runtime directory /run/user/1000/pulse.
(   0.002|   0.000) I: [pulseaudio] main.c: Using state directory /home/ben/.config/pulse.
(   0.002|   0.000) I: [pulseaudio] main.c: Using modules directory /usr/lib64/pulse-7.0/modules.
(   0.002|   0.000) I: [pulseaudio] main.c: Running in system mode: no
(   0.002|   0.000) I: [pulseaudio] main.c: Fresh high-resolution timers available! Bon appetit.
(   0.002|   0.000) D: [pulseaudio] memblock.c: Using shared memory pool with 1024 slots of size 64.0 KiB each, total size is 64.0 MiB, maximum usable slot size is 65472
(   0.003|   0.000) D: [pulseaudio] memblock.c: Using shared memory pool with 1024 slots of size 64.0 KiB each, total size is 64.0 MiB, maximum usable slot size is 65472
(   0.003|   0.000) I: [pulseaudio] cpu-x86.c: CPU flags: CMOV MMX SSE SSE2 SSE3 SSSE3 SSE4_1 SSE4_2 MMXEXT 
(   0.003|   0.000) I: [pulseaudio] svolume_mmx.c: Initialising MMX optimized volume functions.
(   0.003|   0.000) I: [pulseaudio] remap_mmx.c: Initialising MMX optimized remappers.
(   0.003|   0.000) I: [pulseaudio] svolume_sse.c: Initialising SSE2 optimized volume functions.
(   0.003|   0.000) I: [pulseaudio] remap_sse.c: Initialising SSE2 optimized remappers.
(   0.003|   0.000) I: [pulseaudio] sconv_sse.c: Initialising SSE2 optimized conversions.
(   0.003|   0.000) I: [pulseaudio] svolume_orc.c: Initialising ORC optimized volume functions.
(   0.003|   0.000) D: [pulseaudio] database-tdb.c: Opened TDB database '/home/ben/.config/pulse/a0848146a8854c519ce698d28901e824-device-volumes.tdb'
(   0.003|   0.000) I: [pulseaudio] module-device-restore.c: Successfully opened database file '/home/ben/.config/pulse/a0848146a8854c519ce698d28901e824-device-volumes'.
(   0.003|   0.000) I: [pulseaudio] module.c: Loaded "module-device-restore" (index: #0; argument: "").
(   0.003|   0.000) D: [pulseaudio] database-tdb.c: Opened TDB database '/home/ben/.config/pulse/a0848146a8854c519ce698d28901e824-stream-volumes.tdb'
(   0.003|   0.000) I: [pulseaudio] module-stream-restore.c: Successfully opened database file '/home/ben/.config/pulse/a0848146a8854c519ce698d28901e824-stream-volumes'.
(   0.003|   0.000) D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1 added for object /org/pulseaudio/stream_restore1
(   0.003|   0.000) D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1.RestoreEntry added for object /org/pulseaudio/stream_restore1/entry0
(   0.003|   0.000) D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1.RestoreEntry added for object /org/pulseaudio/stream_restore1/entry1
(   0.003|   0.000) D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1.RestoreEntry added for object /org/pulseaudio/stream_restore1/entry2
(   0.004|   0.000) D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1.RestoreEntry added for object /org/pulseaudio/stream_restore1/entry3
(   0.004|   0.000) D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1.RestoreEntry added for object /org/pulseaudio/stream_restore1/entry4
(   0.004|   0.000) D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1.RestoreEntry added for object /org/pulseaudio/stream_restore1/entry5
(   0.004|   0.000) I: [pulseaudio] module.c: Loaded "module-stream-restore" (index: #1; argument: "").
(   0.004|   0.000) D: [pulseaudio] database-tdb.c: Opened TDB database '/home/ben/.config/pulse/a0848146a8854c519ce698d28901e824-card-database.tdb'
(   0.004|   0.000) I: [pulseaudio] module-card-restore.c: Successfully opened database file '/home/ben/.config/pulse/a0848146a8854c519ce698d28901e824-card-database'.
(   0.004|   0.000) I: [pulseaudio] module.c: Loaded "module-card-restore" (index: #2; argument: "").
(   0.004|   0.000) I: [pulseaudio] module.c: Loaded "module-augment-properties" (index: #3; argument: "").
(   0.004|   0.000) I: [pulseaudio] module.c: Loaded "module-switch-on-port-available" (index: #4; argument: "").
(   0.019|   0.015) E: [pulseaudio] module-jack-sink.c: Failed to parse channels= argument.
(   0.034|   0.014) E: [pulseaudio] module.c: Failed to load module "module-jack-sink" (argument: ""): initialization failed.
(   0.034|   0.000) E: [pulseaudio] main.c: Module load failed.
(   0.034|   0.000) E: [pulseaudio] main.c: Failed to initialize daemon.
(   0.034|   0.000) I: [pulseaudio] module.c: Unloading "module-switch-on-port-available" (index: #4).
(   0.034|   0.000) I: [pulseaudio] module.c: Unloaded "module-switch-on-port-available" (index: #4).
(   0.034|   0.000) D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
(   0.034|   0.000) I: [pulseaudio] module.c: Unloading "module-augment-properties" (index: #3).
(   0.034|   0.000) I: [pulseaudio] module.c: Unloaded "module-augment-properties" (index: #3).
(   0.034|   0.000) D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
(   0.034|   0.000) I: [pulseaudio] module.c: Unloading "module-card-restore" (index: #2).
(   0.034|   0.000) I: [pulseaudio] module.c: Unloaded "module-card-restore" (index: #2).
(   0.034|   0.000) D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
(   0.034|   0.000) I: [pulseaudio] module.c: Unloading "module-stream-restore" (index: #1).
(   0.034|   0.000) D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1 removed from object /org/pulseaudio/stream_restore1
(   0.034|   0.000) D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1.RestoreEntry removed from object /org/pulseaudio/stream_restore1/entry0
(   0.034|   0.000) D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1.RestoreEntry removed from object /org/pulseaudio/stream_restore1/entry1
(   0.034|   0.000) D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1.RestoreEntry removed from object /org/pulseaudio/stream_restore1/entry2
(   0.034|   0.000) D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1.RestoreEntry removed from object /org/pulseaudio/stream_restore1/entry3
(   0.034|   0.000) D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1.RestoreEntry removed from object /org/pulseaudio/stream_restore1/entry4
(   0.034|   0.000) D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1.RestoreEntry removed from object /org/pulseaudio/stream_restore1/entry5
(   0.034|   0.000) I: [pulseaudio] module.c: Unloaded "module-stream-restore" (index: #1).
(   0.034|   0.000) D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
(   0.034|   0.000) I: [pulseaudio] module.c: Unloading "module-device-restore" (index: #0).
(   0.034|   0.000) I: [pulseaudio] module.c: Unloaded "module-device-restore" (index: #0).
(   0.034|   0.000) D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
(   0.034|   0.000) I: [pulseaudio] main.c: Daemon terminated.

It’s literally taken me a month to realize that it was something stupid. In the settings, under miscellaneous, Qjackctl has an option for enable D-BUS interface. I turned that on and pulse audio cranks up just fine along phonon. rotfl!YAY and…:. I guess the Qjackctl package that comes with openSuse doesn’t have that enabled by default. I don’t ever remember having to deal with that in Debian/Ubuntu.