just a trivial question

hi guys,
something bugs me lately. i’m using fglrx driver on kde desktop. but the performance is not that good. when i was using same driver on gnome destop performance was much better. so, my question is: does desktop enviroment affects graphics driver performance, or am i just being paranoid?lol!

PS also it seems to me that mesa driver is better on kde, and worse on gnome:)

Please always tell which version of openSUSE thi sis about.

And as this seems to be about KDE, telling which version of KDE you use is also not a bad idea because while there is but one version of KDE that realy is included in an openSUSE version, many people use stable KDE repos for newer versions.

it’s opensuse 13.1, kde 4.11 though this was just a general question, does desktop environment affects graphics performance?


Well, different desktop environments/window managers use the graphics card in different ways, so yes, there could indeed be a difference in graphics performance obviously.
You’re desktop environment’s/window manager’s particular settings might influence things as well.

Please enter KDE’s Systemsettings (“Configure Desktop”)->Desktop Effects->Advanced, and verify that you have the following settings:

  • composite type should be “OpenGL” (2.0 or 3.1 if your card supports it)
  • Qt graphics system should be “Raster”

Those settings should give you the best performance, and make full use of your graphics card.

You might want to disable the “Blur” effect (“All Effects”) and/or “Lanczos” filter (i.e. set the scaling method to something other than “Accurate”), those have been known to cause problems (mainly slowdowns) in the past depending on the graphics driver.

Also, what graphics card are you actually using?

As wolfi323 says. But may I remiind you that you yourself say that you see a difference between using Gnome and KDE. Thus you are the one that first suggested that the desktop evironment used could affect graphics performance.

i’m using radeon 5450. i’ve switched to open-source driver, which works great for me on kde. i used to avoid it on gnome, it didn’t work well. but now it does :slight_smile:

thanks guys for answering so fast