Juniper SSL VPN modrpobe tun

I recently isntalled opensuse 11.3 and I was trying to get the juniper ssl vpn working.

It connects and everything goes fine until it prompts me for the root password. Once I do that, it errors out saying:

“Modprobe for tun module failed” or something of that nature. Anyone know how to resolve this?

What are You using as your client to connect to the VPN ? In my last job we had a juniper VPN that You had to use IE to connect to so my experience with juniper’s VPNs is that they not support OSes other than Microsoft Windows.

If however You have some standalone client to connect to the VPN try openVPN client. It works great with some Cisco VPN access gateways.

Best regards,

I am connecting using firefox, but I have gotten it working in Ubuntu which was my previous installed distro. I just now installed Opensuse. I know that it can work, but I need to somehow tweak the tun module. Just not sure how. I’ve been googling and searching with no luck :confused:

Ok so than it should work on openSUSE as well. Can You think of anything else You had installed on Ubuntu that You haven’t got on openSUSE ? What is the ssl using ? It’s some java application ?

Best regards,

Please tell us what is required for this to work.

What did You install to make it work on Ubuntu and what did You install on openSUSE already to make this work ?
How did You install particular pices of the puzzle ?

Best regards,

Howto setup Juniper Network Connect VPN on Ubuntu 9.10 | Ubuntu Geek

THis usually works. How can I get the official sun java installed? That may be part of the issue

It has depended on the version of ubuntu. In some older versions there were some tweaks needing to be made to the TUN module.

I guess let me get the sun java installed first. how can I go about that?

Try this command :

sudo zypper in java-1_6_0-sun java-1_6_0-sun-plugin

If successful You should get this output after the zypper does it’s magic :

rzes@opensuse:~> java -version
java version "1.6.0_23"
Java(TM) SE Runtime Environment (build 1.6.0_23-b05)
Java HotSpot(TM) Server VM (build 19.0-b09, mixed mode)

Best regards,

Got it resolved. Had to add the proper repo following this document:

Installing Sun Java and openSUSE 11.1

I then completely removed the icedtea java plugins to make sure that firefox was using the sun java and it worked.

Hope this helps any future users that have a Juniper SSL VPN

I’m very happy to hear You solved the problem. Thanks for the feedback.

Best regards,