Jovie (kde4's text to speech app) problems

The title says it all.

The backend used by jovie is supposed to be “espeak” by default. But when i tried to run on command line

#espeak "this is a test message"

for example, it throws an error related to jack

Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started

. (It speaks however)

  1. Does someone knows how to correct this espeak’s jack dependency ?

  2. On jovie’s configuration dialog, there is no talker/filter/job defined. When i click for example “speak clipboard content”, there is no sound ! how can i resolve this?

i’d really like to have my computer speaking and reading for me.

Thanx in advance

Can you check Yast2 - Software and search for “jack”? Are there any apps listed that need to be installed? The last time I looked at jack stuff was in an ancient SUSE version and you had to explicitly install it.

Jack is already installed on my computer. And also, at the time when i run “espeak” command, Jack is already started.