journal block not found

Running opensuse 12.1 with all the latest patches.

I’ve got a 2B Samsung drive that is formatted to ext4 and mounted under samba. Copying about 1TB of data to the drive and I keep getting errors after about 3 hours of copying. I first thought the disk was bad - tried reformatting it, tried the samsung low level format and diagnostic program - it doesnt find and bad sectors and no problems with SMART. I then swapped out the disk with a 1TB drive - same issue. I also tried a different sata card, so I think that rules out hdd/sata port.

I keep getting this:

[21505.449519] jbd2_journal_bmap: journal block not found at offset 32763 on sda1-8
[21505.449738] Aborting journal on device sda1-8.
[21505.449931] EXT4-fs error (device sda1) in ext4_reserve_inode_write:4137: Journal has aborted
[21505.450298] EXT4-fs error (device sda1) in ext4_dirty_inode:4264: Journal has aborted
[21505.450723] EXT4-fs error (device sda1): ext4_journal_start_sb:327: Detected aborted journal
[21505.450823] EXT4-fs (sda1): Remounting filesystem read-only

Any ideas what else I can try?