joining Windows Domain using Suse10.3 and 11

Was interested in joining Windows Domain" in my “Suse10.3” Yast2.
Configured options to support Windows Account logons

The “Joining Procedure” seemed to work fine… Seemed to automatically discover the DC, asked for Domain Admin credentials to Join, authenticated the request, then installed the RPMs necessary to support kerberos authentication.

Reboots now prompt for a login, and with the Windows Domain properly identified.

But, no existing Windows Account credentials works. Only local SuSE accounts work.

Once logged in a person can now browse the Windows Domain although of course because you weren’t able to login with a Domain account from the beginning, you’re prompted for credentials when you try to connect.

Now that im trying out Suse11
I dont even get that far… So when I try to join my suse 11 to the network… It will automatically discover the DC, asked for Domain Admin credentials to Join so when I type in the authenticated the request info… and hit ok so it can add me to the domain…

after few mins I get a pop up error saying. failed to find DC in Domain etc etc…

Now of course I work in a company that uses ADS… I’m trying to convince them that a Linux machine will work on windows network, this just doesn’t cut it. In there eyes.

Any ideas or tips

To join a domain a working DNS setup is required. Normally you have to use the DC as the DNS server.

Is the time in sync? Winbind and kerberos require a working clock.

Is the firewall disabled or did you open the needed ports?

I’ve successfully joined a Windows 2008 Active Directory Domain with openSUSE 11.0.
If it still doesn’t work, use the 3.2.0 final packages available in the build service.

Well it should have a DC.
when I was runing 10.3 it could join though not with out a bunch of trys befefore it joind… And when I tried the SLED10 it joind as well… Tis why I was wondering if was issue with ver 11. The Firewall is off.

I have exactly the same problem. Did you find any solution?