I have loaded jbidwatcher from packman.

It does not appear in the Kmenu.

How can I run it and include it in the menu?

I run Suse 11.1 and KDE3.5


I have not tried to use it myself … my wife is the big ebay user, and she is a winXP lover …

Still, I note on the jbidwacher.com page there is a quick start page. Did you try reading that already for some answers to your question?
QuickStart guide to JBidwatcher


I have downloaded the latest version of jbidwatcher

Where should I put it?

On my other computer where it is working - in the home/bin there is a file


any idea of the syntax I need to install this?

from the link
java -Xmx512m -jar ~/JBidWatcher-1.0.1.jar

I have been using bidwatcher for 4 years - it’s great.


The Packman packaged version is 2.0.1, and generally speaking packman packaged versions of applications tend to be easier for new users to run, even easy than java based applications such as what I believe you now you downloaded in your last post.
PackMan :: Package details for JBidWatcher


I have just downloaded JBidWatcher-2.0.1-0.pm.1.noarch.rpm and got YAST to install and still do not get a working icon on the K menu just a jbidwatcher (Administration) that does nothing.

I think the program has been downloaded and run.

Any ideas?

I am running Suse 11.1 and KDE3.5


I’ve never bid on ebay, so I can not help with those aspects.

But some things I note:

The packman rpm has this content:


The script file JBidWatcher.sh has this content:

mkdir -p $HOME/.jbidwatcher

/usr/lib/jvm/java/bin/java -Xmx512m -jar /usr/share/java/JBidwatcher-2.0.1.jar 2> $HOME/.jbidwatcher/JBidWatcher.log

clearly (at least to me) that the script calls java to run the .jar file JBidwatcher-2.0.1.jar

There is also an icon you can drag to your desktop: /usr/share/applications/JBidWatcher.desktop and you can launch from your desktop.

If you want a menu entry in KDE3, then you can create a custom one, and have it call the /usr/bin/JBidWatcher.sh script, or end the java command " /usr/lib/jvm/java/bin/java -Xmx512m -jar /usr/share/java/JBidwatcher-2.0.1.jar 2> $HOME/.jbidwatcher/JBidWatcher.log "

… as to what you do after running those commands, I believe one 1st has to know something about ebay (of which I know nothing) and second possibly skim the instructions on the site whose url for a quick start that I already provided: QuickStart guide to JBidwatcher

If you need more instruction that that, then apologies, but I can’t help.


Thanks for your help.

I have been using jbidwatcher for 4 years and also Ebay. It’s just getting it loaded on this machine.

I did a few months back I used packman to load it on my lap top and all is working.

Thanks Again

Long Shot…

the /usr/bin/JBidWatcher.sh

exits and is as follows

mkdir -p $HOME/.jbidwatcher

/usr/lib/jvm/java/bin/java -Xmx512m -jar /usr/share/java/JBidwatcher-2.0.1.jar 2>

this file does not exit?
/usr/lib/jvm/java/bin/java -Xmx512m

where would it come from?

the /usr/lib/jvm/folder only contains a folder jre?

Can anyone help please.

Silly question my part.

Have you installed java?

Yes as far as I can tell. A search in YAST brings up many files for java.

I will look on my working machine to see if that folder exists?


It gets worse
no the folder does not exist on my Suse10.2 machine and nor does the file /usr/bin/JBidWatcher.sh

but if I execute the jar file on this machine using Suse 11.1 and KDE 3.5 the program runs fine? logs on Ebay etc but in the shell it says

Fri Oct 16 20:56:33 BST 2009: Error setting up scripting: java.lang.NoClassDefFoundError: org/jruby/runtime/builtin/IRubyObject


well I have got it working - maybe not in the correct way

put JBidwatcher-2.0.1.jar in the home bin folder

created a link on the desktop] to an application with
java -jar ‘/home/brian/bin/JBidwatcher-2.0.1.jar’

in the command line and using the correct icon.

well some sort of success.

That had been the work around on the other machine, [not by me!] Suse 10.2 and thats been working this program 4 years.

I would like to install it correctly but at least it is working.

If you are on kde just right click the kickoff button and choose Menu editor
Create a new item and put java -jar ‘/home/brian/bin/JBidwatcher-2.0.1.jar’ in the command line entry. Save…and… that`s all.


Thanks - done