java video not working after firefox 3.5.9

after the upgrade to firefox 3.5.9 yesterday, video from my internet camera doesn’t appear. Firefox loads the web page from the camera, but the box in the web page containing the video stream doesn’t show up.

my system is opensuse 11.1, 64-bit. I temporarily downgraded to firefox 3.0.18 and the video worked as usual. By shutting off plugins, I found it was the IcedTea Java web browser plugin 1.6.2 that was driving the video.

so I upgraded back to firefox 3.5.9, started looking for an upgraded version of the Java plugin, but the software manager shows that the latest is java-1_6_0-openjdk-plugin (1.6.2_b16-0.1.1 x86_64) and that it is already installed.

any suggestions?



ok, so i go to Plugin Check and it shows the icedtea java plugin and it’s the latest version.

i go to JDK 1.4 Demo Applets and none of the sample applets run.

in the firefox pulldown tools -> add-ons -> plugins window i can enable/disable the icedtea java web browser plugin. when disabled and I try to run an applet, i get the lego brick and a message “click here to download plugins”. when enabled and I try to run an applet, nothing shows.

the error console doesn’t report anything.

Have you tried Sun java ? It’s usually more reliable than Openjdk. Remove Openjdk and install:

zypper in java-1_6_0-sun java-1_6_0-sun-plugin


Has this resolved your problem?

I have similar problem with the java plugin. zypper in java-1_6_0-sun java-1_6_0-sun-plugin doesn’t resolve the problem because the packages are already installed…



no, sorry.

i can get konqueror to work with my internet camera for now. (konqueror doesn’t run the 1.4 demo applets either, but at least reports a problem.)

maybe another update will come down the pipe that fixes this problem. or i may install 11.2 sooner than planned.

i just thought more than two people would have seen this.

Thanks, good luck.