Java not Working in Firefox

OS 11.3 x86-64 & KDE; Firefox 3.6.13 (newer not in repos yet), Java 1.6.0_23 installed (Open JDK/IcedTea removed from system.)

The 1.6.0_24 Java update caused a couple of Java apps I need for work to stop working. I had to download the 23 version from the Oracle site and do a manual install without using Yast after making sure Java/IcedTea were removed first.

The Opera browser works with Java just fine now, but Firefox does not. Firefox is required for work because of our IT Department, so just using Opera is not an option.

Firefox shows the Java Plugin, passes the verification test at Verify Java Version, but Java apps won’t work in the browser.

This site: ParaChat Samples has some sample chat rooms. All I get in Firefox is a blank box and then nothing. I’m not sure if I’m missing a symlink somewhere, or what. Any help appreciated.

If you use ffx 3.6.14 you need to update to 3.6.15 (not sure if avail already in the repos).

This update was **only **because java does not run.

Eventually you will be able to use u24 afterwards.

See this: https://www.mozilla.com/en-US/firefox/3.6.15/releasenotes/ (press on whats new in 3.6.15):

What’s New in Firefox 3.6.15

                Firefox 3.6.15 fixes the following issues found in previous versions of Firefox 3.6:
  • Fixed an issue where some Java applets would fail to load in Firefox 3.6.14
                    You may also be interested in the             [Firefox 3.6.14 release notes](https://www.mozilla.com/en-US/firefox/3.6.14/releasenotes/) for a list of changes in the previous version.           

Cheers.

PS
I think the older branch versions had the same issues since I noticed those were updated as well.

Use the mozilla repo
Index of /repositories/mozilla/openSUSE_11.3

Added the Mozilla repo above, but Yast is not showing the Firefox 3.6.15 update. Its still showing 3.6.13 and current, with no updates available.

Not sure if this will fix the problem but I’m willing to try it. :slight_smile: The 3.6.13 version worked fine with the Java 23 and all I wanted to do was roll things back to before that bad Java update, but something seems to have been fouled up in the process.

Do this
http://dl.dropbox.com/u/10573557/Switcher%20Pics/mozilla-switch.png

The update IS there

On 03/06/2011 08:06 AM, walla299 wrote:
>
> Not sure if this will fix the problem but I’m willing to try it. :slight_smile:

the i586 (32 bit) versions of firefox 3.6.13-0.2.1 and Java
1.6.0.u24-0.2.1 are working perfectly here (on my 32 bit openSUSE
11.3)…and it works especially well with my banks software which is
VERY persnickety…

both are in the standard repos and offered for install (here) by YaST…

there is a reason i run 32 bit software on a 64 bit capable
machine…(the reason is it works, and i’m not running any million
line databases or rendering 3d movies over night, so there is just not
a lot of benefit in using 64, for me…until more of the “little
problems” are solved…)

i do not know (but i bet someone does) how to install 32 bit
applications on a 64 bit system…

ymmv


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11

Yes, it was there once I followed your directions. No FF 3.6.15 is loaded, and works – but Java still won’t load apps. The browser is still seeing the plugin, still passes the verify on the Oracle site and tells me Java 23 and I need to upgrade – but the Java apps start to load and give a blank screen where they are supposed to be.

There is something new, though. Running Firefox from a terminal gave me this on exit after waiting around 10 minutes (ParaChat Samples, Option 8 to see if it would load) :

bruces@linux-xv3h:~> firefox
Exception in thread "main" netscape.javascript.JSException: Plugin instance for applet ID 2 was already released
        at sun.plugin2.main.server.LiveConnectSupport.getInfo(Unknown Source)
        at sun.plugin2.main.server.LiveConnectSupport.shutdown(Unknown Source)
        at sun.plugin2.main.server.JVMInstance.unregisterApplet(Unknown Source)
        at sun.plugin2.main.server.JVMInstance.recycleAppletID(Unknown Source)
        at sun.plugin2.main.server.JVMManager.recycleAppletID(Unknown Source)
        at sun.plugin2.main.server.MozillaPlugin.stopApplet(Unknown Source)
        at sun.plugin2.main.server.MozillaPlugin.destroy(Unknown Source)
/usr/lib64/firefox/firefox: symbol lookup error: /usr/lib64/libkdecore.so.5: undefined symbol: _ZN9QListData6removeEi

This is more feedback than I’ve gotten in the past from the system, so I hope this means we’re making some progress. :slight_smile:

Switching to the 32-bit version is an option. (Something I may consider for 11.4 when I get around to installing it.) However everything was working fine in 64-bit until the bad Java update fouled up the works. All I’m trying to do is roll that back.

I did a google search on the specific error which seems related to some kde libs - did you by any chance updated something from there beside java VM?

That one (undefined symbol: _ZN9QListData6removeEi) might not be even related to your java applet error though.

Does the java console gives some error output? (set tracelevel to 5)

Regarding the symlinks, did you follow sun’s/oracle’s procedure regarding the symlinks - I remember from Firefox support sites that there were a lot of problems related to javaplugin-oji.so and libnpjp2.so libs.

Google search did reveal also this rather weird issue: [ubuntu] Squid configuration to allow Firefox Java plugin - Ubuntu Forums](http://ubuntuforums.org/showthread.php?t=1326849) which might be related to your java chat app (btw you said that ALL java apps do not run but the app from the java.com site did run… did you try other java apps which are not related to chatting - socks creation etc.?)

In any case I think the best way to deal with it is DenverD’s “suggestion” and sticking to the repos packages.

Cheers

Tried your suggestions and still no go.

Ripped out (uninstalled) Firefox, Java, erased profiles in /home, etc. One step shy of formatting the hard drive, in other words. Reinstalled everything from the repos, and used the Yast version tab to install Java 23 rather than the Java 24 update that started this nightmare. Java apps still won’t work in Firefox, especially the chat room software I need for work at home! WTF? The Parachat software will load and run in Opera, but copy and paste won’t work, and a couple of menus don’t work when clicked on. This is why I’ve been trying to get rid of Java 24. Java apps loaded outside the browser don’t work, some functions are missing, or they just crash.

Since I was now officially angry, and didn’t have much to do anyway: Formatted the whole system. Yeah. Nuked it. A bit extreme perhaps, but I’m tired of this.

Installed OpenSuse 11.3 x86_32-bit to see if the problem was something in the 64-bit version. Removed the OpenJDK and installed Java 23 in its place using the versions tab in Yast. Java apps run from a menu or terminal work fine now, but the web apps still won’t work in the Firefox browser. The Parachat software now loads and runs in the Opera browser, so I can work at home on the PC again. Turns out our IT Department doesn’t care about the browser version, but things won’t work without the chat room. Really don’t care for running 2 different browsers when one with 2 different profiles would do, but I’ll go with what works for now.

On 03/13/2011 06:06 AM, walla299 wrote:
>
> but I’ll go with what works for now.

always go with what works!

you might consider the need for a dedicated WORK system that you only
‘upgrade’ AFTER you have verified the new system will support your
work needs…that is, have a static WORK system and an exact copy
of that system in your ‘sandbox’, upgrade the sandbox and see if the
work stuff works…if so, ok…if not, you still have a working WORK
system…

it is difficult, but no more so than other systems–ask around and see
if you can’t find folks who have ‘upgraded’ their (say) MS system and
then found they had to spend lots of money for new hardware and/or
software because their old stuff just didn’t work right any more…or,
the new ‘improved’ and highly ‘innovative’ system didn’t support the
OLD hardware at all…


DenverD
CAVEAT: http://is.gd/bpoMD
[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11