java isnt working

Ok, I keep having wierd problems. My whole Suse install was working wonderful yesterday except I started trying to build VMs and running lots of memory intensive apps and then noticed that when I installed opensuse, it created a 2 GB swap partition and I was maxing out. I needed to increase this. I basically reinstalled my OS and now my swap partition is 60 GB. (I have a 1 TB SSD so hopefully it’s pretty responsive.)

But now I’m having all new issues I didn’t have last time. I am trying to get Crashplan working so I can restore my files and I can’t get the GUI to open. I’m 99% sure the GUI is Java. I uninstalled the openjava and trying to get Oracle Java to work. I am getting nowhere. I don’t care if I install java via tar.gz or .rpm. I guess I’d prefer .rpm. I’ve tried installing the rpm via install software option when I right click and open with app. It installs with no errors. I’ve been trying to figure out how to link the .so file to firefox. I can’t figure out where the plugins folder is at.

This is what I get if I try to see what java I have…

linux-11fn:~ # systemsettings(8552)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
update-alternatives --config java
update-alternatives: warning: /etc/alternatives/java is dangling; it will be updated with best choice
There are 2 choices for the alternative java (providing /usr/bin/java).

Selection Path Priority Status

0 /usr/java/jre1.8.0_121/bin/java 180121 auto mode
1 /usr/java/jre1.8.0_121/bin/java 180121 manual mode
2 /usr/lib64/jvm/jre-1.5.0-gcj/bin/java 1500 manual mode

Press <enter> to keep the current choice
[li], or type selection number: 2[/li]update-alternatives: using /usr/lib64/jvm/jre-1.5.0-gcj/bin/java to provide /usr/bin/java (java) in manual mode

I tried changing it to the bottom one, but nothing better.

I also tried this and no better.

linux-11fn:/home/david/Downloads # zypper in jre-8u121-linux-x64.rpm
Loading repository data…
Reading installed packages…
‘jre1.8.0_121 = 0:1.8.0_121-fcs’ is already installed.
No update candidate for ‘jre1.8.0_121-1.8.0_121-fcs.x86_64’. The highest available version is already installed.
Resolving package dependencies…

Nothing to do.

I used these instructions a couple of weeks ago but on 12.3. They worked. I did it after downloading the jdk but that shouldn’t make any difference.

I intend to install it on 42.2 shortly. What I will do first is to search for the current location of the files to use as a check in case something keeps a copy in a place it shouldn’t…

There is another guide on their site for 13.?? but from memory there isn’t any difference. Actually when the host set up is shown it was installed on leap 42.1. It’s here.

My main reason for not using the open source version is that I want to write and run a couple of java applications. For other uses if ok I would leave things as they are.


I got it to work earlier doing this…

first uninstalled the ice tea java or whatever using software manager
used tar.gz to install

moved extracted tar.gz to /usr/java

got java working in browser using these instructions to link it…

export JAVA_HOME="/usr/java/jre1.8.0_121"

ln -sf $JAVA_HOME/lib/i386/ /usr/lib/mozilla/plugins/


ln -sf $JAVA_HOME/lib/amd64/ /usr/lib64/browser-plugins

I just installed the jdk and jre using rpm’s from the oracle site by right click open with install remove software. Looking at the file list they all go to /usr/java so if sourced from there the alternatives method should work. :slight_smile: Haven’t tried that yet though and as I am not 100% sure about what I am doing it may go wrong.

I had never managed to do this before changing 12.3. Confused by all of the links that are used and not aware of the alternatives method. It seems to have the advantage of being able to keep several versions and switch between them if needed pretty easily.

In the past the browser plugin has always defeated me but this link shows how that can be done. They don’t name the file as I would have expected.