JAVA dilemma

I have a VPS with a hosting service supplied control panel I can access via a browser interface. That interface only seems to work with Sun/Oracle JAVA. From a Windows machine with the Sun/Oracle JAVA installed the browser interface works perfectly. From my openSUSE 12.1 machine it is broken in all parts where you access the console. Access to the VPS via this method is a failsafe in that you can gain control of your VPS if something is wrong and a regular SSH session doesn’t suffice to do what is necessary (Like if your machine is compromised and taken over and you are locked out by the attacker.)

Because Oracle has changed the JAVA license and is generally run by not very nice people all Linux distros have stopped using Sun/Oracle JAVA and installing it and getting it working is no longer a simple matter of getting it from the repos. All the hooks and configurations are no longer automatic. I am faced with the dilemma of trying to get it working on my main desktop machine and risking messing up and breaking it by getting it wrong or depending on a Microsoft Machine. I don’t like either alternative. I really don’t know how to fix this.

I wish the alternative was still there to get it from the normal openSUSE non free repo like it was in 11.X

Or is it just expecting a windows based browser? Have you tried tweaking the user agent string?

The “console” app is pretty horrid. Even the people who hacked it together acknowledged that and yes it expects Oracle. They are working on a new one but no time frame given and it’s not a priority for them. It’s a budget operation.

<Furi-Yuri> Does the buyvm control panel actually expect Oracle JAVA?
<doublebeta> Furi-Yuri: yes, if you want to use the KVM viewer

You could try the IBM version of Java. It is a free download and I have not found any problems with it. Easy to install and supports updatealternatives. It is not certified for opensuse. It works with opensuse up to 11.3. I have not tried it on 12.1 as I am reluctant to move to 12.1 from a mostly working 11.3

Several people have it in their OBS home repo:

Thanks for that link.