Java browser plugin problem

I follow this guide EXACTLY: How do I download and install Java for my Linux computer? - 1.5.0, 6.0

I get this message when I try to install it: “package jre-1.6.0_10-fcs is already installed”

I make sure it’s not installed in YAST. I search for “jre-1.6.0_10-fcs” using “find files/folders” and I can’t find anything.

I’ve had this problem for some months now and I’m dying for a friendly person to pleas help me out.

Why not install it with YaST? It’s in the ‘non-oss’ repo. If you don’t have that repo added just go to YaST>Software Management. Then go to the repositories menu. Choose to add a repository and then choose the community repositories option. There you should find the correct ‘non-oss’ repo for your version of openSUSE. Once it is added hit accept and then in Software Management search for Sun…

That was my first try a couple of month ago but it didn’t work. I’ve tried it over and over again. I don’t get that to work. I install it, it is installed, but when I trie to play a Java game on internet it doesn’t work. I think the problem lies in that when I try to install Java manualy it says it’s already installed. Any more suggestions. Thanks for the help, it’s realy needed for me not to blow up.

Are you using Firefox? Typing


in the address line will tell you if firefox has found java. Perhaps it is installed ok but firefox is not looking in the right place?

Have you had a look athere and here?

“about:plugins” gives me some plugins but not Java. My guess is your guess that Firefox can’t find it because even “Find files/folders” can’t find it. I’ve checked the links you sent. Maybe if there is someway of deleting it through the terminal so I can install it fresh? Ideas?

Thanks for all the help by the way.

Hi. I have java and it works fine. I searched for the file “jre-1.6.0_10-fcs” but could not find it. You want to make sure you have the java-1_6_0-sun-plugin package installed from YaST as well as the java-1_6_0-sun package.

Are you using a 64 bit machine, there seems to be problems with that.

Try typing java -version in a terminal, does it show java is installed?

I’m quite sure I have a 64 bit machine.

When i type “java -version” I get

“Java™ SE Runtime Environment (build 1.6.0_07-b06)
Java HotSpot™ Server VM (build 10.0-b23, mixed mode”

Can this help us in some way?

Tanks a bunch for helpin.

64 bit. You need to go here

I had just installed a new version of nspluginwrapper using the terminal and uninstalled an older one using YAST when everything came to a sudden halt. When I tried to reinstall Java; the browser plugin won’t let itself be installed. It sais "uninstallable providers: java-1_6_0-sun-1.6.0.u.7-1.1.i586openSUSE-11.0-Updates] Conflict Resolution:

  • architecture change of java-1_6_0-sun-1.6.0.u7-1.1.i586
  • do not install java-1_6_0-sun-plugin-1.6.0.u7-1.1.i586
  • Ignore some dependencies of java-1_6_0-sun-plugin"

It looks like where on something; what can it be?

Tanks for all the help.

I chosed “* Ignore some dependencies of java-1_6_0-sun-plugin” and now I can’t use the flashplayer either. I can’t even find it in firefox “Edit-preferences-aplications” anymore. What is this!? How do I get out!?

All help is very welcomed and very needed.