JACK audio server / Realtime Kernel / Rosegarden

Hello everyone!

Hope you are all doing well!

A little back story is in order…
Looking for a Open Source music composition editor similar to Sibelius.

I found and settled on Rosegarden.

Sound card is Creative Audigy 2 Platinum EX. I also have a midi keyboard which I would like to use with rosegarden.

After downloading rosegarden, I found out in order to use the MIDI sequencer, I have to compile and install a real time kernel.

I finally got my kernel configured and installed, recompiled all the video/Ethernet drivers etc (after about a dozen tries lol!)

Now on to the issue…

As root, I can run the JACK audio server with realtime priority (as it is needed by Rosegarden) with the command

jackd -R -dalsa &

it starts up and seems to run.

Then as a regular user, I try to connect to the JACK audio server using the qjackctl application. Qjackctl loads, but cannot seem to connect to the jack server, giving me the message “UNABLE TO CONNECT TO SERVER AS CLIENT”

HOWEVER, using the same procedure above as root, I can connect to the jack audio server with qjackctl.

Rosegarden will start as a regular user but will also not connect to the JACK audio server (therefore: no sound or midi sequencer)

Ive tried running Rosegarden as root (I didnt like having to do that), but get a similar error.

Through some googling, I’ve found that JACK clients (qjackctl, rosegarden etc.) must be executed by the same user who launched the JACK server. – no problem…Except I cannot run a realtime application as a regular user.

I read online that regular users can start realtime applications using the LSM module (whatever that is, I couldn’t find all that much).

So my question is, how do I start the jack audio server in realtime mode as a regular user? if that is not possible…Is there a way to configure JACK so that it is started by root, but allows clients launched by regular users to connect?

Sorry for not including the exact error messages as right now I am at work.

Any help/comments would be greatly appreciated! Thanks in advance!

Have you checked out the Jacklab project? They’ve got a bunch of pages on the openSUSE wiki on setting up openSUSE for proaudio work with JACK et al. I’m running it right now and it works great.

You can’t connect to a root JACK server with user apps. I think your problem is that you haven’t edited your pam limits.conf. It’s very simple, and it enables a normal user to run audio apps at high privileges, like root can. This is documented in the wiki.

I’ll post a link later when I get time.

thank you very much for the prompt response! Ill take a look and advise

the file to which you refer is /etc/security/limits.conf?

I was looking at that yesterday but wrote it off…

From what i get from the wiki…all i have to do is add the following lines to limits.conf and then logout/login?

@audio - rtprio 90
@audio - nice 15
@audio - memlock 4000000

zak89 – Thanks for the help, I got it working. Took a little while playing with the jack connections…then i finally got a sound out of rosegarden. looking forward to playing with it more! Thanks again!

Glad you got it working! Sorry I didn’t get back to you, but it sounds like you’ve got it all figured out anyway! :wink:

By the way, did you add your user account to the audio group? That should have been on the same wiki page.

Enjoy the world of linux pro-audio! By the way, if you have questions or problems, stop by the Jacklab forums at forum.jacklab.net. I hang out there pretty regularly, and there’s a whole crew of linux audiophiles there supporting multimedia production on openSUSE.

Have a lot of fun!

I ended up using the @audio group (if it aint broke…dont fix it)

I was up until almost 4 in the morning and the moment I got sound to come out of the d*mned thing I figured i would quit while I was ahead, so I will be diving in tonight to see what it can do.

Thanks for the link to the forum, Im certain Ill be in there checking things out (probably asking questions too)

Can anyone offer some other help pages that I can read? This jacklab.net is now closed.

JackLab has closed

I have similar errors and can not start or connect to JACK via qjackctl.

I also have the same problem. Would be nice if somebody could help.

Have you followed the ways as described here? Configuring pam is a must to use realtime-priorities as a user.

Hi gropiuskalle,
thx for your reply. Yes I followed the instruction and inserted the lines

@audio   -  rtprio     99
@audio   -  memlock    unlimited

and added my user even to the audio group.

The error message is gone but I still have no sound in rosegarden.
And when I start the jack server other apps like amarok can not play sound anymore.

Maybe it has something to do with pulseaudio?

I just tried to play some midi files with tmidity and it works.

But still no sound in rosegarden.
Do I have to configure some special jack connections or some extra settings in rosegarden?

I already read so much documentation for installing jack and rosegarden, this is one of the most complicated stuff I’ve ever done under linux.

Unfortunately I have little experience with Rosegarden; I’d recommend you sign up on the Linux Audio Users mailing list and post your question there; I never was into sequencing and MIDI so I never figured it out.

Linux Audio Users Mailing List

A lot of very smart and helpful folks on that list.