iwl3945 0000:10:00.0: Queue 0 stuck for 2000 ms

Since my upgrade to OpenSuse 12.2 from 11.4 I have been suffering from noticeable network dropouts. The issue “seems” to begin after watching a YouTube video and then continues to return ad-nauseum.

In /var/log/messages, these messages occur every few seconds:

iwl3945 0000:10:00.0: Queue 0 stuck for 2000 ms
iwl3945 0000:10:00.0: On demand firmware reload

There are many references about this issue on the web and none of them really solve the issue for me. So I have decided to return to Kernel 2.6.37 from OpenSuse Repo 11.4. This “appears” to have resolved the issue

Here’s how I did it:-

First I added the 11.4 updates repo to zypper repositories.


sudo zypper ar -f http://download.opensuse.org/update/11.4/ 11.4
sudo zypper refresh

Next I installed the kernel and kernel-desktop-devel for 2.6 (Needed to run virtualbox)


sudo zypper install kernel-devel-2.6.37.6-0.5.1 kernel-desktop-2.6.37.6-0.5.1
sudo ln -sf /usr/src/linux-2.6.37.6-0.5 /usr/src/linux

Note: That will remove the old link to your current kernel source tree.

Now, because I want to boot the 2.6 kernel as default, I use Yast to change the default kernel. Under “Boot loader settings” - “Boot Loader Options” - “Default Boot Section” — Choose your new kernel there.

Reboot the machine and check you are running the 2.6 kernel

uname -a

Next, if you are a Virtualbox user :


sudo /etc/init.d/vboxdrv setup


I guess, that your question is: Does anybody know a real solutionj to the problem?

On 04/07/2013 11:26 AM, hcvv wrote:
>
> I guess, that your question is: Does anybody know a real solutionj to
> the problem?

I would have tried a newer kernel first. There is obviously a problem with that
driver in the 3.1 kernel; however, it would be good to know if it were fixed in
the 3.7 kernel used by openSUSE 12.3, or in the 3.8 kernel in the kernel HEAD repo.

I have been struggling with this for some time now with OpenSuse and also Ubuntu. I have read that it is an issue between the radeon kernel driver with modeset=1 and the iwl3945 driver. I don’t know. BUT… read on …

I was trying Debian Squeeze which runs an old 2.6(?) kernel which seems to not have the issue and…

Debian just released v7 (Wheezy) and I have been running it for a few days now with NO manifestation of the problem. Not once. I can youtube all day it seems.

uname -a gives 3.2.0-4-amd64

So perhaps try the debian wheezy kernel …

Good luck.

I will return to OpenSuse sometime when this issue has gone.

I tried all sorts of kernel versions.

3.2.0.4
3.4.33-2.24
3.4.28-2.20
2.6.37.6-0.5
2.6.34-12

Actually they all seem to have the issue. I thought the lower version had solved it but no… I don’t want to go any older as it would mean an old version of libc. I don’t want to go there. As I just posted. I will stick with Debian Wheezy for a while.

Well I finally managed to track this problem down. Please bear with we a minute because I am about to start with Debian before returning to OpenSuse.

I am using Debian right now, and have not seen the issue for a month. Yesterday I was using Google Earth and saw some corruption in the image in the window. I noticed some weeks ago a message in the boot log that the radeon/R520_cp.bin is not installed. Yesterday I installed the firmware-nonfree (which fixed Google-Earth) and the message is back.

So shortly after I installed radeon/R520_cp.bin (with all the other firmware-nonfree) the error occurs.

The reason I did not install this package before is because I installed the iwl9365 ucode files by hand on system install.

These were the lines in the dmesg file before…

dmesg.0:    5.181766] platform radeon_cp.0: firmware: agent aborted loading radeon/R520_cp.bin (not found?)
dmesg.0:    5.182046] radeon 0000:01:00.0: failed initializing CP (-2).
dmesg.0:    5.182104] radeon 0000:01:00.0: Disabling GPU acceleration

and now…

dmesg:    5.107334] platform radeon_cp.0: firmware: agent loaded radeon/R520_cp.bin into memory
dmesg:    5.107546] [drm] radeon: ring at 0x0000000008001000

So I would expect OpenSuse to the the same.

I will investigate now to find out what this file is.