IWL Driver bug and wifi light

Ok, so this is pathetic. Just installed Opensuse 11 on a Thinkpad R60e. Everything works except for the wifi indicator light which does nothing, no blinks or anything - dead. I had a similar prob with 10.3 (except the problem was a lot more complex and killed the wifi card more often than not), causing me I regret to say to put Kubuntu 7 on the TP, whilst retaining 10.2 on the desktop. But this time wifi works great, except for the light. I know that there are a lot of people experiencing real problems with wifi and are probably thinking -no light, I wish!! - But this is bugging me. Mucho googling has indicated that there is a bug in the IWL drivers, and is not specific to Opensuse (I tried Kubuntu, the light worked in 7, but has also died in 8). The bug was supposed to be specific to kernel 2.6.25 or less(so Mr Google tells me), but I have (i.e. the bog standard off the i386 install DVD). My question is this, does anyone else know of this bug, and a way to fix it. I can live without the light at the moment, but am planning on travelling soon and I know from experience that the little flashing/constant green light is very helpful when trying to access wifi in hotels etc.