iwconfig failed

Hello:

I am trying to configure ad-hoc by command iwconfig:


sudo /usr/sbin/iwconfig wlan0 nwid AB34


but it failed with messages:


Error for wireless request "Set NWID" (8B02) :
    SET failed on device wlan0 ; Operation not supported.


here is the log file for command:



sudo /usr/sbin/iwlist scan


log:


wlan0     Scan completed :
          Cell 01 - Address: 00:27:19:9D:FD:72
                    Channel:5
                    Frequency:2.432 GHz (Channel 5)
                    Quality=32/70  Signal level=-78 dBm  
                    Encryption key:on
                    ESSID:"TP-LINK_9DFD72"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              12 Mb/s; 24 Mb/s; 36 Mb/s
                    Bit Rates:9 Mb/s; 18 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000063f4c82181
                    Extra: Last beacon: 3165ms ago
                    IE: Unknown: 000E54502D4C494E4B5F394446443732
                    IE: Unknown: 010882848B960C183048
                    IE: Unknown: 030105
                    IE: Unknown: 2A0100
                    IE: Unknown: 32041224606C
                    IE: Unknown: DD0900037F01010008FF7F
                    IE: Unknown: DD1A00037F03010000000027199DFD720227199DFD7264002C010808
          Cell 02 - Address: 90:94:E4:CA:94:B4
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=33/70  Signal level=-77 dBm  
                    Encryption key:on
                    ESSID:"THINKPAD yves"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000003b8b0f7176
                    Extra: Last beacon: 2797ms ago
                    IE: Unknown: 000D5448494E4B5041442079766573
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 03010B
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: Unknown: 2D1A6E181EFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D160B070000000000000000000000000000000000000000
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: DD8A0050F204104A0001101044000102103B00010310470010630412531019200612289094E4CA94B41021000E442D4C696E6B2053797374656D73102300084449522D3630354C102400084449522D3630354C1042000D32303037303431332D303030311054000800060050F2040001101100084449522D3630354C1008000226881049000600372A000120
                    IE: Unknown: DD1E00904C336E181EFFFF000000000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C340B070000000000000000000000000000000000000000
                    IE: Unknown: DD0600E04C020160



thank you very much:P

Why do you make your computer copied/pasted text more difficult to post for you and to read for us, by splitting it up in two pieces: the command and the output. Please make one copy/paste of prompt-command-output-next prompt. Thene everybody can see in one view who you were, where you were, what you did and what you got. Thus not:

I did

uname -a

and I got

Linux boven 3.4.47-2.38-desktop #1 SMP PREEMPT Fri May 31 20:17:40 UTC 2013 (3961086) x86_64 x86_64 x86_64 GNU/Linux

but simply

henk@boven:~> uname -a
Linux boven 3.4.47-2.38-desktop #1 SMP PREEMPT Fri May 31 20:17:40 UTC 2013 (3961086) x86_64 x86_64 x86_64 GNU/Linux
henk@boven:~>

all right, here it is


/home/albert% uname -a
Linux dream.future 3.7.10-1.16-desktop #1 SMP PREEMPT Fri May 31 20:21:23 UTC 2013 (97c14ba) x86_64 x86_64 x86_64 GNU/Linux


On 08/07/2013 02:46 AM, albumns wrote:
> I am trying to configure ad-hoc by command iwconfig

can we start this thread over?

-what operating system and version are you using?

-if you use a desktop environment, which and what version?

-what do you mean by “configure ad-hoc”…does that mean
–YaST cannot be used to configure your wireless?
–or, Network Manager is not working?
–or, you are wanting to learn how to configure or modify your
wireless without using either YaST or Network Manager?

-is your wireless hardware 802.11 or pre-802.11?

-how or why did you pick AB34 to be your Network/Domain ID

-what were you trying to accomplish by only setting the ID and none
of the other wireless parameters needing to be set?

sorry, but maybe i just don’t understand what you are trying to do,
so please tell me: Was your wireless working correctly prior to you
attempting to set its Network ID to “AB34”? and, afterwards?

finally…Henk van Velden showed you an example of how to provide
info here… he was not asking you for you to provide the output of
‘uname -a’, instead he was asking you to please show the input, the
output, the beginning prompt and the ending prompt of your two commands:


sudo /usr/sbin/iwconfig wlan0 nwid AB34
sudo /usr/sbin/iwlist scan


dd
http://tinyurl.com/DD-Caveat
http://tinyurl.com/DD-Complaints
http://tinyurl.com/DD-Hardware
http://tinyurl.com/DD-Software

On 08/07/2013 10:06 PM, albumns wrote:
> Code:
> --------------------
> > > henk@boven:~> uname -a
> > Linux boven 3.4.47-2.38-desktop #1 SMP PREEMPT Fri May 31 20:17:40 UTC 2013 (3961086) x86_64 x86_64 x86_64 GNU/Linux
> > henk@boven:~>
> --------------------

As your kernel is 3.4.X, I assume you are using openSUSE 12.2.

Please be aware that not all wireless drivers support ad-hoc mode. As you also
omitted that crucial piece of information, I have no way of telling if you have
such a device.

As the wireless community is now working on code for kernel 3.12, it is possible
that the driver for your device has been fixed to work in ad-hoc mode. If you
add the Packman repo, you could try the compat-wireless package, which may be
known as compat-drivers.

One other possibility is that your driver does not implement the WEXT commands
used by iwconfig, but that setting up ad-hoc mode would work using the
equivalent iw commands.

On 08/08/2013 03:46 PM, Larry Finger wrote:
> As your kernel is 3.4.X, I assume you are using openSUSE 12.2.

that is from Henk’s output, the OP’s is:
“<snip> 3.7.10-1.16-desktop #1 SMP PREEMPT <snip>”


dd