iw package and other problems.


I managed to get recognized my Trendnet TEW-424UB wireless USB adaptor with ndiswrapper.

Now I have the configuration problem.

When I try to do the configuration in Yast, in network devices -> network settings and I save I get a message that I must install the “iw” package.

Because the computer is quite far from wired networks I can’t get it on Internet to download the package automatically.
So, I want to ask if it’s possible to install this package off-line because I can’t find it by searching on OpenSUSE website.

On this computer I use OpenSUSE 11.2 32-bit with KDE.

I put some commands if someone wants to know how I manage to get this USB WiFi adaptor to work (with the Windows XP driver sis163u verison 5.1.1039.1050):

robert@VL420:~> /usr/sbin/ndiswrapper -l

WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.

sis163u : driver installed
        device (0457:0163) present

robert@VL420:~> lsusb

Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 001 Device 002: ID 045e:006a Microsoft Corp. Wireless Optical Mouse (IntelliPoint)

Bus 001 Device 003: ID 0457:0163 Silicon Integrated Systems Corp. 802.11 Wireless LAN Adapter

Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

robert@VL420:~> sudo /usr/sbin/ndiswrapper -m
root's password:
adding "alias wlan0 ndiswrapper" to /etc/modprobe.d/ndiswrapper ...

robert@VL420:~> sudo /sbin/modprobe ndiswrapper [lights go on on the device]

WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.

BTW, why I must give the whole path for all commands? Is there in Linux a command like the MS-DOS “path” to put some default folders?

Those commands are typically used by “root” only and it is not a good idea to put in your PATH. (You might execute some commands by accident and may mess up the whole system).

You can use the su command to become root, execute the needed commands and exit.

Try the following to see the status of your wireless set up:


Thanks syampillaifor your quick answer.

Here there is my network status:

VL420:/home/robert # ifconfig
eth0      Link encap:Ethernet  HWaddr 00:04:23:0C:31:65
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Boucle locale
          inet adr:  Masque:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:74 errors:0 dropped:0 overruns:0 frame:0
          TX packets:74 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:4396 (4.2 Kb)  TX bytes:4396 (4.2 Kb)

VL420:/home/robert # iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11g  ESSID:off/any
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated
          Bit Rate:24 Mb/s   Tx-Power:17 dBm   Sensitivity=0/3
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

I find strange that I must type modprobe ndiswrapper each time I plug the USB Wi-Fi adaptor for the light to turn on.

Anyway, my problem remains: I can’t finish the configuration in YaST because it asks me to install the “iw” package.

I mention that everything is happening on OpenSUSE 11.2 32-bit with KDE

Your wireless lan is not yet associated with any AP. Can you see the status of the knetworkmanager (look in the system tray for this)? If it is not running, you may run it now.

Unfortunately, after I manage to install off-line the iw package I tried to do the configuration in YaST by putting the ndiswrapper service to run at start.

But the whole computer froze and now even after restart the computer freezes just after loading the desktop shortcuts and nothing is working (not even the mouse).

In this moment I try to reinstall the whole OpenSUSE from scratch.

I thought that Linux is more stable than Windows :frowning:

On 02/14/2010 10:36 AM, robertgf wrote:
> I thought that Linux is more stable than Windows :frowning:

You make this comment after installing a Windows driver that destabilizes your

I think this can be a bug, too.
Because the crash happend in YaST, when doing the network configuration. Just during the “configuring the firewall” message in the list. Here there is a link to a picture of the computer screen (well, it’s in French, but “pare-feu” is “firewall”): YaST blocking on Flickr - Photo Sharing!
Each time the computer stopped at that point.
The last time when I put the option for loading ndiswrapper at start-up, the whole computer jammed after restart.
The computer didn’t crash no matter what I did in command-line.
And the card was recognized as hardware.

It’s not a big deal, my new OpenSUSE installation is nearly done.

BTW, in the tutorial Ndiswrapper - openSUSE
the link sending to http://en.opensuse.org/NDISwrapper#Conflicts_with_NetworkManager (about Conflicts_with_NetworkManager) is pointing to an empty page.

And if I follow the tutorial in the chapter Configuring your card in YaST and I keep empty some fields (ESSID for example), I get the messages that those fields mustn’t be left blank.

But maybe that can help someone to see if this is OK, even if the driver is for Windows.

So, I installed again OpenSUSE 11.2 32-bit version.

I configured the wireless router as no encryption and YaST didn’t lock-up the computer during the configuration of the wireless device.
So I assume the computer crushed because of the activation of the WPA2 encryption in YaST.

I can see the wireless signal now, but I can’t connect.

I’ll open a new post with my new problem.

Thanks to syampillai for the hints.