ivtv on OpenSuse 11 - No sound


I’m having a hard time getting ivtv to work with OpenSuse 11. I have a PVR-150 which OpenSuse detected, but had to change some settings in /etc/modprobe.d/tv before the module would load. The second options line was using ‘card’ instead of ‘cardtype’ This is how the file looks now:

alias char-major-81 videodev
options i2c-algo-bit bit_test=1
options ivtv cardtype=3

YaST configured TV card

kYBq.w283SGJ3O+B:Hauppauge WinTV PVR-150 or PVR-500

alias char-major-81-0 ivtv
alias char-major-81-1 off
alias char-major-81-2 off
alias char-major-81-3 off

After this change, the module loads fine and I get video from /dev/video0. But now I have no sound. Other system sounds work fine. Once, I tried the following command:

v4l2-ctl --set-audio-input 0 -d /dev/video0

That gave me audio until I stopped mplayer and tried kdetv (which I’ve since learned doesn’t work with this type of tuner). Re-running the command has not restored audio. Does anyone know how to make this work properly?



Turns out a reboot fixes it every time. I just need to remember not to run kdetv (or xawtv or tvtime).