I've mullered my bootloader

Here is the full output of parted, the Toshiba drive is my USB stick:

Model: ATA Samsung SSD 840 (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system     Flags
 1      1049kB  56.6GB  56.6GB  primary   ntfs            type=07
 2      56.6GB  56.6GB  16.8MB  primary                   hidden, type=1b
 3      56.6GB  58.8GB  2149MB  primary   linux-swap(v1)  type=82
 4      58.8GB  120GB   61.2GB  extended                  boot, lba, type=0f
 5      58.8GB  77.0GB  18.3GB  logical   ext4            type=83
 6      77.0GB  120GB   43.0GB  logical   ext4            type=83

Model: TOSHIBA TransMemory (scsi)
Disk /dev/sdb: 15.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      2187kB  4442MB  4440MB  primary               boot, hidden, type=17

I checked the manual of my netbook (Asus 1015CX) and it doesn’t mention anything about efi.

When you say wipe everything, do you mean I would need to wipe Windows as well?

I think Partition 2 was factory installed for utilities of some sort, or system recovery.
I lost access to it at boot time when I put opensuse on and replaced the original hard disk with an SSD drive.

I don’t know about chroot, will look it up to see if it can help, any advice would be appreciated.

Hi Wild_Goose,

I really took the time to try it out :slight_smile:
I booted my system from an openSUSE 12.2 KDE Live CD -
at those times, i.e. 12.2, the Live system still did fit on a CD - imagine !!

And yes.
After booting from that live CD,
the feedback is just the same:

I get the same responses as in

That already was my guess.

You will have to ‘chroot’,
in order to run YaST from your hard disk partition,
and in order to fix booting issues there.

Search for ‘chroot’ on the WEB and you will find!

I have no practical experience with that,
so I’m not able to help you at that point.

If you don’t like to try it,
a fresh install of openSUSE would indeed be the quickest way to fix things.

Best wishes

Hi, Wild Goose:

Lets see if you can come to the end of your chase… :wink:

This guide I wrote might help:


Make certain, though, that you boot with the openSUSE install or live version that matches your version to do this. That is, if you are installing 13.1, use 13.1; if you are installing 12.3, use 12.3; and so forth.

The “chroot” section is as shown for openSUSE 12.3

But, if you are using 13.1, the “chroot” section changes a bit to the following:

chroot /mnt
mount -t proc proc /proc
mount -t sysfs sysfs /sys

Good luck, let us know how you fare.

HI Mike, thanks for taking the trouble to check that out on your system :slight_smile:

I tried chroot, but unsuccessfully (see below).
In the end I did a reinstall of opensuse 13.1, this time I did not tick the “boot from MBR”
and “boot from root partition” options.

When I first installed I ticked both those options, as I was thinking “how else is it going to boot?!”

  • but maybe you don’t have to check those options to get a booting system? I don’t know.

Anyway my system is now dual booting again, but I don’t know if the underlying issue has been solved,
i.e. if I changed boot settings in yast again would grub2 fall over again?
Maybe best to leave it alone now.

By the way, my partition table still looks the same.

Thanks for that Fraser, I ended up doing a reinstall before I saw your post.

I tried chroot after booting into rescue mode off the USB DVD iso,
and it said that sys and proc were not mounted, and I needed to bind-mount them,
which I didn’t really understand so I gave up at that point and did a reinstall.

But now I know how to sort that out for future reference, thanks.

You don’t check them if instilling on an EFI unless you are doing a legacy install. Note not all EFI BIOS’s properly support legacy installs . >:(

If installing in a older machine with an older BIOS you would need to deal with MBR. BUT EFI is different

Hi Wild_Goose,

I’m surprised !
Look at your original/first post in this thread:

There you did not mention that you ticked the “boot from MBR” and the “boot from root partition” options.

I don’t know what the effect may be, if you ticked both of that options at the same time.

Good to hear that :wink:

Yes, leave it alone seems to be a very good approach ;):wink:

Otherwise you would at least have to save your GRUB configuration file, before you change anything,
which for legacy GRUB is /boot/grub/menu.lst,
and for GRUB2 seems to be /boot/grub/grub.cfg
(I don’t have GRUB2, and I thus don’t have experience with it)

Good luck

And in addition you would have to save your MBR before checking ‘boot from MBR’.

Otherwise your original MBR is lost.