I've just installed Leap 15 on an old HP Compaq 6910p. Need help with getting the wireless working.

Hi folks. Just got Leap on my old HP laptop, but I don’t remember what it is that I need to do to get the wireless internet working. I seem to remember it being something to do with Broadcom being a bit weird about the firmware for the card.

lspci has it listed as

10:00.0 Network Controller: Broadcom Limited BCM4311 802.11a/b/g (rev 02)

The Ethernet port works well enough, but I really need the wireless to work and I can’t remember how to get it going again. Anyone got any suggestions?

I don’t know the specifics of what applies to your hardware.

One option is to install broadcom-wl from packman.

Then there’s “b43-fwcutter” which extracts firmware from Windows drivers. And there a few others, if you put “broadcom” in the search box of Yast Software Management. You need to have the packman repo configured and enabled to find all of them.

I have an older laptop with broadcom wifi – around 2009 vintage. I have not needed to do anything special to get it working in recent years. I did need “broadcom-wl” when I first got that laptop.

Been awhile since anyone posted about trying to support the BR 4311 chipset… nrickert described a few procedures that were required long ago.

Looking for more up to date info,
Found what might be relevant to your case today,
Besides installing the bcm43xx-firmware package from Packman as nrickert says, you may need to blacklist legacy drivers (or, maybe just not installing the legacy firmware from Packman might be sufficient)
https://wiki.archlinux.org/index.php/Broadcom_wireless#b43

HTH,
TSU

Or this one from the wirelss section:
https://forums.opensuse.org/showthread.php/484106-Broadcom-firmware-is-needed-for-b43-but-I-have-no-network-an-easierwork-around

But I would use broadcom and broadcom-wl from Pckman.

But first update your system, get the Packman Repo and install both packages.

To the OP,

The Wireless section of these forums look to me as being more specific then a more general Network/Internet. And indeed it has a few important stickies at the top, that are worthwhile to read (and to act on) before posting a question about a non-functioning Wifi.
And of course, the chance that the wireless gurus are lurking there is larger then here.

Apologies for posting in the wrong section, Henk. After I read Tsu’s comments about blacklisting certain modules, it jogged my memory about what I did to get the wireless working under OpenSUSE 13.1 and I found the old thread about asking for help in that case (https://forums.opensuse.org/showthread.php/499411-Wureless-card-stopped-working-after-Network-Install-of-Suse-13-1-x86). It essentially boiled down to blacklisting some firmware modules with

echo "blacklist b43" > /etc/modprobe.d/50-b43.conf
echo "blacklist ssb" >> /etc/modprobe.d/50-b43.conf

rebooting, and then just running

/usr/sbin/install_bcm43xx_firmware

and rebooting again.

So I tried to do this again under the current installation, but the /usr/sbin/install_bcm43xx_firmware command complains that there’s a problem with one of the files it downloads (last couple of lines from the following output)

Downloading b43 firmware
Extracting b43 firmware
This file is recognised as:
  filename   :  wl_apsta.o
  version    :  784.2
  MD5        :  29c8a47094fbae342902d84881a465ff
Extracting b43/lcn1bsinitvals26.fw
Extracting b43/n0bsinitvals22.fw
Extracting b43/lcn0bsinitvals26.fw
Extracting b43/ac1bsinitvals42.fw
Extracting b43/ucode24_lcn.fw
Extracting b43/ht0bsinitvals26.fw
Extracting b43/ucode24_mimo.fw
Extracting b43/n20initvals36.fw
Extracting b43/ucode15.fw
Extracting b43/b0g0bsinitvals9.fw
Extracting b43/lcn405initvals35.fw
Extracting b43/ac1initvals42.fw
Extracting b43/lp0bsinitvals13.fw
Extracting b43/b0g0bsinitvals5.fw
Extracting b43/ucode43.fw
Extracting b43/lp0initvals16.fw
Extracting b43/lp1bsinitvals20.fw
Extracting b43/lcn1initvals25.fw
Extracting b43/b0g0initvals13.fw
Extracting b43/lcn402initvals33.fw
Extracting b43/sslpn3bsinitvals21.fw
Extracting b43/ht0initvals29.fw
Extracting b43/n2bsinitvals19.fw
Extracting b43/sslpn1bsinitvals20.fw
Extracting b43/ucode25_lcn.fw
Extracting b43/lcn0initvals24.fw
Extracting b43/lcn404initvals33.fw
Extracting b43/sslpn1bsinitvals27.fw
Extracting b43/lcn404bsinitvals33.fw
Extracting b43/ucode22_sslpn.fw
Extracting b43/lcn1bsinitvals25.fw
Extracting b43/lcn406initvals37.fw
Extracting b43/ac3initvals43.fw
Extracting b43/lcn2initvals26.fw
Extracting b43/ucode20_sslpn.fw
Extracting b43/lcn403bsinitvals33.fw
Extracting b43/a0g0bsinitvals9.fw
Extracting b43/n0initvals17.fw
Extracting b43/ht0bsinitvals29.fw
Extracting b43/ucode21_sslpn.fw
  ucode time:     21:35:19
Extracting b43/sslpn1initvals20.fw
Extracting b43/sslpn0initvals16.fw
Extracting b43/lcn0initvals26.fw
Extracting b43/ucode27_sslpn.fw
Extracting b43/ucode29_mimo.fw
Extracting b43/ucode21_sslpn_nobt.fw
  ucode time:     21:35:19
Extracting b43/lp0initvals15.fw
Extracting b43/ucode19_sslpn.fw
Extracting b43/lcn1bsinitvals24.fw
Extracting b43/lcn401bsinitvals33.fw
Extracting b43/lp0bsinitvals14.fw
Extracting b43/ucode16_sslpn_nobt.fw
  ucode date:     2012-08-15
Extracting b43/n16bsinitvals30.fw
Extracting b43/a0g1bsinitvals13.fw
Extracting b43/lcn402bsinitvals33.fw
Extracting b43/ucode19_sslpn_nobt.fw
Extracting b43/ucode40.fw
Extracting b43/lcn1initvals24.fw
Extracting b43/sslpn2initvals19.fw
Extracting b43/ac2initvals41.fw
Extracting b43/n16initvals30.fw
Extracting b43/ucode16_lp.fw
Extracting b43/n0initvals22.fw
Extracting b43/sslpn3initvals21.fw
Extracting b43/lp1initvals22.fw
Extracting b43/ac2bsinitvals41.fw
Extracting b43/a0g1bsinitvals9.fw
Extracting b43/n0bsinitvals11.fw
Extracting b43/a0g1bsinitvals5.fw
Extracting b43/lcn2bsinitvals26.fw
Extracting b43/ucode34_mimo.fw
Extracting b43/n1initvals20.fw
Extracting b43/lcn2initvals25.fw
Extracting b43/ucode37_lcn40.fw
Extracting b43/n0initvals16.fw
Extracting b43/n0bsinitvals24.fw
Extracting b43/n1bsinitvals20.fw
Extracting b43/b0g0initvals5.fw
Extracting b43/b0g0initvals9.fw
Extracting b43/lcn0bsinitvals24.fw
Extracting b43/lcn2bsinitvals25.fw
Extracting b43/sslpn4bsinitvals22.fw
Extracting b43/ucode11.fw
Extracting b43/n2initvals19.fw
Extracting b43/pcm4.fw
Extracting b43/ucode13.fw
Extracting b43/lcn0initvals25.fw
Extracting b43/sslpn1initvals27.fw
Extracting b43/lp0bsinitvals15.fw
Extracting b43/lp0initvals14.fw
Extracting b43/lp1bsinitvals22.fw
Extracting b43/n18initvals32.fw
Extracting b43/lcn405bsinitvals35.fw
Extracting b43/ucode41.fw
Extracting b43/lcn400initvals33.fw
Extracting b43/sslpn0bsinitvals16.fw
Extracting b43/lcn401initvals33.fw
Extracting b43/ucode33_lcn40.fw
Extracting b43/a0g1initvals9.fw
Extracting b43/ucode32_mimo.fw
Extracting b43/lcn400bsinitvals33.fw
Extracting b43/lcn404bsinitvals35.fw
Extracting b43/n19initvals34.fw
Extracting b43/ac3bsinitvals43.fw
Extracting b43/n0initvals25.fw
Extracting b43/ucode26_mimo.fw
Extracting b43/n0bsinitvals16.fw
Extracting b43/lcn404initvals35.fw
Extracting b43/lp2bsinitvals19.fw
Extracting b43/n19bsinitvals34.fw
Extracting b43/ucode20_sslpn_nobt.fw
Extracting b43/ac0bsinitvals40.fw
Extracting b43/lcn2initvals24.fw
Extracting b43/sslpn4initvals22.fw
Extracting b43/sslpn2bsinitvals19.fw
Extracting b43/n0bsinitvals25.fw
Extracting b43/lp2initvals19.fw
Extracting b43/n18bsinitvals32.fw
Extracting b43/lcn0bsinitvals25.fw
Extracting b43/n0initvals11.fw
Extracting b43/lcn2bsinitvals24.fw
Extracting b43/n0absinitvals11.fw
Extracting b43/a0g0initvals5.fw
Extracting b43/a0g1initvals13.fw
Extracting b43/pcm5.fw
Extracting b43/ucode35_lcn40.fw
Extracting b43/ucode14.fw
Extracting b43/ucode36_mimo.fw
Extracting b43/a0g0initvals9.fw
Extracting b43/ucode17_mimo.fw
Extracting b43/lp0initvals13.fw
Extracting b43/ucode25_mimo.fw
Extracting b43/lp0bsinitvals16.fw
Extracting b43/lcn406bsinitvals37.fw
Extracting b43/ac0initvals40.fw
Extracting b43/ucode30_mimo.fw
Extracting b43/b0g0bsinitvals13.fw
Extracting b43/n20bsinitvals36.fw
Extracting b43/ucode42.fw
Extracting b43/lcn407initvals38.fw
Extracting b43/lcn1initvals26.fw
Extracting b43/ht0initvals26.fw
Extracting b43/ucode38_lcn40.fw
Extracting b43/lcn407bsinitvals38.fw
Extracting b43/lcn403initvals33.fw
Extracting b43/ucode16_sslpn.fw
Extracting b43/ucode16_mimo.fw
Extracting b43/n0bsinitvals17.fw
Extracting b43/a0g1initvals5.fw
Extracting b43/n0initvals24.fw
Extracting b43/lp1initvals20.fw
Extracting b43/a0g0bsinitvals5.fw
Extracting b43/ucode9.fw
Extracting b43/ucode5.fw
Extracting b43/ucode22_mimo.fw

Downloading b43legacy firmware
Extracting b43legacy firmware
Sorry, the input file is either wrong or not supported by b43-fwcutter.
This file has an unknown MD5sum 988af504ba29e87d3682c27169835292.

b43 firmware successfully installed.
b43legacy firmware successfully installed.

So after that, I tried the offline installer from the thread that Henk suggested. The offline installer ran without a hitch, so I’m guessing that the /usr/sbin/install_bcm43xx_firmware has a bug in it. Unfortunately, I still don’t have any wireless connectivity. I tried entering my wireless network details manually (because there did not appear to be any way to scan for them) but to no avail. I guess I’ll have a rummage through some of the other threads Henk suggested and, failing that, I’ll try the Packman method.

  1. Is the appropriate driver loaded now?
/usr/sbin/hwinfo --netcard
  1. Wireless network device node present?
ip a
  1. Is the wifi disabled?
/usr/sbin/rfkill list

*You may need to install the rfkill package first.

If it is only soft-blocked, then it can be enabled with

sudo /usr/sbin/rfkill unblock wifi

If hard-blocked, then check the appropriate switch, button, or key combo to turn on.

/usr/sbin/hwinfo --netcard

says

Driver Status: ssb is not active

I guess that’s to be expected given that I’ve blacklisted that module, but I’d have expected it to just load whatever it did when I had 43.1 installed. Could this be caused by a change to the

/usr/sbin/install_bcm43xx_firmware

script that might not include whatever the previous installation loaded?

Can you remove blacklist again? What happens if you try to load the driver manually like this?

sudo modprobe b43

Do you get wlan0 present?

ip a

If not, then capture what is reported by the following…

dmesg|egrep "b43|firmware"

Well that was unexpected. All I did was undo the blacklisting with

mv /etc/modprobe.d/50-b43.conf /etc/modprobe.d/50-b43.conf.old

and then rebooted to make the change take effect, and the Wi-Fi connection was established as soon as I reached the desktop.

If I’m reading the output from /usr/sbin/hwinfo --netcard correctly (pasted below), it’s saying that the driver in use is: “b43-pci-bridge”. Is this driver okay to use, or is it likely to cause some kind of problem in the future?

linux-u3d1:~ # /usr/sbin/hwinfo --netcard
08: PCI 19.0: 0200 Ethernet controller                          
  [Created at pci.378]
  Unique ID: rBUF.5g8e3y9cDQ8
  SysFS ID: /devices/pci0000:00/0000:00:19.0
  SysFS BusID: 0000:00:19.0
  Hardware Class: network
  Model: "Hewlett-Packard Company Compaq 6910p"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x1049 "82566MM Gigabit Network Connection"
  SubVendor: pci 0x103c "Hewlett-Packard Company"
  SubDevice: pci 0x30c1 "Compaq 6910p"
  Revision: 0x03
  Driver: "e1000e"
  Driver Modules: "e1000e"
  Device File: eth0
  Memory Range: 0xd8500000-0xd851ffff (rw,non-prefetchable)
  Memory Range: 0xd8520000-0xd8520fff (rw,non-prefetchable)
  I/O Ports: 0x5000-0x501f (rw)
  IRQ: 28 (1446 events)
  HW Address: 00:1b:38:e6:4e:8e
  Permanent HW Address: 00:1b:38:e6:4e:8e
  Link detected: no
  Module Alias: "pci:v00008086d00001049sv0000103Csd000030C1bc02sc00i00"
  Driver Info #0:
    Driver Status: e1000e is active
    Driver Activation Cmd: "modprobe e1000e"
  Config Status: cfg=no, avail=yes, need=no, active=unknown

18: PCI 1000.0: 0282 WLAN controller
  [Created at pci.378]
  Unique ID: y9sn.NWTqOKo4_vC
  Parent ID: qTvu.TNTLQA7QFE2
  SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:10:00.0
  SysFS BusID: 0000:10:00.0
  Hardware Class: network
  Model: "Hewlett-Packard Company Broadcom 802.11a/b/g WLAN"
  Vendor: pci 0x14e4 "Broadcom"
  Device: pci 0x4312 "BCM4311 802.11a/b/g"
  SubVendor: pci 0x103c "Hewlett-Packard Company"                                                                                                                                  
  SubDevice: pci 0x1371 "Broadcom 802.11a/b/g WLAN"                                                                                                                                
  Revision: 0x02                                                                                                                                                                   
  Driver: "b43-pci-bridge"                                                                                                                                                         
  Driver Modules: "ssb"                                                                                                                                                            
  Device File: wlan0                                                                                                                                                               
  Features: WLAN                                                                                                                                                                   
  Memory Range: 0xd8000000-0xd8003fff (rw,non-prefetchable)                                                                                                                        
  IRQ: 17 (32022 events)
  HW Address: 00:1a:73:dc:3d:d9
  Permanent HW Address: 00:1a:73:dc:3d:d9
  Link detected: yes
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "pci:v000014E4d00004312sv0000103Csd00001371bc02sc80i00"
  Driver Info #0:
    Driver Status: ssb is active
    Driver Activation Cmd: "modprobe ssb"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #11 (PCI bridge)

Oh and ip a says

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: irda0: <NOARP> mtu 2048 qdisc noop state DOWN group default qlen 8
    link/irda 00:00:00:00 brd ff:ff:ff:ff
3: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 00:1b:38:e6:4e:8e brd ff:ff:ff:ff:ff:ff
4: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:1a:73:dc:3d:d9 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.136/24 brd 192.168.1.255 scope global noprefixroute dynamic wlan0
       valid_lft 81531sec preferred_lft 81531sec
    inet6 fd1d:24cd:3ade:0:4463:44de:c18e:61fa/64 scope global temporary dynamic 
       valid_lft 6913sec preferred_lft 3313sec
    inet6 fd1d:24cd:3ade:0:ed70:4185:cb3:c6e6/64 scope global mngtmpaddr noprefixroute dynamic 
       valid_lft 6913sec preferred_lft 3313sec
    inet6 fe80::f20f:3635:fe93:7c0f/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

No, that is as expected (which is why I asked you do remove the blacklisting.) Running the following will show you the relevant loaded modules…

lsmod |grep b43

If I’m reading the output from /usr/sbin/hwinfo --netcard correctly (pasted below), it’s saying that the driver in use is: “b43-pci-bridge”. Is this driver okay to use, or is it likely to cause some kind of problem in the future?

It’s all as it should be for your hardware.

Good to read that it’s working now. :slight_smile:

Oh I just meant I found it to be unexpected because, back when I was trying to get Wi-Fi going on 42.1, I remember getting the impression that the blacklisted modules were the cause of the problem. Thanks for the help, though.