Its all good

Hi all. Just want to yell out that I have installed opensuse 11.2 without a single problem. It was an awesome experience. I tried earlier versions of opensuse (2-3 years ago on same machine) but I gave it up after numerous issues. My machine is very old - P4 3GHz, 1G RAM, ATI Radeon 7500, mix of IDE/SATA HDDs & a few PCI addon cards. Thanks opensuse!!

You said you have an ATI 7500. Before running an open GL screensaver with that card, I would advise you to read the problem described here :
All filesystems vanish (look empty) afer a while. - openSUSE Forums

This pretty nasty bug of the radeon driver affects ATI 7500 cards (unfortunately only under openSUSE! - Ubuntu and Mandriva don’t have this issue.)

Thanks for the tip. Fortunately I am not a fan of screen savers.

It is open GL related (Not limited to screen savers)and it did hit Debian too. It appears it a a combination of bugs in Mesa and a newer Kernel. AFAIK only on the ATI 7500

Mine is actually HIS Excalibur ATI RADEON 7500LE, a (cheaper) variant of Radeon 7500LE but still classed as RV200. It is a fairly robust oldish dual-head card with DVI. Flawless under WinXP. I wonder why Ubuntu don’t have same issues with this card. Sorry, I know very little about Linux & ignorant of many things Linux.

Right, it affects Debian too, but not Ubuntu and Mandriva. I can confirm that since I have Ubuntu and Mandriva too on this machine, both running xscreensaver and openGL after 10 minutes.
At least, you’re aware at the risk of running openSUSE 11.2 with this graphic card in this situation. The other options are:

  • waiting until it get fixed
  • compiling the kernel and the radeon driver yourself (?)
  • using openSUSE 11.1
  • replacing the graphic card.

Otherwise I’m afraid you’re going to start an openGL application sooner or later and run into trouble. >:(

While tracking the problem, I first reinstalled openSUSE 11.1, then I put a Nvidia MS 4000 in this computer (fortunately I had one left in a drawer).

Yes I know, I should raise a bug report :shame:

Says here 11.2 should work on RV200 - Radeon - openSUSE
BTW, did it stuffed your entire HDD or just the partition opensuse is installed in?

They were not aware of the bug by the time this page was written.

BTW, did it stuffed your entire HDD or just the partition opensuse is installed in?

It affected (at least) all partitions set to be automatically mounted in /etc/fstab. One time it didn’t affect the root partition, which allowed me to run “df” and get that crazy “16TB” output, which finally led to the explanation.

If you want to test, first unmount as many partitions as possible (like the /home partition if you happen to have one), become root and run an openGL program, open a terminal and type “ls”. Be aware of the risk and prepared to reinstall in the worst case. If you don’t see any content, reboot immediately. You’ll probably have to do a hard reset, since “shutdown” won’t be found and SysReq key might not work. With some luck, mots filesystems will still be untouched or easy to repare. If you’re hit by the bug, it will reproduce every time you run openGL.

This problem seems kernel version sensitive. I think the version installed from the normal install should be ok. Just do not upgrade the kernel until they get this fixed.

If that case, reinstall and DO NOT update when the setup asks you if you want to do so, or you will end up with the latest kernel.

Hey thanks. Don’t think I want to risk HDD corruption. Do you think Ubuntu is free from this bug?

I think someone did confirm this already.

****…already did the patch updates last night. I am worried now. I dare not test it. Maybe Ubuntu?

It is possible to roll back you know

any problems with changing drivers until the issue is fixed?

Firstly do you actually have the problem?

This is quite a strange one, and for how common the r100/r200 if this was a common problem I would expect a lot more people encountering it.

Any way I added a bit more to All filesystems vanish (look empty) afer a while. - openSUSE Forums

Hmm … If I correctly remember, there was an ‘ati’ driver used with models previous to radeon. I think that it could support the ATI 7500. Not sure but I guess I already used it years ago.

Any idea if Mandriva suffers from the same bugs?

This appears to be a kernel version Mesa version problem that seems to effect only one chip set. Unfortunately it is yours. This could happen to any distro. BTW Mesa is the package that does 3D stuff in OpenGL which I believe most if not all ditro’s use to do 3D.

If this was wide spread we see a lot more reports. So it may only effect a subset of 7500 chip video. Maybe only one broad manufacturer??? But that is pure speculation.

If I were you I’d simply reinstall or rollbak to the previous kernel go into Yast and mark the kernel to not update. Wait a while and see if the problem gets fixed before updateing to a newer kernel.If you reinstall just set the home partition not to format mount as /home and all partitions are correct before continuing. That will save any personal data and settings you have made to date.

Would be great if you can tell me which kernel to unmark in Yast? There are so many marked for update!