It sometimes takes longer for my opensuse to start up

It sometimes takes longer for my opensuse to start up. (since a few weeks)
When I then hit the escape key, I see openSUSE checking the file system.

There are 3 harddisk in my pc, how do I find out what the problem is.

The openSUSE I use to type this, uses brtfs.

I wonder if it is related to this:

Please show here input/output from:

systemd-analyze critical chain

The command is missing an - between critical and chain, :slight_smile:

graphical.target @2min 21.121s
└─display-manager.service @2min 20.532s +588ms
 └─systemd-user-sessions.service @2min 20.521s +9ms
   └─remote-fs.target @2min 20.520s
     └─iscsi.service @2min 20.495s +24ms
       └─network-online.target @2min 20.456s
         └─NetworkManager-wait-online.service @2min 16.528s +3.927s
           └─NetworkManager.service @2min 16.148s +349ms
             └─network-pre.target @2min 16.118s
               └─firewalld.service @2min 15.841s +276ms
                 └─polkit.service @2min 15.737s +101ms
                   └─basic.target @2min 15.723s
                     └─sockets.target @2min 15.722s
                       └─virtlogd-admin.socket @2min 21.961s
                         └─virtlogd.socket @2min 15.721s
                           └─sysinit.target @2min 15.717s
                             └─auditd.service @2min 15.670s +47ms
                               └─systemd-tmpfiles-setup.service @2min 15.624s +43ms
                                 └─local-fs.target @2min 15.586s
                                   └─home-guus-leaphome.mount @2min 15.395s +189ms
                                     └─systemd-fsck@dev-disk-by\x2duuid-64d5c6b8\x2d8098\x2d497b\x2db56a\x2dbeb464958102.service @1.263s +353ms
                                       └─dev-disk-by\x2duuid-64d5c6b8\x2d8098\x2d497b\x2db56a\x2dbeb464958102.device @584542y 2w 2d 20h 1min 49.263s +1.540s

Sorry for the typo. :stuck_out_tongue:

Here’s the culprit:

└─home-guus-leaphome.mount @2min 15.395s +189ms
  └─systemd-fsck@dev-disk-by\x2duuid-64d5c6b8\x2d8098\x2d497b\x2db56a\x2dbeb464958102.service @1.263s +353ms

home-guus-leaphome.mount checking took more than 2m 14s to complete following the previous service in the chain. Please show /etc/fstab’s guus-leaphome line. Odds are you can avoid the delay by adding option nofail to its line, but that would probably be a mere workaround, not an actual fix for the long checking time.

2 Likes

My work laptop using tumbleweed plasma 6, with an i7, 12gb ram takes 1:30 min. when pressing power button until login screen, and when I log-in it takes the same amount of time to get to the desktop, although I’m using a 1tb 5400 rpm hdd, maybe that’s the culprit here, LOL!

1 Like

Hmm leap home, could it be that this harddisk is dying ?

There are 3 physical hard disk.

One for Tumbleweed, a solid state, then two older ones not solid state, one for leap one for windows.

Fstab:

UUID=9c8140f9-0b81-41eb-ab94-d7342c38d218  /                       btrfs  defaults                      0  0
UUID=9c8140f9-0b81-41eb-ab94-d7342c38d218  /var                    btrfs  subvol=/@/var                 0  0
UUID=9c8140f9-0b81-41eb-ab94-d7342c38d218  /usr/local              btrfs  subvol=/@/usr/local           0  0
UUID=9c8140f9-0b81-41eb-ab94-d7342c38d218  /srv                    btrfs  subvol=/@/srv                 0  0
UUID=9c8140f9-0b81-41eb-ab94-d7342c38d218  /root                   btrfs  subvol=/@/root                0  0
UUID=9c8140f9-0b81-41eb-ab94-d7342c38d218  /opt                    btrfs  subvol=/@/opt                 0  0
UUID=9c8140f9-0b81-41eb-ab94-d7342c38d218  /home                   btrfs  subvol=/@/home                0  0
UUID=9c8140f9-0b81-41eb-ab94-d7342c38d218  /boot/grub2/x86_64-efi  btrfs  subvol=/@/boot/grub2/x86_64-efi  0  0
UUID=9c8140f9-0b81-41eb-ab94-d7342c38d218  /boot/grub2/i386-pc     btrfs  subvol=/@/boot/grub2/i386-pc  0  0
UUID=9c8140f9-0b81-41eb-ab94-d7342c38d218  /.snapshots             btrfs  subvol=/@/.snapshots          0  0
UUID=3AB8-553F                             /boot/efi               vfat   utf8                          0  2
UUID=b9cf1de0-e38d-46a4-ba88-08665ca8d340  /home/guus/VMmount      ext4   data=ordered                  0  2
UUID=64d5c6b8-8098-497b-b56a-beb464958102  /home/guus/leaphome     ext4   defaults                      1  2


(Leap is only there as Linux back up os, for when Tumble weed would fail.
I, knock on wood, never had to use it, but remember Installing it, and check if it would boot)

For just this one (leaphome) entry, change
ext4 defaults 1 2
to
ext4 nofail 0 0

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.