It all started with Kbluetooth...

I recently decided I wanted to get my bluetooth mouse and keyboard setup on my suse 11.2 install. Initially I plugged in the usb blue tooth transmitter and tried to connect the keyboard/mouse but to no avail so I found Kbluetooth ( version 0.4.2-24.15 ) and installed using the package manager. While installing, it gave me a message about needing to install some dependencies so I let it go ahead and install. After everything finished up I closed out and noticed my desktop was in shambles by this I mean some icons such as the icon for the 4 different workspaces is hanging from the top of the screen but begins on the bottom it takes up about a quarter of the screen. The same issue is true for a lot of other icons and my taskbar is along the top and in no particular order… I can give a screen shot if necessary. Everytime I close Dolphin or Yast or any application I’m getting crash messages and error dialog. I was sifting through some of the traceback info and it seems there is an issue with the wrong versions being installed. A line that led me to believe this

KSycocaPrivate::checkVersion: Found version 143 , expecting version 162 or higher. 

I’m not sure how to handle this sort of situation. I would appreciate any advice and thank you all in advance for any help.

Know where you go the package. Let use see the output of

zypper lr -d

#  | Alias                                 | Name                                  | Enabled | Refresh | Priority | Type   | URI                                                                                   | Service
1  | KDE:KDE4:UNSTABLE:Desktop             | KDE:KDE4:UNSTABLE:Desktop             | Yes     | Yes     |   99     | rpm-md | |
2  | KDE:Qt46                              | KDE:Qt46                              | Yes     | Yes     |   99     | rpm-md |                    |
3  | Packman_                              | Packman                               | Yes     | Yes     |   99     | rpm-md |                                        |
4  | VideoLan_VLC                          | VideoLan VLC                          | No      | Yes     |   99     | rpm-md |                                       |
5  | | | No      | Yes     |   99     | rpm-md |                                                 |
6  | openSUSE 11.2-0                       | openSUSE 11.2-0                       | No      | No      |   99     | yast2  | cd:///                                                                                |
7  | repo-debug                            | openSUSE-11.2-Debug                   | No      | Yes     |   99     | NONE   |                        |
8  | repo-non-oss                          | openSUSE-11.2-Non-Oss                 | Yes     | Yes     |   99     | yast2  |                          |
9  | repo-oss                              | openSUSE-11.2-Oss                     | Yes     | Yes     |   99     | yast2  |                              |
10 | repo-source                           | openSUSE-11.2-Source                  | No      | Yes     |   99     | NONE   |                       |
11 | repo-update                           | openSUSE-11.2-Update                  | Yes     | Yes     |   99     | rpm-md |   

kde unstable is a wild move. Did you do that intentionally?

lol! No I was under the impression that I was installing the Kbluetooth application. I saw that also and was looking into the best way to basically revert back to what was previously installed.

You should remove repo 1 and 2
su - terminal

In this order.

zypper rr 2
zypper rr 1

Then do

zypper dup

Thank you caf! My desktop looks normal again :slight_smile:

That’s a relief.

I must adjust my previous statement… It’s almost back to normal. It seems when I open my ff the top of the screen is missing the minimize, resize, and close buttons. Also there isn’t a firefox bar on the lower panel. Any ideas?

Try pressing F11
Does that change anything

Well it does change things but doesn’t correct them. It is a display issue with KDE because it isn’t only firefox I’ve discovered. Okular and Dolphin are both having the same issues.

Try checking the window manager and if necessary switching it to kde’s default ‘kwin’
System settings - General Tab
Default Applications

Window Manager - is it set to KWin?

logout and back in if you change it

If I try opening Yast the password box pops up but when I type my password the corresponding '* ’ s don’t show up in the password field. Also if I click on the kickoff button in the bottom right it appears but I can’t click on anything because it still thinks I’m in the firefox window so the launcher shows up but it is just transposed over my firefox screen. This is leading me to believe I need to install or reinstall a KDE package.

Also I just noticed that when I open up a shell to try and do anything from command line I can’t type in that either.

Please try re-booting

If it remains we should try creating a new user account. But try the above first.

Well caf once again you are a genius. Rebooting seems to have fixed it, I should’ve thought of that myself I apologize for having wasted your time. The thing that threw me was that all of the issues I was having started right when I turned on my computer I hadn’t installed or removed anything so I never considered rebooting. Guess this will teach me to never over look the power of a reboot. :slight_smile:

Thanks again for your time and help Caf.

No problem my friend - Happy to help;)