Issues with WPA Enterprise + NetworkManager

Hi everyone.

I’m having trouble to connect to the wireless network at my university.

It uses WPA Enterprise with PEAP authentication, TKIP encryption and a CA-certificate.

This is what I enter in KNetworkManager:
Security: WPA Enterprise
EAP method: PEAP
Identity: my username
Password: my password
CA-certificate: /etc/ssl/certs/cacert.pem (I copied it there, downloaded from the university’s homepage, I also got 3 other certs with the suffixes .crt, .cer and .der)
Phase 2 method: MSCHAPv2

When I try to connect to the network the symbol in the systray starts working and ends up with a gray globe saying not connected. Here is what the NetworkManager logfile says:

Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0) starting connection ‘eduroam’
Jan 14 09:54:16 linux-im9r NetworkManager: <info> (wlan0): device state change: 3 → 4
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled…
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started…
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled…
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting…
Jan 14 09:54:16 linux-im9r NetworkManager: <info> (wlan0): device state change: 4 → 5
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0/wireless): access point ‘eduroam’ has security, but secrets are required.
Jan 14 09:54:16 linux-im9r NetworkManager: <info> (wlan0): device state change: 5 → 6
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled…
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started…
Jan 14 09:54:16 linux-im9r NetworkManager: <info> (wlan0): device state change: 6 → 4
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled…
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting…
Jan 14 09:54:16 linux-im9r NetworkManager: <info> (wlan0): device state change: 4 → 5
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0/wireless): connection ‘eduroam’ has security, and secrets exist. No new secrets needed.
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added ‘ssid’ value ‘eduroam’
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added ‘scan_ssid’ value ‘1’
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added ‘key_mgmt’ value ‘WPA-EAP’
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added ‘pairwise’ value ‘TKIP CCMP’
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added ‘group’ value ‘TKIP CCMP’
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added ‘password’ value ‘<omitted>’
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added ‘eap’ value ‘PEAP’
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added ‘fragment_size’ value ‘1300’
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added ‘phase2’ value ‘auth=MSCHAPV2’
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added ‘identity’ value ‘<my identity>’
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added ‘ca_path’ value ‘/etc/ssl/certs’
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: set interface ap_scan to 1
Jan 14 09:54:16 linux-im9r NetworkManager: <info> (wlan0): supplicant connection state: disconnected → scanning
Jan 14 09:54:16 linux-im9r NetworkManager: <info> (wlan0): supplicant connection state: scanning → disconnected
Jan 14 09:54:31 linux-im9r NetworkManager: <info> wlan0: link timed out.
Jan 14 09:54:41 linux-im9r NetworkManager: <info> Activation (wlan0/wireless): association took too long.
Jan 14 09:54:41 linux-im9r NetworkManager: <info> (wlan0): device state change: 5 → 6
Jan 14 09:54:41 linux-im9r NetworkManager: <info> Activation (wlan0/wireless): asking for new secrets
Jan 14 09:54:41 linux-im9r NetworkManager: <WARN> get_secrets_cb(): Couldn’t get connection secrets: Requested setting is empty.
Jan 14 09:54:41 linux-im9r NetworkManager: <info> (wlan0): device state change: 6 → 9
Jan 14 09:54:41 linux-im9r NetworkManager: <info> Activation (wlan0) failed for access point (eduroam)
Jan 14 09:54:41 linux-im9r NetworkManager: <info> Marking connection ‘eduroam’ invalid.
Jan 14 09:54:41 linux-im9r NetworkManager: <info> Activation (wlan0) failed.
Jan 14 09:54:41 linux-im9r NetworkManager: <info> (wlan0): device state change: 9 → 3
Jan 14 09:54:41 linux-im9r NetworkManager: <info> (wlan0): deactivating device (reason: 0).

This is the output of my last connection attempt.

My system is a DELL Inspiron 1720 with openSUSE 11.1 x86_64. Wireless adapter is an Intel PRO/Wireless 3945ABG. Configuration is set via DHCP.

Connecting to my WLAN at home with WPA2-PSK works fine, so the driver isn’t the problem.

If you need anymore information just ask :slight_smile:

GeisterMeister wrote:
> Hi everyone.
>
> I’m having trouble to connect to the wireless network at my university.
>
> It uses WPA Enterprise with PEAP authentication, TKIP encryption and a
> CA-certificate.
>
> This is what I enter in KNetworkManager:
> Security: WPA Enterprise
> EAP method: PEAP
> Identity: my username
> Password: my password
> CA-certificate: /etc/ssl/certs/cacert.pem (I copied it there,
> downloaded from the university’s homepage, I also got 3 other certs with
> the suffixes .crt, .cer and .der)
> Phase 2 method: MSCHAPv2
>
> When I try to connect to the network the symbol in the systray starts
> working and ends up with a gray globe saying not connected. Here is what
> the NetworkManager logfile says:
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0)
>> starting connection ‘eduroam’
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> (wlan0): device
>> state change: 3 → 4
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0)
>> Stage 1 of 5 (Device Prepare) scheduled…
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0)
>> Stage 1 of 5 (Device Prepare) started…
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0)
>> Stage 2 of 5 (Device Configure) scheduled…
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0)
>> Stage 1 of 5 (Device Prepare) complete.
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0)
>> Stage 2 of 5 (Device Configure) starting…
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> (wlan0): device
>> state change: 4 → 5
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation
>> (wlan0/wireless): access point ‘eduroam’ has security, but secrets are
>> required.
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> (wlan0): device
>> state change: 5 → 6
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0)
>> Stage 2 of 5 (Device Configure) complete.
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0)
>> Stage 1 of 5 (Device Prepare) scheduled…
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0)
>> Stage 1 of 5 (Device Prepare) started…
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> (wlan0): device
>> state change: 6 → 4
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0)
>> Stage 2 of 5 (Device Configure) scheduled…
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0)
>> Stage 1 of 5 (Device Prepare) complete.
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0)
>> Stage 2 of 5 (Device Configure) starting…
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> (wlan0): device
>> state change: 4 → 5
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation
>> (wlan0/wireless): connection ‘eduroam’ has security, and secrets exist.
>> No new secrets needed.
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added ‘ssid’
>> value ‘eduroam’
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added
>> ‘scan_ssid’ value ‘1’
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added
>> ‘key_mgmt’ value ‘WPA-EAP’
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added
>> ‘pairwise’ value ‘TKIP CCMP’
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added
>> ‘group’ value ‘TKIP CCMP’
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added
>> ‘password’ value ‘<omitted>’
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added ‘eap’
>> value ‘PEAP’
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added
>> ‘fragment_size’ value ‘1300’
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added
>> ‘phase2’ value ‘auth=MSCHAPV2’
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added
>> ‘identity’ value ‘<my identity>’
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: added
>> ‘ca_path’ value ‘/etc/ssl/certs’
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Activation (wlan0)
>> Stage 2 of 5 (Device Configure) complete.
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> Config: set
>> interface ap_scan to 1
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> (wlan0): supplicant
>> connection state: disconnected → scanning
>> Jan 14 09:54:16 linux-im9r NetworkManager: <info> (wlan0): supplicant
>> connection state: scanning → disconnected
>> Jan 14 09:54:31 linux-im9r NetworkManager: <info> wlan0: link timed
>> out.
>> Jan 14 09:54:41 linux-im9r NetworkManager: <info> Activation
>> (wlan0/wireless): association took too long.
>> Jan 14 09:54:41 linux-im9r NetworkManager: <info> (wlan0): device
>> state change: 5 → 6
>> Jan 14 09:54:41 linux-im9r NetworkManager: <info> Activation
>> (wlan0/wireless): asking for new secrets
>> Jan 14 09:54:41 linux-im9r NetworkManager: <WARN> get_secrets_cb():
>> Couldn’t get connection secrets: Requested setting is empty.
>> Jan 14 09:54:41 linux-im9r NetworkManager: <info> (wlan0): device
>> state change: 6 → 9
>> Jan 14 09:54:41 linux-im9r NetworkManager: <info> Activation (wlan0)
>> failed for access point (eduroam)
>> Jan 14 09:54:41 linux-im9r NetworkManager: <info> Marking connection
>> ‘eduroam’ invalid.
>> Jan 14 09:54:41 linux-im9r NetworkManager: <info> Activation (wlan0)
>> failed.
>> Jan 14 09:54:41 linux-im9r NetworkManager: <info> (wlan0): device
>> state change: 9 → 3
>> Jan 14 09:54:41 linux-im9r NetworkManager: <info> (wlan0):
>> deactivating device (reason: 0).
> This is the output of my last connection attempt.
>
> My system is a DELL Inspiron 1720 with openSUSE 11.1 x86_64. Wireless
> adapter is an Intel PRO/Wireless 3945ABG. Configuration is set via DHCP.
>
> Connecting to my WLAN at home with WPA2-PSK works fine, so the driver
> isn’t the problem.
>
> If you need anymore information just ask :slight_smile:

You should pose your question on the NetworkManager mailing list -
networkmanager-list@gnome.org. If you use KDE, that is still the place
to write despite the Gnome address.

Larry

Hi GeisterMeister. Have you found any solution? I have the same problem at my University:(

I wasn’t able to figure out what the problem was. So I went a step back and used Windows instead. Other ppl I talked to said that connecting our network with Linux is very close to impossible. So I gave up on this issue…

If anybody finds a solution, please report here so I can try it again!

It’s not the solution, but “yet another attempt”:
Wicd
at least here i see no issues for WPA/WPA2/WEP/etc… please read “The Mom’s Cookbook” if something does out of control.

Originally Posted by syadasti View Post
I got off my ass and used teh google.

Stupid knuckleheads at ubuntu didn’t bother to address this significant problem before release, people have known for awhile.

https://bugs.launchpad.net/ubuntu/+s...er/+bug/274995

Here are two workarounds:

Quickfix:
ALT+sysrq+R (get keyboard control)
ALT+sysrq+E (kill tasks)
CTRL+ALT+DEL (call shutdown)

Better fix:
sudo gedit /etc/init.d/alsa-utils

The file opens in Gedit and around the line 353 you’ll find the instruction “stop)” (or do a find for “stop)” (without quotes)). Below this instruction you should add these two instructions:

ifconfig wlan0 down
ifconfig eth0 down

So, the section of the file should look like this after editing (don’t delete/change anything after this section!):

stop)
ifconfig wlan0 down
ifconfig eth0 down
EXITSTATUS=0

Best fix:
Don’t release buggy software. Hopefully they push an update via update manager.

I think this might very well be the fix for the problem in ubuntu, but SUSE is not ubuntu, and my system doesn’t seem to have the file /etc/init.d/alsa-utils.

If someone konws the equivalent procedure in SUSE, plesase share…

Many thanks