Issues with sound & wireless


I have multiple issues with my fresh OS TW install on my HP Revolve 810 G3 notebook.

  1. WiFi does not auto connect after resume, when I try to connect manually nothing happens, except that my WiFi SSID disappears from the list for a while, but even after reappearing it won’t connect. After opening the WiFi settings it finally connects after a couple of minutes. This happens infrequently.

  2. I have connected my notebook to an external LCD with audio. HDMI audio (even though it’s connected via DP) is set as default, but the detection only works 50% of the time. My audio up and down keys are also still stuck to the old (internal notebook’s) audio outputs and won’t change the volume of the HDMI output. In return I only get flickering on my LCD when trying to adjust the volume. I always have to manually adjust the volume using the tray icon slider there.

Any help would be appreciated :frowning:


Given you do not know why it only works 50% of the time (with no further info provided), it is even more difficult for someone not in front of your PC, to know why …

Can you provide more information?

With notebook connected to external LCD with HDMI audio working ok, also with notebook connected to the internet please run the diagnostic script noted below in a konsole/xterm as a regular user, and save the resultant URL … ie


Let the diagnostic script run to completion (selecting the UPLOAD/SHARE option when prompted) and look in konsole/xterm for the URL/web address. Keep a record of that address.

Then next time HDMI does NOT work when it should work, run the same diagnostic script as before … ie


and make note of the resultant URL.

Then post to this thread here both URLs … both the one where audio over HDMI worked and the one where audio over HDMI did not work. We will then compare the two outputs and see if they provide any hints as to why HDMI audio was not detected/working the other 50% of the time.

I can’t help there.

Thanks for your help, I’ll do that.

Yes, I know I have not provided much information. But dealing with these issues I don’t quite know how to. Especially since I excepted this to work flawlessly on a Broadwell machine. If it would never work it’d be easier to specify I guess :frowning:


The wireless issue still persists. Any way to find out why it wouldn’t auto connect (sometimes)?


You didn’t say how you’re managing your network. I’m not sure how Wicked works but Network Manager works great. Open YaST and under System select Network Settings then on the window that opens select Network Manager Service under “Network Setup method”. Close that and you should have an icon by the clock that will allow you to configure your network. Check to auto connect when available. You can store your password un-encrypted or encrypted. I’ve never took to time to set up encryption for it so I don’t know exactly what’s involved there.

That icon by the clock should have all of the settings you’ll need. Without more information I’m only guessing as to what is going on.

I’m using the network manager (it was enabled by default) and the checkbox “connect automatically when available” is also ticked. It’s also set to “store password encrypted” (by default).

Could it be a kwallet issue?

I wouldn’t think so, rather suspect something going wrong re. unloading/reloading the wifi card’s driver during suspend/resume.

EDIT: Have a look at dmesg output after coming from suspend, with no working wifi

Yes, it could be Kwallet, make sure it’s able to access it. Open the manager and go to the second tab “access control” and check mark it to notify you when an app tries to access it. That’ll tell you if it’s even trying and if it’s able to.

And it may be that it doesn’t have the encryption software installed. I’m not real familiar with it but I also helped a friend install TW. He uses wifi and when we tried encrypted (the second selection) it wouldn’t keep the password. We did this on the phone so I didn’t check it out more. He ended up using store as plain text and it kept the password. I’m going to look it over someday when I’m at his house.

I just seen this because I was checking why I wasn’t getting thread reply notifications, I thought I had them on. I wish I could help you more but I’m just not that familiar with TW. I’ve been using it less than a month.