Issues with Nvidia GTX 1060 on a Laptop (suspend to RAM and external monitor)

Hi all,

I have a Clevo laptop P750DM2-G (see main specs below orhere for full ones). As a standalone laptop everything works well (I initially had issues with the Wifi chip but it’s all good now) except that there is no way to get out of the “suspend to Ram” (closed lid when unplugged) without a reboot. What is even more annoying, considering I use it as my main office computer, is the fact I cannot get an external monitor working on it under Opensuse tumbleweed. Under win10 I can connect my 2560x1080 monitor through HDMI or mini DP #2 whereas under Opesuse tumbleweed the “display setting” does not show any connected monitor (only the “default” display i.e. the built in laptop display). I suspect it’s a new hardware issue vs kernel/open source video drivers but I did some testing with a desktop (AMD FX8730 + 990FX) with a Nvidia 660TI/1060GTX and the results are as follows: DVI/HDMI/DP connection all working at highest res as well as resuming from suspend to RAM state with the 660TI; DVI working, HDMI working but not a max resolution (otherwise crashing as soon trying to resume from a “suspend to ram” state), DP working at full resolution but crashing irreversibly after trying to recover a “suspend to ram state”. I know that proprietary drivers may be the solution but considering it’s a roll-over distro I am not overly keen on going down this path…

Thx for any suggestion/solution

  • 15.6" FHD 1920 x 1080 IPS WVA Matte 60Hz LED with G-Sync
  • NVIDIA GeForce GTX 1060 6GB GDDR5 VRAM - G-Sync
  • Chipset Intel Z170 Express
  • Intel Core i7-6700K Processor (8M Cache up to 4.2 GHz)
  • 16GB DDR4 2133MHZ (1 x 16GB)
  • Intel 540S 240GB SATA 3 M.2 SSD x2 in RAID 0 (Windows 10) and Samsung 850EVO 500GB SSD x2 (one for Opensuse Tumbleweed and one for - windows data)
  • Intel 8260 AC Dual Band WIFI/BT

Hi Leo,

According to Tips for buying notebook with decent graphics (Winter 2016 edition)
for that model, you should be able to turn off the Intel card, if you have one, in BIOS. Check dmesg & see which card(s) are loaded. Also, install ‘xrandr’ and run “xrandr --listproviders” and find out.

You may have to install the “Nvidia” proprietary driver & then use ‘nvidia-config’ to get the monitors up. The Nouveau driver is not up to speed for your card as of now IMHO. But, it’s coming.

You can check the Factory Mailing List and not do kernel upgrades when there are problems; check out “dkms” for kernel updates.

You may find that xrandr can set the monitors too – “man xrandr”.

Good luck!

Thx for your help Snakedriver.

There is no possibility to activate the i7 built-in video card in the bios as far as i can see. The Nvidia 1060GTX seems to always be activated. Xrandr did not provide much help either. I tried to install Nvidia drivers (the “hard way”) but during the compilation I got a message saying that some config files (sorry forgot the names but looked like kernel headings or something similar) were not correctly updated. I tried to blacklist nouveau driver manually as described in the instructions but it did not worked: I checked and the nouveau driver is still activated. To speak the truth in all my previous linux distros installations that went pear shaped the setup of graphic drivers was mostly the culprit. I will have to dig up more posts about video drivers troubleshooting.

Hi

@leomedia2: did you manage to get the external monitor to work ? It would be great if you could share some feedback as I plan to open a ticket on the opensuse bug tracker soon.
I have the same issue with my new laptop Gigabyte Aero 14W v7 (GTX 1060) where the discrete device is not properly detected. The nouveau driver does not yet support the Pascal architecture yet. And the installation of the proprietary driver is of no help. I didn’t find anything related in the opensuse bug tracker.
Thanks