Issues with Intel HD 4000 graphics and WiFi adapter

I’m a complete Linux novice going through my first setup of an OpenSuse laptop. The machine is a System76 Lemur Ultra. I’m running 12.1 and I’ve upgraded to the 3.5 r6-2 default kernel to resolve some issues I was having with powering off and the sound card.

I’m still having trouble with the intel HD 4000 graphics card. OpenSuse doesn’t seem to recognize the card’s 3D capability and even booting with nomodeset the resolution doesn’t quite scale right. I’m assuming this is a driver issue?

My other issue is with the network card, it’s either a Centrino 1030 or a Centrino Advanced-N 6235 (have to double check with the person who actually bought it). I understand both adapters are supported in current kernels and the driver is displaying as using iwlwifi but I cannot control the adapter state with the keyboard shortcuts and the adapter won’t scan for networks. I’m pretty sure its not something trivial like wireless being disabled in OpenSuse.

For wireless network problems, please post those problems in the following forum: Wireless AND make sure to read through the three stickies messages (at the top of the forum) before you post wireless questions. There is a lot of good info there. I might ask that you look at this message number two here: where I feel I might go with kernel 3.4.4 as 3.5 is not yet in final release and can have bugs not related directly to your PC. As I understand it, kernel 3.2 was required and 3.4.4 should work fine for the Intel graphics you mention. Normally after you have a kernel version working right (like 3.4.4), you can then go with a Release Candidate kernel version (like 3.5-rc6) to test the kernel, not your PC unless you have specific information that says only the RC kernel version supports some major hardware on your PC. This happens of course, but not often except for hot off the presses computers.

Thank You,


Ok. I’m on Kernel 3.4.4-2 default now. I’ll focus on the display issue first. Display works best in nomodeset still and this is what it says in the dump from YaST2 hardware info:

17: PCI 02.0: 0300 VGA compatible controller (VGA)
  [Created at pci.319]
  Unique ID: _Znp.iVtsQ3tx306
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel VGA compatible controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x0166 
  SubVendor: pci 0x1558 "CLEVO/KAPOK Computer"
  SubDevice: pci 0x0240 
  Revision: 0x09
  Memory Range: 0xf7800000-0xf7bfffff (rw,non-prefetchable)
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  I/O Ports: 0xf000-0xf03f (rw)
  IRQ: 11 (no events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00008086d00000166sv00001558sd00000240bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is not active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=no, avail=yes, need=no, active=unknown

I’m assuming “Driver Status: i915 is not active” is not a good sign? Also what is the VGA boot option command that would be equivalent to a 720p display @ 1366x786?

please post the output of

su -
hwinfo --framebuffer

As I understand it, HD 4000 graphics is an Intel Ivy Bridge built-in GPU {Ivybridge Intel® HD Graphics 2500/4000 *(used in 3rd Generation Intel® Core™ i7/i5/i3 processor family)} *and so is that what you have? Can you specify the actual CPU you are using and if you are using built-in graphics?

You might want to add this repository less the quotes to YaST / Software / Software Repositories : “

and then bump MESA up to version 8 and load the latest xf86-video-intel file. You need to set the option in YaST / Software / Software Management to allow Vendor change. When you search on mesa and Intel, look at the version tab to make the upgrade. It is for sure, you need to remove the nomodeset command to use the latest kernel driver. I have not tried to get the built-in video to work from Intel before, but I found a nice article here you might want to read: [Phoronix] Intel HD 4000 Ivy Bridge Graphics On Linux Review]( AND beware of the many ads they have there to read.

Thank You,