issues soundcard ALSA

I recently installed OpenSuse 11.1 and I’m having issues with getting the sound to work. I already ran through the entire list of fixes and I already made an ALSA-conf file on the website, which can be found here : http://www.alsa-project.org/db/?f=b5007170d154125b9c5cb26e74cb4b8c47f4c777

Can anyone help me with getting my sound to work? I’m puzzled, since it always operated fine on the last 5 operating systems installed on this pc.

Your digital audio settings are confusing … you may wish to double check those in your mixer.

Do you have alsa-firmware installed?

Can you also provide the output of the following commands typed in a terminal or konsole:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

What’s confusing about them? i’ve tried every combination in the mixer actually so that’s not the problem. It must be driver related as usual…:\

**
first command returns :**
alsa-oss-1.0.17-1.37
alsa-utils-1.0.18-6.4
alsa-plugins-pulse-1.0.18-6.12
alsa-plugins-1.0.18-6.12
alsa-1.0.18-8.7

second command returns:
pulseaudio-0.9.12-9.6
pulseaudio-module-gconf-0.9.12-9.6
pulseaudio-module-lirc-0.9.12-9.6
libpulse-mainloop-glib0-0.9.12-9.6
alsa-plugins-pulse-1.0.18-6.12
libpulse-browse0-0.9.12-9.6
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-zeroconf-0.9.12-9.6
libpulse0-0.9.12-9.6
libpulsecore4-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
pulseaudio-module-x11-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6

third command returns:
rpm -q libasound2

fourth command returns:
Linux linux-t7zy 2.6.27.19-3.2-pae #1 SMP 2009-02-25 15:40:44 +0100 i686 i686 i386 GNU/Linux

and the final command returns:
# CvwD.fQ0hnWtjobB:CMI8738 6ch-MX
alias snd-card-0 snd-cmipci

I also get the following error when trying to test the sound in the box where all the audio-devices are listed :
audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink profile=music: Kan het audio-apparaat niet openen voor afspelen.

Yeah, I know it’s in Dutch, but the last line means : “Can’t open audio-device for playing”

“third command returns:
rpm -q libasound2”

That one’s wrong, but I’ll check it out in about an hour or 7 when I wake up.

Which speaker-test are you using to get this error? Did you try both speaker tests ? (sometimes one will work and the other will not).

ie to test to see if your sound works, is to open a konsole or xterm, and type (it may be easier to copy and paste this into your konsole/xterm):speaker-test -Dplug:front -c2 -l5 -twavNote Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 75%. Note the test for surround sound is different.

If that test yields errors, try instead this more simple test:speaker-test -c2 -l5 -twavIf there is no sound from either test when using a konsole (or xterm) as a regular user, try as user root. ie type “su” (no quotes, and enter root password when prompted) and then try the test line. If you get sound with root permissions, but you got no sound as a regular user, then you probably have a permissions problem.

Also when testing, in you mixer move your PCM and master volume levels up to 95% or so. Once sound is established you can back off on those levels.

If either of those sound tests work, you should hear a lady’s voice saying ‘FRONT RIGHT’,‘FRONT LEFT’ five times.

Don’t forget to also test going to YaST > Hardware > Sound > Other > Volume and check the volume levels there. You can also try YaST > Hardware > Sound > Other > Test … its not uncommon that the YaST sound test does not work, but the speaker-test (above will work). There is also a bug in YaST in 11.1 sound configuration module and sometimes one or both of those two functions will crash the YaST sound configuration module (the fix for the bug is purportedly identified, but it can only be updated later, at a time when applying the fix does not break other functions).

This looks wrong. … It looks like there is a line missing.

Try again:cat /etc/modprobe.d/soundand post here the output.

@oldcpu: missed it this time? This poster doesn’t have the kernel-driver installed either.

The kernel-driver is missing, or at least outdated. You should have alsa-driver-kmp(your-kernel-version) installed. After you’ve done that, the simplest thing is to reboot, so that the newly installed kernel module will be loaded.

Ok, thank you all, I’ll check it out once I’m home, I’ll add the results. lol!

openSuse’s is so far really nice, so I’m looking forward to having a working openSuse system.

If he is not using the cutting edge 1.0.19 alsa “git” version, then its not needed. The basic (older) 1.0.17 alsa driver is included with the more recent openSUSE-11.1 kernels (I believe).

Out dated is possible, but it may be too soon to come to that conclusion. One should NOT install the 1.0.19 alsa-driver-kmp(ones-kernel-version) without also updating all the other alsa applications to 1.0.19.

the tests from the terminal work, but I’m still getting errors (totem: can’t open audio device for playing) when playing sound from eg. a website. And I don’t get any sound when testing through the yast audio-settings. Also I’ve never heard the boot sound (if any) from openSuse.

  • here are the results for “cat /etc/modprobe.d/sound”

*options snd slots=snd-cmipci

CvwD.fQ0hnWtjobB:CMI8738 6ch-MX

alias snd-card-0 snd-cmipci*

also, when I try to access alsamixer, I get this :
alsamixer
*ALSA lib pulse.c:272: (pulse_connect) PulseAudio: Unable to connect: Connection refused

alsamixer: function snd_ctl_open failed for default: Connection refused*

OK, so you have basic sound. Great! Congratulations !!

Check totem for its output audio module. That may be adjustable, and you may be able to change it from auto (or from something else) to alsa, or pulse, … etc … See if you can find a setting that works. I do not use Totem, so I can not say.

Reference YaST, its test playback has been known to be buggy since 11.0 (for some video cards), and many of us are hoping it will be fixed by 11.2.

Reference multimedia, I typically use Amarok for mp3 and smplayer, xine, and vlc for video. If you do not know already, I typically recommend users set up their PC with only 4 repositories in the software management. There is guidance for my views here in post#5: openSUSE Forums - View Single Post - NEWBIES - Suse-11.1 Pre-installation – PLEASE READ If you set up OSS, non-OSS, Update, and Packman following the guidance there (which links to a details page explaining what to select on your openSUSE) then with those 4 (and only those 4, no others) you can go to YaST > Software > Software management , change " the filter" to “search” , and select smplayer, vlc, libxine1, xine-ui, amarok, amarok-packman, amarok-xine for installation. Then you should be able to play videos with those apps.

Again, I can’t help re: Totem specifics as I don’t use it.

OK, i’ll do, but shouldn’t openSuse also make a startup/shutdown noise?

Since I’m not hearing any system sounds as well.

Yes it should. This can be desktop specific, and its not an area that I pay attention to (I don’t like the startup/shutdown sound).

Someone else will need to provide suggestions related to that.

Good luck.

So I just changed the repositories to what I think are the dutch equivalents of the English description on the site. I downloaded a bunch of media players : dragon, listen, amarok, banshee, …

Most of them not working, others nowhere in sight, so I found no working media player so far, except for dragon which does not show up in my default applications and is weird in use. Amarok can’t be executed since I’m using gnome and banshee delivers a nice error message when trying to play a cd for testing purposes without playing the CD. So I wasn’t even able to test any media player I downloaded. The only one that pops-up in the default applications list is totem.

Banshee error message:
*Er is een niet-afgehandelde uitzondering opgetreden: Object reference not set to an instance of an object

at Banshee.Collection.Database.DatabaseTrackInfo.Save (bool,Hyena.Query.QueryField]) <0x00129>
at Banshee.Collection.Database.DatabaseTrackInfo.Save () <0x00035>
at Banshee.Collection.TrackInfo.SavePlaybackError (Banshee.Streaming.StreamPlaybackError) <0x0003b>
at Banshee.MediaEngine.PlayerEngineService.OnEngineEventChanged (Banshee.MediaEngine.PlayerEventArgs) <0x00060>
at Banshee.MediaEngine.PlayerEngine.RaiseEventChanged (Banshee.MediaEngine.PlayerEventArgs) <0x00020>
at Banshee.MediaEngine.PlayerEngine.OnEventChanged (Banshee.MediaEngine.PlayerEventArgs) <0x0003c>
at Banshee.GStreamer.PlayerEngine.OnError (intptr,uint,int,intptr,intptr) <0x00223>
at (wrapper native-to-managed) Banshee.GStreamer.PlayerEngine.OnError (intptr,uint,int,intptr,intptr) <0x00054>
at (wrapper managed-to-native) Gtk.Application.gtk_main () <0x00004>
at Gtk.Application.Run () <0x0000a>
at Banshee.Gui.GtkBaseClient.Run () <0x00044>
at Banshee.Gui.GtkBaseClient.Startup () <0x00041>
at Hyena.Gui.CleanRoomStartup.Startup (Hyena.Gui.CleanRoomStartup/StartupInvocationHandler) <0x00091>

.NET Version: 2.0.50727.1433
OS Version: Unix 2.6.27.19

Assembly Version Information:

Mtp (1.4.0.0)
ipod-sharp (0.0.1.0)
taglib-sharp (2.0.3.0)
NDesk.DBus.Proxies (0.0.0.0)
Mono.Zeroconf.Providers.AvahiDBus (3.0.0.80)
Mono.Zeroconf (3.0.0.80)
Banshee.Dap.Mtp (1.4.0.0)
Banshee.Dap.MassStorage (1.4.0.0)
Mono.Media (1.4.0.0)
Banshee.InternetRadio (1.4.0.0)
Banshee.PlayQueue (1.4.0.0)
Banshee.FileSystemQueue (1.4.0.0)
Banshee.CoverArt (1.4.0.0)
Migo (1.4.0.0)
Banshee.Podcasting (1.4.0.0)
Banshee.NotificationArea (1.4.0.0)
Lastfm (1.4.0.0)
Banshee.Lastfm (1.4.0.0)
Banshee.Bookmarks (1.4.0.0)
Banshee.MultimediaKeys (1.4.0.0)
System.Configuration (2.0.0.0)
MusicBrainz (1.4.0.0)
Banshee.AudioCd (1.4.0.0)
Banshee.Daap (1.4.0.0)
pango-sharp (2.12.0.0)
Banshee.Widgets (1.4.0.0)
Banshee.Dap.Ipod (1.4.0.0)
Banshee.Dap (1.4.0.0)
Banshee.Hal (1.4.0.0)
Banshee.Unix (1.4.0.0)
Banshee.GStreamer (1.4.0.0)
gconf-sharp (2.24.0.0)
Banshee.Gnome (1.4.0.0)
Banshee.NowPlaying (1.4.0.0)
System.Transactions (2.0.0.0)
NDesk.DBus.GLib (1.0.0.0)
Mono.Cairo (2.0.0.0)
System.Data (2.0.0.0)
Mono.Data.SqliteClient (2.0.0.0)
System.Xml (2.0.0.0)
gdk-sharp (2.12.0.0)
Mono.Addins (0.4.0.0)
atk-sharp (2.12.0.0)
Hyena.Gui (1.4.0.0)
gtk-sharp (2.12.0.0)
Banshee.ThickClient (1.4.0.0)
Nereid (1.4.0.0)
NDesk.DBus.Proxies (0.0.0.0)
Mono.Posix (2.0.0.0)
Banshee.Core (1.4.0.0)
System (2.0.0.0)
Hyena (1.4.0.0)
NDesk.DBus (1.0.0.0)
glib-sharp (2.12.0.0)
Banshee.Services (1.4.0.0)
Banshee (1.4.0.0)
mscorlib (2.0.0.0)

Platform Information: Linux 2.6.27.19-3.2-pae i686 i386 GNU/Linux

Disribution Information:

[/etc/SuSE-release]
openSUSE 11.1 (i586)
VERSION = 11.1

[/etc/lsb-release]
LSB_VERSION=“core-2.0-noarch:core-3.2-noarch:core-2.0-ia32:core-3.2-ia32”

I’m kinda giving up on openSuse. :frowning:

Based on 7 posts for help? … Well, its up to you of course. Find an OS you like and go for it !!

As for openSUSE, this is all solveable. … The problem, and please, I hope you don’t mind my saying, … but the problem is you are going about this all wrong.

The EASY way is to:

  • 1st
    set up your repositories - 2nd
    download a handful of applications that I know work

dragon, listen, banshee … I NEVER use them. Don’t need 'em. I’m sure they can be made to work, but the problem is the users who have them working, don’t like to help out (at least thats my rather/very harsh view after my having monitored this forum, and monitored 2 of the other 3 forums that were merged into this forum, for a number of years, since those apps were created at different times (dragon being very recent, and I know nothing about listen, … but banshee gets next to no support)).

I always use vlc, xine, smplayer, and amarok. But 1st, I set up my repositories. Just 4 specific repositories. No others. Adding others adds problems, … problems I can solve, but new users typically can NOT. So only 4 specific repositories. Those 4 repositories are OSS, Non-OSS, Update and Packman. Just those 4. You can find guidance for setting up those 4 here: Repositories/11.1 - openSUSE-Community The odds are OSS, Non-OSS, and Update are already setup. In which case just add Packman.

Do NOT add videolan repository. That causes more new users problems than one can shake a stick at. The reason being videlan apps/codecs are often not compatible with those from Packman.

So once those 4 repositories are added (and any others than those 4 removed), go to the 2nd step. That is go to YaST > Software > Software management > Filter and change it to “search” and search for and install the Packman (not Novell/SuSE-GmbH) packaged versions of amarok, amarok-xine, amarok-packman, libxine1, xine-ui, smplayer, vlc, ffmpeg, libffmpeg0, w32codec-all, xvidcore. You can tell Packman packged versions by the “pm” in the file version. THAT should get you started.

And you can use amarok for audio files, and smplayer, xine, and vlc for your videos.

I set up my repositories to the 4 advised ones and I downloaded the apps then, but I’m using Gnome, so Amarok, and xine do not work and I’ve just installed vlc, but it isn’t solving anything. So I cannot change my default application for playing sound to anything other than totem, because all other media players do not work. Most packages in the repositories seem to be for KDE, But I recently uninstalled PC-BSD with KDE because it made this old computer run too slow, so I’m not taking it back.

I personally still think it’s an issue with the system settings or with some kind of driver. As most media players show messages as “couldn’t connect with audio”.

Then there is something wrong in what has been installed on your PC. I am very suspicious you have mixed applications from repos that you should not have been using, but I can not confirm that.

Please provide the output of:
zypper lr

Also, I need some other specific output from you. If the basic terminal sound tests work, and you told me they did work, then xine, vlc, amarok WILL work.

Please copy and paste the following into a terminal and post here the output:
rpm -qa | grep layer
rpm -qa | grep mpeg
rpm -qa | grep xine
rpm -qa | grep amarok
rpm -qa | grep mad
and confirm again that the speaker-test that I provided above still works (for you told me it did work).

“Isn’t solving anything”. Whats that supposed to mean? I know you are frustrated, but I can not decipher anything out of a frustrating statement like that.

So totem does play sound? What output audio module and what output video module do you have selected with totem?

My experience in comparing a fedora-10 running gnome, and an opensuse-11.1 running kde-3.5.10 and 4.1.3 (on the same PC) is gnome runs slower. IMHO this is a classic YMMV (your mileage may vary).

What output audio and video module do you have selected when you get that error message ? Please specify error message by specific applications. Specifics are necessary to solve this.

Didn’t want to come over like that, frustrated then.

I’m now reinstalling openSuse with KDE, I’ll see if that works. It could be the BSD-kernel that made PC-BSD slower so, I’m willing to retry.

I’ll post the current status after openSuse is reinstalled.

It works in KDE, it’s not as nice as gnome IMO, but it’ll do. lol!
Amarok is working fine, now I just have to make everything transparent again and adjust it to my needs. Must’ve been a gnome related error on my system. :confused:

Thanks oldcpu, I respect your wisdom :wink:

Glad to read its working.

It SHOULD work under Gnome. … 'fraid I’m a KDE user, and I’m not much good at helping with Gnome.