Issues mounting and booting a SATA HDD

Hi, Questions are listed below, if you wish to skip the history;)

A long time ago I installed (for dual boot with Vista) openSUSE 11.1 on my HP (dv5z) laptop and had random stupid issues with it and stopped using it for a few months and just used Vista. Recently I decided to give openSUSE 11.1 another try on a new computer (it is the only OS) and it has been working really well this time… a day ago (I will admit out of my stupidity) I spilled liquid on my HP Laptop and since have keep all removable parts out and am letting it dry.
Before I attempt to boot it again I want to backup everything that is not already backed up. I plugged my HP hdd into open SUSE via SATA and it sees the partition but doesn’t seem to be mounting them as there are no names or free space listed (HP Recovery name is listed but there is no free space listed for that and it does not allow access, I believe it shouldn’t anyway though). I noticed that it does show the ext3 partitions for that openSUSE but same issue, no access. [QUESTION 1]
I thought I would try a different approach and boot off of HP drive, openSUSE booted but it went straight into command line. It never did that before but I also have not booted into it in a looong time.[QUESTION 2] It will boot into vista, though it will not recognize my USB Keyboard or Mouse on the log in screen, I have not tried using a PS2 keyboard because I figured the login screen was proof enough and windows cant read ext3 so I wouldn’t be able to do what I want anyway.


  1. Do I have to do anything special to mount this drive properly as it sees the partitions but will not allow access to them (neither the NTFS or ext3)?

  2. Can someone tell me the hot key and/or command to change from CLI to GUI? Or give a site that has good commands for copying files (I do not know the exact directories for anything)!

ANY advice is welcome and helpful!
Thanks for reading that, even the questions and this outro is long…

Have you tried mounting the drive(s) using Yast -> System > Partitioner?

You can do it with the command line but the Yast way might be easiest for ya

Most likely the laptop has a different graphics card to the machine you put the drive in to boot off, perhaps a situation like the laptop having intel or ati graphics but the pc nvidia?

You can use yast2 at the command prompt to start the text mode version of yast and use it to add the relevant repository for your card and install it’s driver

Hope that helps

Hi, thanks for the reply

I tried the partitioner and I get an error -3003 saying the device is in already use. So I try to force it with the command:
mount -t ntfs-3g/dev/sbd1/local-0force
(Also tried saving to the /srv folder)
and a new command line comes up right away with no error or acknowledgment, when I open the folder I try to mount to, it does not show up!

The video cards are both nvidia but I am sure they use different drivers.
I am not sure how to add repositories and install through CLI, would it be easier to try to install the VESA drivers from the opensuse install DVD?

Nevermind!! I got it mounted now… THANKS to you Ecky :wink:

With the message saying it is already in I figured that something was up (as I see this a lot trouble shooting drives in Windows) and realized that the drive has never been shut down properly (through Windows)… so I plugged in a PS2 keyboard, booted from the ntfs drive and logged into Windows and then shut it down, and booted back into Suse from the desk top HDD and was able to mount it fine through YAST