Issue with Tumbleweed Yast

Has anyone had problems with yast?

I have tried clean installs from the last three tumbleweed iso’s (both kde & gnome) and had the same issue. Say for example I select Totem to de-install the standard message comes up - that two packages depend on totem and asking whether these packages are also to be removed. I click yes and OK and yast just closes without doing anything.

Yes. I think this has been mentioned on the factory mailing list, and I think there is an open bug report.

When there is a conflict dialog, Yast closes (probably crashes) at the end of the dialog.

I got around that problem by using “zypper” which does not crash. If I recall, “yast --ncurses” probably also works without crashing.

Thanks for posting. Always good to know that am not the only one!

I had never used zypper before but am picking it up (slowly).

in yast have you tried deleting the dependant packages first
before trying to delete Totem?

this has worked a couple of times in similar situations

this is also the case when trying to remove an old kernel,
the old has to be removed before installing the new


Actually it’s fixed already, but I think the fix didn’t make it into Tumbleweed yet.
Fixed packages are available in the devel repo (YaST:Head) though, see the bug report.

This hit me the other day too. And as already mentioned, I just used zypper.
But I’m still plagued with a host of other issues in Printing/CUPS

Thanks very much. I did a yast update from YaST:Head repo and yast is back working fine.

not yet pushed to tumbleweed repo… it’s long :wink:

Yeah. They submitted further changes meanwhile which probably delay the review process.

Also, there hasn’t been any new Tumbleweed snapshot at all in the last 2 weeks because of problems:

The fix has been accepted 7 hours ago, and should be in the next snapshot, hopefully published in the next few days.

But, there is a new TW snapshot. Got ~1000 updates this morning, incl. Plasma5 5.4.1 …

Just checked, the fix for sw_single hasn’t made it yet.

No. The new snapshot is actually a few days old already, it’s 20150924.

But as mentioned the fix has been accepted into Factory a few hours ago, and therefore should be in the next snapshot (20150927 or later).

I noticed that too.

Thanks for the heads-up Wolfi

update soon :), i hope

Maybe, maybe not.
See here:

with the tdoay update, problem is still there

No, it isn’t.
I just tried on a fresh Tumbleweed installation, and YaST does not crash any more after the conflict resolution dialog shows up.

Maybe your system is not fully up to date?
Run “zypper dup”, and/or check that you have libyui-qt-pkg7-2.45.4 installed.

Same for me - following a clean install of 02102015 - yast works fine.

crashed 1 time on 3 attempt…

More details, please.
When does it crash exactly, e.g.

Maybe you have a completely different problem?

And what libyui* packages do you have installed?

rpm -qa libyui*