Issue with amdgpu-pro-17.30-465504 driver & Radeon R9 290

I’m not able to successfully get my system to run with the amdgpu-pro drivers. I’m running Lead 42.3 (kernel 4.4.69-19-default).

I’ve tried following the procedure listed here: link, however I never see a prompt to accept the repository GPG key, instead I get this message: “Package amdgpu-pro-core is broken , integrity check has failed.” regardless if I re-download the driver from AMD’s site.

I’ve followed the instructions given on AMD’s site (link) and the installation process appears to finish, however I am not able to boot into a usable GUI. I see the “Oh no! Something has gone wrong.” screen. Logging out or rebooting does not resolve the issue. My Xorg.1.log output. Ctrl+alt+f1, sudo init 3, and rerunning the amdgpu-pro-install installation script removed the driver and I was able to boot into my previous setup using the radeon driver.

Would somebody please assist me by pointing out what I’m doing incorrectly? Here’s some info of my setup that I’ve seen help others with their issues:

rpm -ql xorg-x11-driver-video


rpm -qa | grep amdgpu


uname -a

Linux Spectre2 4.4.79-19-default #1 SMP Thu Aug 10 20:28:47 UTC 2017 (2dd03e8) x86_64 x86_64 x86_64 GNU/Linux

sudo /sbin/lspci -nnk |grep -A3 VGA

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290] [1002:67b1]
	Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:0b00]
	Kernel driver in use: radeon
	Kernel modules: radeon

rpm -qi dkms

Name        : dkms
Version     : 2.3
Release     : 8.2
Architecture: noarch
Install Date: Mon 11 Sep 2017 06:10:45 PM PDT
Group       : System/Kernel
Size        : 208629
License     : GPL-2.0
Signature   : RSA/SHA1, Fri 16 Jun 2017 03:30:32 AM PDT, Key ID 45a1d0671abd1afb
Source RPM  : dkms-2.3-8.2.src.rpm
Build Date  : Sun 28 May 2017 11:19:13 AM PDT
Build Host  : swkj14
Relocations : (not relocatable)
Packager    :
Vendor      :
URL         :
Summary     : Dynamic Kernel Module Support Framework
Description :
This package contains the framework for the Dynamic
Kernel Module Support (DKMS) method for installing
module RPMS as originally developed by Dell.
Distribution: Extra / openSUSE_Leap_42.3

Just a note: I’m unable to get Tumbleweed to run on my setup. I’ve heard it has superior AMD graphics card compatibility, just won’t work for me.

I’ve not got the mdgpu-pro driver working with my Mullins (R5) SI card either, but do have the oss amdgu driver running.

Update your system to run the 4.4.85 kernel and install the CIK enabled drivers from here;

Project here:

I’ve installed the 4.4.85-22-default kernel, however I’m not entirely sure not to proceed with the CIK enabled drivers installation.

When installing with rpm:
rpm -i amdgpu-4.4.85-3.5.x86_64.rpm

warning: amdgpu-4.4.85-3.5.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 479de3c9: NOKEY
error: Failed dependencies:
    amdgpu-kmp is needed by amdgpu-4.4.85-3.5.x86_64

Would you show me how to add your repo to zypper so the dependencies could be handled automatically and properly?

You can add the repo (then when the kernel updates the kmp will too :wink:

zypper ar -f -g "openSUSE-Leap-42.3-AMDgpu-Update" repo-AMDgpu-Update
zypper ref
zypper in amdgpu amdgpu-kmp-default

Make sure you uninstall the amdgpu-pro drivers and repo first.

I tried the above steps and now my system won’t boot into a GUI.

I’m seeing “bbswitch: No discrete VGA device found” message at the login prompt.
Xorg.0.log displays the following EE & WW messages:
(WW) xf860OpenConsole: VT_ACTIVATE failed! Operation not permitted
(EE) xf860OpenConsole: Switching VT failed

Picture link]( of Xorg.0.log output:

In removing the previously installed amdgpu-pro drivers, a good number of applications appear to have been removed, which I don’t know how to prevent.

How do I go about ensuring the installation of the default X server and video drivers? I want to get to a point where my setup worked with a GUI.

Uninstalling the amdgpu-pro driver just removes it’s rpm’s (10-19 of them)…?

So this is a dual grapics system?

If you unintsall the two amdgpu rpms, run mkinitrd again it should be back to defaults…

It’s a single R9 290 in the machine. Removed the one driver I saw with the name amdgpu via yast. Got the this]( output. Only way I can use a GUI is with adding nomodeset to the linux line in grub2.

After that processed, I reboot and allow the system to boot without modifying grub2.

I see the green loading screen, then I get the login prompt. The following messages appear:

bbswitch: no discrete VGA device found
[FAILED] Failed to start Load Kernel Modules.
radeon 0000:01:00.0: radeon_vce: Can’t load firmware “radeon/BONA IRE_vce.bin”
radeon 0000:01:00.0: failed VCE (-2) init

Output of systemctl status systemd-modules-load.service: (and the picture link](
Loaded: (/usr/lib/systemd/system/system/systemd-modules-load.service; status; vendor preset: disabled)
Active: Failed (result: exit-code) since 2017-09-14 16:28:45 PDT; 3 min 45s ago
Docs: man:systemd-modules-load.service(8)
Process: 435 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 435 (code=exited, status=1/FAILURE)

Hey, thanks for trying to assist. I’m just going to reinstall the OS partition. This has been a headache way too long.

Appreciate your time.

So I tried again the above steps you recommended with a slightly better handle of what to and not to do. I was never able to boot past the black screen with the blinking cursor. I removed amdgpu & amdgpu-kmp-default and ran mkinitrd to get back to my previous graphical setup w/o issue.

Things I did:
I added your repo:

zypper ar -f -g “openSUSE-Leap-42.3-AMDgpu-Update”
This is on a system where I haven’t attempted to upgrade video drivers, so I ran:
zypper ref
zypper in amdgpu amdgpu-kmp-default
I have a few kernels installed, and tried booting into all of them:

Do you by chance have any more recommendations on what I can try?

What does the output from lspci and modinf say, for example;

/sbin/lspci -nnk |grep -A3 VGA

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon R3 Graphics] [1002:9850] (rev 40)
    Subsystem: Hewlett-Packard Company Device [103c:8305]
    Kernel driver in use: amdgpu
    Kernel modules: radeon, amdgpu

sbin/modinfo amdgpu |grep filename

filename:       /lib/modules/4.4.87-25-default/updates/amdgpu.ko

~ » /sbin/lspci -nnk |grep -A3 VGA
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290] [1002:67b1]
Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:0b00]
Kernel driver in use: radeon
Kernel modules: radeon

~ » sudo modinfo amdgpu |grep filename
filename: /lib/modules/4.4.87-25-default/weak-updates/updates/drivers/gpu/drm/amd/amdgpu/amdgpu.ko

Looks like you still have amdgpu-pro stuff present… did you uninstall it and all the rpms it installs?

I uninstalled the two packages your instructions specified via yast and then removed the “openSUSE-Leap-42.3-AMDgpu-Update” repo.

I see these rpms installed, but I suspect they were part of the initial system reinstall, though I could be wrong:

~ » rpm -qa | grep amdgpu

Yes those ones are but did you run the amdgpu-pro script to uninstall all their stuff (which includes a whole graphics stack…) and disable the amdgpu-pro repository?

Also check down in /lib/modules/4.4.87-25-default/weak-updates/ for other bits and pieces… sounds like it wasn’t a clean uninstall, so not sure what other bits may be lurking in other areas of the filesystem…

There are a few… try a grep on 465504 instead of amdgpu…

Grepping for 465504 did not produce anything.
rpm -qa | grep 465504

I removed the amdgpu-pro repo:

zypper lr                                                                                                                     Repository priorities are without effect. All enabled repositories share the same priority.

#  | Alias                               | Name                                    | Enabled | GPG Check | Refresh
 1 | google                              | google                                  | Yes     | (r ) Yes  | No     
 2 | google-chrome                       | google-chrome                           | Yes     | (r ) Yes  | Yes    
 3 | | devel:tools:compiler                    | Yes     | (r ) Yes  | Yes    
 4 | | home:Herbster0815                       | Yes     | (r ) Yes  | Yes    
 5 | | home:megamaced                          | Yes     | (r ) Yes  | Yes    
 6 | | network                                 | Yes     | (r ) Yes  | Yes    
 7 |    | libdvdcss repository                    | Yes     | (r ) Yes  | Yes    
 8 |      | Packman Repository                      | Yes     | (r ) Yes  | Yes    
 9 | kernel-repo                         | kernel-repo                             | Yes     | (r ) Yes  | Yes    
10 | kernel-repo_head                    | kernel-repo_head                        | Yes     | (r ) Yes  | Yes    
11 | openSUSE-Leap-42.3-0                | openSUSE-Leap-42.3-0                    | No      | ----      | ----   
12 | packman                             | packman                                 | Yes     | (r ) Yes  | Yes    
13 | repo-debug                          | openSUSE-Leap-42.3-Debug                | No      | ----      | ----   
14 | repo-debug-non-oss                  | openSUSE-Leap-42.3-Debug-Non-Oss        | No      | ----      | ----   
15 | repo-debug-update                   | openSUSE-Leap-42.3-Update-Debug         | No      | ----      | ----   
16 | repo-debug-update-non-oss           | openSUSE-Leap-42.3-Update-Debug-Non-Oss | No      | ----      | ----   
17 | repo-non-oss                        | openSUSE-Leap-42.3-Non-Oss              | Yes     | (r ) Yes  | Yes    
18 | repo-oss                            | openSUSE-Leap-42.3-Oss                  | Yes     | (r ) Yes  | Yes    
19 | repo-source                         | openSUSE-Leap-42.3-Source               | No      | ----      | ----   
20 | repo-source-non-oss                 | openSUSE-Leap-42.3-Source-Non-Oss       | No      | ----      | ----   
21 | repo-update                         | openSUSE-Leap-42.3-Update               | Yes     | (r ) Yes  | Yes    

22 | repo-update-non-oss                 | openSUSE-Leap-42.3-Update-Non-Oss       | Yes     | (r ) Yes  | Yes  

I’m not sure I have the amdgpu-pro install script anymore, would you recommend installing it just to use it to uninstall everything related to amdgpu-pro?

No, you should be good, did you check down in the weak-updates directory? I would delete anything down in there amdgpu related…

Then also check down in /etc/modprobe.d and /etc/X11/xorg.conf.d but if that amdgpu.ko file is left, one wonders what else may be lurking :frowning:

Found these amdgpu references:

/lib/modules/4.4.87-25-default/weak-updates » find . | grep amdgpu


No references to amdgpu in the other locations:

/etc/modprobe.d » grep -r amdgpu *                                                                      

/etc/X11/xorg.conf.d » grep -r amdgpu *                                                                 

When I delete amdgpu.ko, do I go through that earlier process you outlined to install the oss amdgu driver?

Well you could try adding my amdgpu module and amdgpu package in again, then add the grub kernel commandline option exp_hw_support=1 I’ve not had to do that once I added the CIK switch…

Is it okay to stay with the 4.4.87 kernel or should I be doing this with 4.4.85?