Issue with a Packman package, again

Using openSUSE 12.2 x86_64 GNOME 3.4.

I’m trying to update my system packages with Yast Software Manager, by first applying switch to all my repos but Packman, then applying switch to Packman itself and at the last updating all packages within @System repo.

But when applying switch to Packman I get this message:

libavfilter2-0.11.1-1.4.x86_64 requires libavcodec54 = 0.11.1, but this requirement cannot be met.
     deleted providers: libavcodec54-0.11.1-1.4.x86_64
   --Following actions will be done:
     keep old libavcodec54-0.11.1-1.4.x86_64
     keep old libswresample0-0.11.1-1.4.x86_64
     keep old libswscale2-0.11.1-1.4.x86_64
   --Uninstall libavfilter2-0.11.1-1.4.x86_64
   --Break libavfilter2-0.11.1-1.4.x86_64 ignoring some of its dependencies

I thought these kind of errors would be gone for good since I installed openSUSE 12.2. What should I do now?

My system is fully updated. I don’t have libavfilter2, but I do have libavfilter3. Check for that. Suggest taking option to Uninstall libavfilter2, since its dependency libavcodec54 isn’t available as per message.

uninstall libavfilter2 (obsolete), install libavfilter3 instead

PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.5 | GeForce GT 420
ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.2 | HD 3000
eCAFE 800: oS 11.4 i586 | AMD Geode LX 800@500MHz | 512MB | lamp server

Thanks very much. That worked.