Issue installing nVidia drivers the "hard way"

So I am following the instructions found: NVIDIA/The hard way - openSUSE

And I have installed all of the following via yast:

compiler gcc,
program make and
package kernel-source
package kernel-syms

How ever I get the following error message from the nVidia package installer when I try to run it:

The kernel header file '/lib/modules/' does not exist.

Did I do something wrong/am I missing something here? Not sure if it matters but I am on run level 3 and logged in as super user as the page also says. Using OpenSUSE 11.1 64bit

Any help would be awesome,

You need the linux-kernel-headers as well :wink:

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 3 days 23:28, 4 users, load average: 2.09, 1.75, 1.61
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

I just looked through the repos and did not find a kernel v 2.6.37. Did you upgrade/update your kernel from a source outside the repos? If so, you will need to get the source files for that kernel. It looks like the kernel source available in the repos is 2.6.27, 2.6.29, 2.6.30 and 2.6.31.

The kernel and kernel-source version have to match.

Ahh thank you much. Should have realized that! Someone should really add that to the wiki…


It is the .27 - sorry typoed it when I copied it over (using my netbook to post as I am still setting up my Sager darn tiny keyboard!) will fix in first post.


Simplest way to solve all this, is starting the software installer, Pattern View, select Linux Kernel Development. This will install all needed files to install the NVidia driver ‘the hard way’. If you managed to install, don’t forget the ‘sax2 -r -m0=nvidia’…

I installed Linux Kernel Development package via YaST and I am still getting the same error message when trying to install the nvidia driver :frowning: Other suggestions?

And what do you mean by don’t forget

sax2 -r -m0=nvidia


Assuming you have the Matching kernel packages (Check the version numbers carefully)

This is my method:

Alright so here is how to install the nvidia driver manually, in case the one in the repo doesn’t work or u just want to use the latest.
Go to Yast>Software>Software Management
Search for and install if you don’t have these:


Now download the latest Nvidia driver:
Place the file in your /home/username
Now restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then just type the number: 3
At the login
Type “root” then enter and then your root password and press enter.
now type
cd /home/username
*Now remember you can use the {TAB} key to auto complete
so type:
and the whole file name should auto complete
eg: sh
Follow the installer and let it compile the kernel module for you.
Say Yes to everything
Use TAB to move around

I followed all the instructions in your guide as listed and I still get the

The kernel header file '/lib/modules/' does not exist.

Error message from the nvidia 190.18 binary file when trying to run it. (I can confirm the file works - I just installed with it in Fedora11 and Ubuntu 9.04)

I am open to suggestions still… but for now I am admitting default and just installing the version from the repos :frowning: But I would really like to extra performance the beta drivers grant :confused:


Please open a terminal and do this:

rpm -qi linux-kernel-headers

post result

jeff@linux-arsd:~> rpm -qi linux-kernel-headers
Name        : linux-kernel-headers         Relocations: (not relocatable)
Version     : 2.6.27                            Vendor: openSUSE
Release     : 2.28                          Build Date: Tue 02 Dec 2008 11:03:12 PM CST
Install Date: Mon 24 Aug 2009 03:34:08 PM CDT      Build Host: build21
Group       : Development/Libraries/C and C++   Source RPM: linux-kernel-headers-2.6.27-2.28.src.rpm
Size        : 2491401                          License: GPL v2 only
Signature   : RSA/8, Tue 02 Dec 2008 11:03:29 PM CST, Key ID b88b2fd43dbdc284
Packager    :
URL         :
Summary     : Linux Kernel Headers
Description :
This package provides Linux kernel headers, the kernel API description
required for compilation of almost all programs. This is the userspace
interface; compiling external kernel modules requires kernel-source
Distribution: openSUSE 11.1


Now post the result of these:

rpm -qi kernel-source
uname -a
jeff@linux-arsd:~> rpm -qi kernel-source
Name        : kernel-source                Relocations: /usr/src 
Version     :                         Vendor: openSUSE
Release     : 0.1.1                         Build Date: Sun 16 Aug 2009 05:10:04 AM CDT
Install Date: Mon 24 Aug 2009 03:28:57 PM CDT      Build Host: gubaidulina
Group       : Development/Sources           Source RPM: kernel-source-
Size        : 308630927                        License: GPL v2 only
Signature   : RSA/8, Sun 16 Aug 2009 05:16:07 AM CDT, Key ID b88b2fd43dbdc284
Packager    :
URL         :
Summary     : The Linux Kernel Sources
Description :
Linux kernel sources with many fixes and improvements.

    Linus Torvalds <>

    see /usr/src/linux/CREDITS for more details.

Source Timestamp: 2009-08-15 17:53:59 +0200
GIT Revision: 8a413546901c407e96f7fba18574cceeb40452af
Distribution: openSUSE 11.1
jeff@linux-arsd:~> uname -a
Linux linux-arsd #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux


Why have you not updated?

Are you doing updates

su terminal and do

zypper ref


zypper up

You might want me to take a look at your repos;

zypper lr -d

post here