Issue adding a user to an Access Control List in Nautilus

Hello everyone, I have a shared folder that has it’s access restricted to certain users on a file server at work.

Currently when I try to add a user I follow this process:
Right click the Folder, go to Properties
Click the “Access Control List” tab
Select a user from the “Participants List”
Click Add

For most users this process works fine but with one of them I get the following error:
“Could not add ACL entry: Invalid Argument”

I also tried a script that a former employee created which seems to employ this command:

setfacl -m u:<USER>:rw- <PATH>

Running the command with the correct user and path returns a similar “Invalid Argument” error.

Has anyone seen this before and do you know if I can run a command that would give me more information, like which argument is invalid? We’re using OpenSuse 10.2 Thanks a bunch,


Just in case anyone stumbles across this, it turns out the error only occurs if you try to add more than 25 entries to the ACL, I was able to add the users to a group and add the group to the ACL instead and it worked.