ISO9660 CD won't automount

I can’t get data CDs (iso9660 filesystem) to automount via Dolphin. The device notifier notices the insertion, and offers a k3b action, but no action to open with Dolphin. And there is no CD icon in Dolphin to allow me to mount it.

If I run Dolphin in a terminal window, it says the following when the CD is inserted:

MEDIA CHANGED in "/org/freedesktop/UDisks2/block_devices/sr0" ; size is: 0
MEDIA CHANGED in "/org/freedesktop/UDisks2/block_devices/sr0" ; size is: 51613696
org.kde.baloo: "/org/freedesktop/UDisks2/block_devices/sr0"
QObject::connect: invalid null parameter

I can mount the device manually (albeit as root) with “mount /dev/sr0 /mnt”, which works fine. I am a member of the cdrom group (so have rw access to /dev/sr0). There are no cdrom entries in /etc/fstab.

Does anyone else see this?

(LEAP 42.2, 64-bit)

Incidentally, inserting USB sticks or DVD media works as expected - the device notifier offers me an option to open with Dolphin and Dolphin sees the device in its list.

Is this more likely to be an issue with the device notifier configuration, or with Dolphin?

Monitor udev with

udevadm monitor

and/or monitor udisksd with

udisksctl monitor

Inset a data CD and observe/capture the output. That might shed more information about what’s occurring here.

The device notifier notices the insertion, and offers a k3b action, but no action to open with Dolphin.

It is possible to create additional actions via

System Settings > Removable Storage > Device Actions > Add

With a bit of experimentation it should be possible to create a new device action ‘Open with File Manager’ for the optical disk.

Thanks for the help with this. Here is the result of those two commands:

# udevadm monitor
monitor will print the received events for:
UDEV - the event which udev sends out after rule processing
KERNEL - the kernel uevent

KERNEL[109952.989637] change   /devices/pci0000:00/0000:00:1f.2/ata2/host1/target1:0:0/1:0:0:0/block/sr0 (block)
UDEV  [109954.003095] change   /devices/pci0000:00/0000:00:1f.2/ata2/host1/target1:0:0/1:0:0:0/block/sr0 (block)

# udisksctl monitor
Monitoring the udisks daemon. Press Ctrl+C to exit.
19:44:09.111: The udisks-daemon is running (name-owner :1.22).
19:44:26.641:  /org/freedesktop/UDisks2/drives/MATSHITADVD_RAM_UJ8A0A_YK95_274251:  org.freedesktop.UDisks2.Drive: Properties Changed
  TimeMediaDetected:            1491936266638792
  OpticalNumDataTracks:         10
  OpticalNumTracks:             11
  OpticalNumSessions:           11
  Optical:                      true
  Media:                        optical_cd_r
  MediaAvailable:               true
  Size:                         235761664
19:44:26.642: /org/freedesktop/UDisks2/block_devices/sr0: org.freedesktop.UDisks2.Block: Properties Changed
  Size:                 235761664

Is that as expected?

I have tried playing with adding device actions. I didn’t manage to get it working, but then I wasn’t expecting to have to do this, so I wasn’t trying very hard - I’m sure this used to work, and I’ve never added anything to these settings before. But I’ll try again…

Try to install the libblkid1 package from here:

I’m not sure if it will help in your case, but it fixes some problems in recognizing/mounting CD’s.

Thanks for the suggestion, but I already have that loaded.

Is this a clue: udisksctl cannot mount the device, but mount can (the files are accessible under /mnt):

# udisksctl mount -b /dev/sr0
Object /org/freedesktop/UDisks2/block_devices/sr0 is not a mountable filesystem.
# mount /dev/sr0 /mnt
mount: /dev/sr0 is write-protected, mounting read-only

What does the following reveal?

udisksctl info -b /dev/sr0

# udisksctl info -b /dev/sr0
    Configuration:              ]
    CryptoBackingDevice:        '/'
    Device:                     /dev/sr0
    DeviceNumber:               2816
    Drive:                      '/org/freedesktop/UDisks2/drives/MATSHITADVD_RAM_UJ8A0A_YK95_274251'
    HintAuto:                   true
    HintIgnore:                 false
    HintPartitionable:          false
    HintSystem:                 false
    MDRaid:                     '/'
    MDRaidMember:               '/'
    PreferredDevice:            /dev/sr0
    ReadOnly:                   true
    Size:                       235761664
    Symlinks:                   /dev/cdrom

It is strange that it can be mounted with mount but not via udisksctl. The same symptoms described here, and there is a link to an old bug report (which may or may not be relevant). A bug report may be required to help resolve this issue.

I’m assuming the following will not report the expected filesystem details

/usr/sbin/blkid -o udev -p /dev/sr0

For example I get…


So perhaps there is an issue with the version of libblkid1 you have installed.

I’m getting the following, which is showing iso9660?

# /usr/sbin/blkid -o udev -p /dev/sr0

That output seems to be ok. I’m surprised though that the udisksctl info isn’t consistent with that (ie no filesystem reported). Not quite sure what’s broken but a bug report needed IMHO.

OK, well thanks for all the help anyway. So I should report the difference in behaviour between “udisksctl mount” and “mount” as the bug (I mean the top level issue of being unable to see a CD in Dolphin is a distraction from the real issue)?

Is there any more information, other than that already on this thread, which is relevant to the bug report?

I’d leave the file manager comments (Dolphin) out of the report since as you’ve found there is an underlying issue with udev/udisks2. The udisksctl and mount command behaviour is certainly relevant. It is perhaps worth reading the opening post in the bug report I linked to back in post #11 to get an idea on what to post.

Is there any more information, other than that already on this thread, which is relevant to the bug report?

The udisksctl info and blkid output that you posted may also help characterise the issue, and be prepared for requests for additional information or steps to undertake.

Bug now created on this: