ISO image

Dear All,
I tried to backup dvd on my hd with dvd95 and k9copy.
At first, wanted to mount the image. I tried with isomorphin but the iso file isn’t recognized. What could be the problem ? Is it another way to mount an iso image on a virtual drive ?
Then, tried to open the image with vlc, vlc close as soon as I open the files.
An finally, tried to burn a blank dvd with brasero or k3b, but the result isn’t readable either.
Any good idea ?
Many thanks in advance

mount -o loop image.iso /mnt/disk

(also, your image may be corrupt/broken)

Sounds like a duff .iso
vlc will play a .iso movie no problem
isomaster or AcetoneISO will do virtual drives

Installed acetoneiso, works fine.
But my problem is somewhere else. The iso file generated by dvd95 (version 1.5p2,uptodate on packmann repo) is not usable under vlc.
I saw a such a bug report on their forum. Also saw that version 1.5p3 is available on their source website. Why isn’t it updated on packmann repo ?
k9copy is adviced as well but I think is made for kde and I use gnome. Installed it anyway but does not work. The whole process is made successfully but the iso file is not created.
Is it another application to use ?
Many thanks in advance

do you just want to make an ISO out of your existing DVD(s)? if so, first fire up mplayer to unlock it - mplayer dvd://

quit mplayer after a few seconds and use dd to make an ISO image

dd if=/dev/dvd of=image.iso

I need the functionalities of dvd95 to choose video, audio and subtitles steams.
Thank You

Then why not just install manually the latest version of dvd95 and not wait until packman packages it (which can take some time depending on who’s maintaining it)? You can grab it from sourceforge

Good idea. Never did it so far.
Would you be so kind to indicate me how to ?
many Thanks in advance

just grab the source code from sourceforge. Unpack it somewhere and run ./configure in its directory

note that you’ll need build environment packages, (gcc, make, gnome devel packages, etc). Usually when configure runs, it checks for them and aborts if something it needs is not found. If you encounter this, look at what configure is complaining about and install the package(s) then re-run ./configure

after configure is successfully done, run make and then as root make install. I just compiled it myself and didn’t had any problems

Hi again,
Configure went ok, but after…
“run make” ? Does not function.
I get “There is no target specified or no make file were found”
There is a and a .am
Is it what you mean ?
Sorry for that but I have no experience in cli
Thanks so far

I don’t think configure went OK - you missed something, read what it outputs - because if it did, it’ll create a Makefile just like it did here.

The last thing you should see when configure stops is this line:

if you don’t see that then it didn’t go successfully and you missed something

btw, if you want me, I can package it in an RPM and send it to you. I have 64-bit here only though

Thank You for your proposal.
Will be useful perhaps, if I am really not able to do it myself. Even if I have 32 bit system only…

Find herunder the last lines
checking for PACKAGE… configure: error: Package requirements (libgnomeui-2.0 libxml-2.0) were not met:

No package ‘libgnomeui-2.0’ found
No package ‘libxml-2.0’ found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PACKAGE_CFLAGS
and PACKAGE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

But I have both application installed already, but version 2.24 and 2.9. Newer version should run, no ?
Thank You so far

you should install the devel packages of the above mentioned ones. Remember, when building from source, you always need -devel packages. On my system…

neutrino@neutrino:~> rpm -q libgnomeui-devel libxml2-devel

to install: zypper in libgnomeui-devel libxml2-devel

Hi again,
Yess Sir, You did it. Still needed to add several other stuffs and finally, the configure did what had to.
Is the structure/process for install applications mostly similar ?

I run now dvd95 p3 version, let’s see if the result works …
Thank You

yes, it is similar for other projects too but it also depends on how the project is setup to configure stuff. Some don’t have a configure script and directly offer a Makefile so you just run that. Usually most offer README and INSTALL files which explain what one needs and how one can build them so always take a look in these files if they are present

Dear Microchip8,
Problem remains the same. Job is performed successfully but the image cant be used.
Any good advice ?
Thank You

no idea really, seems the app is doing something wrong. Did you try k9copy or dvdshrink ran under WINE?

Such a good Evening,
In fact dvd95 works. Sometimes, perhaps due to encryption, the ripping isn’t usable.
I tried dvdshrink under wine. Looks to be fine. I just don’t how find the virtual place where to get the image (C:…)
Do You whare can I find it ?
Thank You so far

Look in hidden user section .wine/drive_c