iscsitarget update confusion


I’ve recently setup a custom home server running openSUSE 11.3 64-bit in terminal mode. I’ve since successfully setup and configured it to act as an iSCSI target using the iscsitarget package and the corresponding kernel module, along with the YaST module for the configuration. Prior to setting up my hard drive accordingly, however, I noticed that when I ran ‘zypper up’ in a terminal I got the following:

pph-server:~ # zypper up
Loading repository data...
Reading installed packages...

The following NEW package is going to be installed:

The following package is going to be REMOVED:

1 new package to install, 1 to remove.
Overall download size: 129.0 KiB. After the operation, additional 199.0 KiB will be used.
Continue? [y/n/?] (y):

At the time I accepted, and found later that it removed the setup I had, meaning I had to start over. However when I ran YaST in a terminal it then wanted to re-install the iscsitarget package, which subsequently removed the tgt package, and so this continued for a bit. (Thankfully no actual data was stored on the target at this stage :).) For the time being I’ve locked the iscsitarget package and the kernel module to prevent zypper from wanting to remove it and install tgt instead since I now have my target working as I want.

The question I have is why zypper was trying to remove iscsitarget and install tgt, and yet the corresponding YaST module was wanting to do the opposite. Is tgt considered a better option by the openSUSE developers, in some way, for setting up an iSCSI target? Is iscsitarget development/availability being ceased by them in favour of tgt? Is there something else I’m missing? Neither of these packages seems old to me: the latest version of iscsitarget was released on SourceForge last July, while tgt was only updated this month.

Any help would be appreciated. Thanks.



Bump. Anyone?

On 02/10/2011 01:36 PM, jonitfcfan wrote:
> Bump. Anyone?

you might try asking in the networking forum, or more likely in a mail
list or IRC channel…see:

i don’t many here have any need or experience with iSCSI

[NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.0.11, nVidia
173.14.28 3D, Athlon 64 3000+]
“It is far easier to read, understand and follow the instructions than
to undo the problems caused by not.” DD 23 Jan 11