iSCSI Target and client name

Hello,

I’m trying to use OpenSUSE 13.2 as a iSCSI target to a XenServer 6.2 host. I did the configuration with yast2, and the iSCSI target is running. So far, so good.

Problem is: when I try to connect to the iSCSI target from XenCenter, it discover the IQN, fine, but when it tries to discover the LUNs, I get an error saying that logging failed. The thing is, I don’t use any authentification on the iSCSI target!

The problem might be that I didn’t specify a client in the Target Client Setup. So I added one, with the hostname of the XenServer box as the client name, didn’t work. I have tried with the IP of the XenServer box as the client name, same problem.

I also tried to connect to the iSCSI target with GlobalSAN, and it didn’t work either.

So, what should I use as the client name?

You should use iSCSI name used by your client. iSCSI has no idea about host names. Usually IQN (iSCSI Qualified Name) is used although EUI is also possible; you need to check your iSCSI cllient setup.

Whenever you post about a problem,

  • You should always post the exact error as displayed and probably where it came from (ex GUI, stdout, a logfile)
  • You should probably specify which type of technology you’re setting up if there are multiple choices. Last I checked, there are at least 3 different iSCSI technologies in the OSS. AFAIK Linux I/0 is the latest and is supposed to promise best performance.
  • It can be helpful to know your exact setup steps.

TSU