iscsi on 10.3 64bit - please help!

Hi, I’m trying desperately to get iscsi working on 10.3 x64.

I can find no information as to how to get this working anywhere on the net except for a suse howto that is specific to 10.1, 10.2. The step by step instructions FAIL on 10.3, /etc/init.d/iscsitarget fails as no kernel module exists.

one achived post that says “the iscsitarget package was removed in 10.2” is all i can find.

So where does that leave 10.3 users wanting to setup iscsi? why have yast modules for packages that dont exist? Why have some packages that wont work unless you install other packages that dont exist?

Am I missing completely missing something here?

i just want it to work like it does on every other distro.

thanks in advance (though i’ll be mightly surprised if anyone has any answers)

Doing this from memory, so package names can vary a bit… If you look for ’ iscsi ’ in YaST > Software Management you should have two packages you can install;
iscsitarget & yast2-iscsi-server (along with the matching kernel version you are using)

When these are installed you can configure your target through YaST > iSCSI Server.

It’s all still there & with better performance than in 10.2, so nothing has been cut here :slight_smile:

Don’t forget to set the target to auto start at boot.

Hope that helps,

Hi Wj,
Thanks, but have you actually tried that?

I only wish it was that easy.

there are only 3 packages listed in yast:


when installed, these give you the “iSCSI Initiator” and “iSCSI Target” options under yast>Network Services

When you run “iSCSI Target” it complains that it needs the package “iscsitarget” in order to run.

This package isn’t part of the SuSE 10.3 x64 distro and isnt found on the “openSUSE-10.3-Updates” or “packman” repositories. It makes no sense that a Yast module is installed for a package that doesnt exist.

Anyway, I actually found the package for 10.3 on RPMfind (god knows where it got it from) and downloaded and installed that also.

now I have 4 packages installed:


“iSCSI Target” in yast now runs and I can configure a lun etc, however there are no kernel modules, so the service fails completely. This is my problem. No Modules.

when i type “/etc/init.d/iscsitarget start” I get:

Starting iSCSI target service: FATAL: Module iscsi_trgt not found.
netlink fd
: Comnnection refused
startproc: exit status of perent of /usr/sbin/ietd: 255

if i run “modprobe iscsi_trgt” I get “Module iscsi_trgt not found”. This is because “iscsi_trgt.o” is not there at all.

I’ve also tried downloading the source tar ball from and that fails to compile at all under 10.3 (even when following the SuSE specific instructions).

why they give you yast-modules for packages that they no longer provide is beyond me. Where are the kernel modules?

This is driving me nuts!

hmmm… I’m on openSUSE 11.0 here at the moment, so cant check directly - 11.0 does have the packages though.

Do you have all the openSUSE (main, oss & non-oss) repositories added if you look in YaST > Software Repositories.
If you like you could post the output of ’ zypper lr ’ so we can check.

I have set up iSCSI for a client end of last year, and that was 10.3 if I remember correctly… :confused:

Hi Rivalz,

I’ve just checked the status for the iscsitarget packages in openSUSE 10.3
It’s there but not in the standard repros. You can get it using the build service.

The iscsitarget module is now distributed via the build service, project

Check this report for details :

Hope that sorts it for you!

Good luck,

Sorry Magic31, forgot to drop back here and let you know the buildservice rpm fixed my problem and thank you for the help.

iscsi is now working fine.

Good to hear that! Thanks for posting back!