iscan (приложения для сканирования для сканнеров Epson)

Всем привет.
Столкнулся с проблемой при работе программы сканнера iscan.

Само приложение работает сносно (я знаю про издавний баг работы приложения с кириллицей отправлял запрос в avasys результата не было или было чтото типа прекращена поддержка моего сканера). И это самое приложение нормально работало с 13.1. После обновления выдает вот такую ошибку.

http://susepaste.org/view/raw/45077424

(простите, не знаю как тут сделать спойлер)

На этом скриншоте видно, что само приложение работает (на предпросмотре виден скан документа) но я не могу сохранить по причине якобы отсутствия места. Для сохранения я выбирал директорию и имени латинскими буквами. Место на диске есть. Права на запись в данную директорию я имею. Член группы scan.
Если есть мысли по решению данной проблемы, попробую.

Данная проблема также описана тут](https://bugzilla.redhat.com/show_bug.cgi?id=888459)

Заранее спасибо
Андрей

Откуда пакет?
Можно попробовать адаптировать пакет из арча, если это этот пакет:
https://www.archlinux.org/packages/community/x86_64/iscan/

Пакеты из Epson downloads их три:

zypper se iscan

Загрузка данных о репозиториях…
Чтение установленных пакетов…

С | Имя | Заключение | Тип
–±---------------------±-----------------------------------------------------------------------±-----
i | iscan | simple, easy to use scanner utility for EPSON scanners | пакет
i | iscan-data | Image Scan! for Linux data files | пакет
i | iscan-plugin-gt-f670 | Image Scan! plugin for the Epson GT-F670 / Epson Perfection V200 PHOTO | пакет

Забил ваш Epson на поддержку, кажется это очевидно.

Кстати, didencool, из вас все нужно клещами тянуть?)) По вашей же ссылке описаны попытки фиксов с ldd и LD_PRELOAD - вы_это_пробовали? Также можно попробовать создать символьные ссылки вида “установленная версия libpngXX -> нужная приложению версия libpng”.

да я это понимаю

Я к сожалению не могу знать что может понадобиться

нет, и я вряд ли могу сказать что понимаю о чем речь.

Да только при установке никаких проблем с зависимостями не было. При запуске из консоли я тоже никаких проблем не увидел. Поэтому пока не вижу в этом смысла.

Спасибо

Да только при установке никаких проблем с зависимостями не было. При запуске из консоли я тоже никаких проблем не увидел.

Тем не менее, если в качестве зависимости выступает devel пакет, то ссылки на библиотеку libpng{12,16} будут разные.
Покажите:

rpm -qa libpng*

Имеющиеся в дистрибутиве инструменты пробовали использовать?
У меня МФУ от Epson. Сначала брал пакеты для принтера и сканера с avasys, а потом перестал - имеющихся средств стало хватать. Сканирует и печатает без проблем. Может быть в вашем случае тоже не стоит заморачиваться.

> Забил ваш Epson на поддержку, кажется это
> очевидно.

Я, в ответ, давно забил на “iscan”, когда выкинули из стандартного
репозитория.
У меня Epson Perfection 1250. “XSane” вполне устраивает.

> попытки фиксов с ldd и LD_PRELOAD -
> вы_это_пробовали? Также можно
> попробовать создать символьные ссылки
> вида “установленная версия libpngXX ->
> нужная приложению версия libpng”.

Ну, libpng12 всегда имеется, она входит в LSB.

не совсем понял при чем тут devel пакет, он ведь только если что-то компилируется может быть использован
вывод вот он похоже libpng12 не установлено

> rpm -qa libpng*libpng16-16-32bit-1.6.13-2.4.1.x86_64
libpng16-compat-devel-1.6.13-2.4.1.x86_64
libpng16-devel-1.6.13-2.4.1.x86_64
libpng16-16-1.6.13-2.4.1.x86_64
libpng12-0-32bit-1.2.51-3.1.2.x86_64

Да xsane работает, но от него невыносимо грустно =( Не знаю как это объяснить но когда сканирую в xsane цвет какой то ужасный потом его привести в нормальное состояние задачка становится нетривиальной. В этом смысле iscan лучше. simplescan не пробовал. (Когда пробовал не работал с моим сканером) Нужно попробовать еще раз.

Да вчера запуст ил
env LD_PRELOAD libpng16(полное имя) iscan

увидел проблему. Действительно ругается на libpng1.6 говорит что нужна libpng1.2 и чего то там не может перекодировать UTF-8 чуть позже выложу вывод этой строки.

Логичным мне представляется
1.Установить libpng12 (x86-64)
2.Попробовать запустить iscan с использованием libpng12 [env LD_PRELOAD libpng12(полное имя) iscan]

Спасибо

Да xsane работает, но от него невыносимо грустно =( Не знаю как это объяснить но когда сканирую в xsane цвет какой то ужасный потом его привести в нормальное состояние задачка становится нетривиальной.

Там есть куча опций по работе с цветом. Посмотрите настройки.