Is Win10 1709 compatible with VB 5.1.30?

Hi. Does anyone know pls? Is Win10 1709 compatible with VB 5.1.30 [openSUSE-supplied, not from Oracle]?

I have 3 x Win10 VMs running in TW on 2 PCs. Until ~14 days ago all 3 were 1703 & worked correctly. Sadly after that i upgraded each to 1709, & all 3 broke, with identical fault… cannot now get Win10 admin rights, so cannot install any pgms, run any command as admin, etc. Luckily i was able to rollback one VM from the bad 1709 to the good 1703, but the other 2 are stranded at 1709 [it was not til after the 10-day rollback limit on these two that i realised there was a fault].

Even doing a full “Reset this pc” to a clean 1709 made no improvement. Today i spent hours on phone with MS, & though willing & helpful Tech Support could not get past the impasse. They mentioned that the root cause might be that 1709 is not yet supported by VB 5.1.30… but i suspect that was a guess by them rather than a known fact.

I’ve been fighting this for 2 days now & will continue searching online for clues after posting this, but thought i’d take time out to raise this here in case someone already knows the answer. Thank you.

Doesn’t really sound like a VirtualBox issue?

I would imagine it’s windows and it’s developers deciding how you should use (or not use) your machine and the operating system, sounds like the feature ransome-ware and controlled folder access more likely?

Thanks Malcolm. I definitely tend to agree with you rotfl!

The last couple of days have been highly aggravating, bringing back all the bad memories of fighting Windows over all those years. Thank goodness i jumped to Linux in 2015. Though i feel dirty still touching Windows, i kinda sorta still need it here [in VMs] as i remotely support my old Dad’s Win10 pc, so i need to keep it here too so i can keep up with the latest MS shenanigans & test possible s/w for him, rather than just throw it immediately on his pc with whatever consequences.

All that said, i have still not found a way to repair 1709 on any of the VMs, so i abandoned it, created a 1703 ISO, & reinstalled that clean in one of the VMs, which is now good again. Tomorrow it’s the turn of the final dead 1709 to be obliterated & replaced with 1703.

Nice one MS [not]. Ta again.

Windows and graphics issues seem to be common…the infamous black screen…

So did you check that ‘Controlled Folder Access’ was off?

Golly, what a great suggestion, thanks. I’d not known of this, but prompted by you i have now found where it is. It’s OFF, so that’s not the root cause. However, i wonder how many other obscure new settings are buried deep in 1709 that i also don’t know about [given i have not been following, nor interested to follow, anything about this new Win10 version til it bit me]. One of those might be the root cause, or… alternatively i might just stick with my current weary supposition that 1709 is VM-borking crapware. Heehee.

A quick Google search returns a number of hits, but primarily with Win10 1709 (Fall Creator’s Update) running as the HostOS. That’s not necessarily, but can be related to your problems running as a GuestOS (different kernel modules, but possibly similar new incompatibilities).

Remember that all major MSWindows upgrades (which is what the Fall Creator’s Update is) can be rolled back in Windows(I don’t remember the exact location but it should be easy to search for the location)… So, you shouldn’t need to wipe and rebuild. Also, remember that by default in Win10 the Administrator account is hidden. I prefer to “un-hide” it so if necessary I can logon to that account and don’t have to rely on “Run as Administrator”. I don’t know if you can enable access to the Administrator account after losing “run as administrator” permissions removed, but since you say you have returned to a previous Windows version where you have that permission, you may want to do what I describe for that “rainy day”


I don’t use windows (I have it installed on a 32GB SSD), but came across a mention in a StartPage search… I hate it, every time I boot to it it takes so much time to get access back to the machine for openSUSE with all it’s updates and shutting down (~ 2 hours today)…

Thanks. Re the rollback, yes i’m well aware of that, but… as i wrote in my OP:

Luckily i was able to rollback one VM from the bad 1709 to the good 1703, but the other 2 are stranded at 1709 [it was [u]not til after the 10-day rollback limit on these two that i realised there was a fault].

On the one VM that i managed to catch before the 10 days expired, the rollback worked very well. If only i’d noticed the problem on those other two in time… Sigh. Your “wipe and rebuild” actually is the only option now open to me on 2 of the 3 VMs; even the MS Tech eventually agreed with that, once she like me found that everything she would normally try to rescue a damaged system was unavailable to her due to that UAC block [or whatever breakage lay beneath & caused that outcome]. You see, the first thing she tried was to discover the 1709 fault & fix it, but when that proved impossible the second thing she tried was some “secret” MS trick to force the rollback despite being >10 days & that option having disappeared from my [visible] Settings. She could not do that either, again due to no elevated privileges being available. That was why acquiring, creating & using a 1703 ISO became the only remaining option [her advice].

In my searches i did not bother reading anything about Windows hosts, as i assumed whatever i might find therein might be simply wrong or N/A for my scenario, which obviously is Win Guest in Linux Host.

Re your

I don’t know if you can enable access to the Administrator account after losing “run as administrator” permissions removed

I do know now, because i tried it. One of the preliminary steps in the procedure relies on being able to run cmd.exe as administrator, which… of course… is exactly what is blocked by the underlying problem. It’s a “lovely” vicious circle.

I do like your rainy day idea, which under the circumstances seems extremely wise. I shall do that today on the rolled-back 1703, the reinstalled 1703, & after redoing the third VM [currently still 1709 & broken] i’ll also do it there.

Many thanks again.

If you’re past the 10 day limit (That’s ridiculously short),
The following article suggests several methods which worked to extend the original Win10 Upgrade (from Win7 or 8.1), suggesting those methods should work for the Creator’s Update as well


OMG yes, you are soooo right - it’s just stupid to force that brevity on hapless users. Actually, probably not stupid at all, probably quite smart, but in a deeply cynical put-user-last sense.

Thanks so much for finding & sharing that page [now bookmarked for “next time”]. Given my recent ructions i was curious to see my 3 x Win10 VMs’ status. FYI:

  1. The VM on my Tower that i successfully rolled-back from 1709 to 1703.
  • $Windows~BT … does exist

.–> i’ve accordingly now renamed to “Win10_1703-$Windows~BT”. - Windows.old … does not exist

  1. The other VM on my Tower that i upgraded to 1709, but has not yet been clean-installed via my 1703 ISO.
  • $Windows~BT … does not now exist anymore

. - Windows.old … does still exist

  1. The VM on my Lappy that could not be rolled-back, & so is now 1703 again via ISO clean-install.
  • ​$Windows~BT … does not exist

. - Windows.old … does exist

A general FYI -
Problem should not exist anymore.

Windows 10 Creator’s Update Anniversary might have been patched,
But VB has also released a new version that should work

virtualbox 5.1.30-118389


Oh? Interesting, thanks.

My VB Version [per OSS repo] is only 5.1.30-4.1, so i assume that still remains no good… although maybe if Win10 is now patched, trying the update once more even with that VB# might work. Or maybe it’ll be still a mess. I had hoped that by now, or soon, the Oracle VB 5.2 might make it into the oS repos, & i was assuming that surely they [Oracle] would have ensured full compatibility with that latest Win10. But that’s just me making naive assumptions,