Is this normal?

After deleting my Ubuntu partition and using the free space to create a partition for openSUSE with 4GB swap, I installed the OS. The install ran smoothly and it even automatically set up a boot loader for my windows partition.

I logged in to the KDE Desktop. I updated through the Software Updates application, and it prompted me to reboot. When I clicked restart my screen went blank but my computer stayed on without restarting. This lasted over an hour before I decided to force a shut down by holding my CPU’s power button down.

OpenSUSE starts up fine, but after I select the OS from the boot loader the screen goes black twice while loading the KDE desktop. I’m quite new to openSUSE and have never had this problem before with Ubuntu, so I’m just curious if this is all normal? If it isn’t, any suggestions on how to fix the solution would be greatly appreciated.

I also shut down the computer last night, and it didn’t hang at all, so that’s good at least.

Thank you.

EDIT: If it helps, I installed openSUSE via the Live KDE method, on a bootable usb.

I think the first reboot during install is often done with “kernelexec” or something of the sort. The kernel is reloaded without a full boot.

When I installed on my desktop, it hung at that point. I had to power off and reboot. However, once that was done, the normal rebooting has worked fine (I reboot to Windows twice a week, to update virus table :frowning: ).

On an older laptop, the initial reboot worked just fine. However, since then I must remember to shutdown rather than reboot, for a reboot always fails.

I believe this has to do with the hardware and BIOS support for power settings.

The first thing to try in black screen situations is to boot with the option ‘nomodeset’. Depending on your graphic card (nvidia or ATI), you can later install the proprietary driver.

Alright, I’ll try that. My computer will still not restart, but shuts down fine. I’m kind of baffled on how to fix that.

@nrickert - Thanks for the suggestions!

Try to boot in runlevel 3 by appending ‘3’ (without quotes) to the boot options. Do you get a console where you can login? If so, type the following command and post the output here:

hwinfo --gfxcard | grep -i -e model -e driver

Yep, I got a console where I was prompted to log in. After doing so I ran:

hwinfo --gfxcard | grep -i -e model -e driver

However, no output was given. The console just echoed the command. It didn’t give me any errors with the syntax, though.

Maybe I’m doing something wrong? I’ve had the luxury of Ubuntu spoon feeding me (the user) throughout my usage of it. Thanks again for the help.

EDIT: After trying your suggestion of booting with nomodeset, it seemed to remove the problem of my screen losing the VGA Signal on and off during KDE’s start up. That’s a start I suppose?

OpenSUSE’s default boot option is set to VGA = 0x31a in the bootloader as well, if that helps.

And your graphics device is???

Did you log on as root?

That one should work:

**/usr/sbin/**hwinfo --gfxcard | grep -i -e model -e driver

and if it doesn’t:

/sbin/lspci | grep -i vga

Model: “ATI RADEON HD 4650”
Driver: “radeon”
Driver Modules: “drm”
Driver Info #0:

1:00.0 VGA compatible controller: ATI Technologies Inc RV730 PRO [Radeon HD 4650]

  • Boot in runlevel 3, as explained in post #5, but this time login as root.
    Check if you have an Internet connection by pinging a site. I usually ping
 ping -c 2
  • If you are connected, you can install the proprietary ATI driver by following the steps described in this post: Upgrading ATI driver with atiupgrade
  • If you don’t, you can still use the atiupgrade script but you would either have to start X ‘somehow’ (for example by using the vesa driver) and run the script twice or initiate a network connection manually in console mode. This is normally not complicated (using ifconfig + route or dhclient). However it seems not to work as expected (as far as I can tell) when the network is configured to use the network manager.
  • This is a problem. Everyone should be able to connect in runlevel 3. Someone should write a howto explaining how to connect in console mode while using the networmanager - or they should just rewrite the networmanager so that it doesn’t need the GUI - this is not Windows!