Is this laptop well supported by opensuse+kde?

I’m looking for a new laptop and I have found this model.

Acer Aspire AS5251-1805 15.6-Inch Black Laptop | My Best Laptop

If anyone has this computer, could you tell me How good it is supported by opensuse? How good Kwin works with its graphics card (ATI Radeon HD 4250)?

If you do not get a reply from an owner, you can always download a Live CD and try that.

My experience is for new laptops, one often does NOT find someone with the same laptop on openSUSE. The key thing in such a case is to search sites such as linlap for acer5252 or other sites such as Linux Laptops (I see nothing there for 5251 or Tux Mobile (I see nothing there for 5251. If they provide no indication as to Linux compatibility, then sometimes a search under the laptop name with Ubuntu or Linux will show of a Linux user with some experience … ie such as googling for “Acer AS5251 Ubuntu”. The problem with searching with Ubuntu is despite the gems of information one can find, there also is incredible misinformation because of the many new users who post inacurrate information on their forums/bug-reports.

Hence if that does not work, then look at the laptop’s components (especially graphics and wireless and sound which tend to cause the most heart burn ).

In this case, for graphics its an ATI 4250. I think that is supported by both radeon driver and proprietary driver, but I’m not sure. To see if supported by Radeon driver, on an openSUSE-11.3 PC type “man radeon” and read what is supported by the opensource radeon driver (I see no mention of radeon open source support for the HD4250, but I am not at a linux PC). For the ATI driver type in google “ATI graphic driver” and go to the ATI site and search and read their release notes to see what they say about the ATI HD 4250 and Linux support. I note on that page

ATI Integrated Product Family Support
The ATI Catalyst™ Linux software suite is designed to support the following ATI
desktop products:
AMD Chipset Product support: ATI Radeon™ HD 4250
so while the open source driver may not work, the proprietary driver should work. This may mean you need to initially use the FBDEV or the VESA graphic driver, until you can get the proprietary driver functioning. This is typically EASY for an advanced user, but new users could struggle a LOT.

For the wireless, an Acer InviLink Nplify 802.11b/g/n, I don’t know where to go there. Perhaps do a google search on it. Our wireless forum area has many stickies, and you could read those to see if they point you to a compatiblity list.

For the sound, you need to find out what sound hardware audio codec. One thing about sound and openSUSE, is the SuSE-GmbH packager for sound is also an alsa sound developer, so many (but NOT all) times if there is a sound problem with the alsa sound driver not being compatible with openSUSE, he will fix the bug and the problem IF a user takes the time to write and support the resolution of a bug report.

Good luck.

This is an excellent suggestion, assuming you have access to the laptop.

I read one site that suggested the wireless may be a BCM43225 (Broadcom) in which case you may need to use a proprietary wireless driver to get this functioning. ie possibly not difficult for an advanced Linux user, but a new Linux user will struggle.

I see a Ubuntu user notes the Broadcom open source driver (direct from Broadcom) may have been recently updated to work with this laptop: [SOLVED] My Broadcom wireless driver saga is almost to end…with your help! - Ubuntu Forums]( … I don’t know enough about this to comment, other than to say there may be a driver for it, … Often it is a ‘propietary’ and not an ‘opensource’ driver that is on a manufacturer’s web site (for wireless) but this may be the case … and its possible that an open source version of this driver is not yet available for openSUSE-11.3.

Webcam. I note on this page Acer CrystalEye Webcam on Linux / Ubuntu « The Journey of Life (where one needs to search for 5251 after loading) that someone reports the webcam on the Acer Aspire 5251 working with the opensource uvc driver.

Had to check first, but learned that I installed 11.3 on an Acer Aspire 5251. Don’t know if it’s exactly the same, the sticker on the back stating full model number has been removed. This is the little note I left the owner on her desktop:

  • Webcam works out of the box
  • Wifi needs the broadcom-wl driver from Packman
  • Videocard works great with ATI proprietary driver
  • Synaptic touchpad needs some additional settings in KDE to function like it should

So, no real problem. You may need some help, but it will work.

I have the computer at home now, but I have troubles installing the software. When I look at the bios info (by clicking f2) there are 6 boot options, including booting from the cd, but when I click f12 to get the boot options list only 3 options appear and the option to boot from the cd is not there. What should I do?

Set the BIOS to boot from CD, i.e. make it the first boot device. If the CD is inserted and does not work, you eiter did not burn it correctly or the download was corrupted.

I have made it the first boot option, but it just ignores the cd, I know that the CD works fine I check it in my desktop computer and it works just fine in there. Maybe I should call Acer?

I have one of these with 11.3 KDE 4.5.2 running very well.

Haven’t noticed anythhing no working.

Desktop effects work well with the default open source driver.

Only negative is the Toshiba HD went bad after a month of VERY light use. Replaced it with a 500GB WD Black Scorpio and it’s flying again :slight_smile:

You may want to look closely at the boot sequence gui to be sure you have it set correctly before sending the machine back to Acer.

When my HD went out I changed my bios to boot first from USB and had to go back to bios setup a couple times to get it right.

The bios gui seemed a bit confusing.

How much age difference between the PC where the CD was burned and this laptop ? I’ve encountered cases where a CD burned on a new PC would not work on an old PC (but worked ok on the new) and also I’ve encountered cases where a CD burned on an old PC would not work on a new PC.

The best way to mitigate the possibility of that happening is to burn at the slowest speed possible, on a CD +/- R and NOT on an RW. Also use a high quality CD media and not some bargain basement special. Even with that precaution an age difference can cause a problem.

For the graphic:

My notebook use ATI Radeon HD4300 which runs perfect with the ATI driver (fglrx).
The opensource driver Radeon also works.

Look in your BIOS to see where it is telling you show LOGO screen and turn it off. You can trun this back on once you have it set or leave it off so you can see the prompt for boot from CD. The LOGO screen some times hides the “boot form CD prompt”. When it tells you boot from CD you have to hit a key or it will boot from the first hard drive. Compines like to hide this screen because most users dont need to see it.