Is this Graphics Card running Optimally?

How do I know if my graphics card is running optimally? I installed the nVidia driver with the one click method, rebooted and that’s it. Graphics are not that smooth. Even web pages don’t scroll smoothly. Videos in full screen on YouTube are very slow etc.

openSUSE 12.1
Gnome 3.2.1
Intel Pentium 4 CPU 2.20GHz
GeForce GT 430 PCI
MemTotal: 2GB

00:02.0 Display controller [0380]: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device [8086:2562] (rev 01)
	Subsystem: Dell Device [1028:0160]
	Kernel driver in use: i915

02:00.0 VGA compatible controller [0300]: nVidia Corporation GF108 [GeForce GT 430] [10de:0de1] (rev a1)
	Subsystem: ZOTAC International (MCO) Ltd. Device [19da:2200]
	Kernel driver in use: nvidia

I can give more info if needed, just ask please.

Thanks, Kirk

I note your Dell has two graphics chipsets. Is it a laptop with switcheable graphics? Or is it a desktop system which has onboard graphics and an nvidia card added? Can you clarify this picture a little?

It’s a desktop system with onboard graphics and an nVidia card added. Thanks.

Does disabling Kernel Mode Setting (KMS) with YaST help ? You can disable KMS by navigating to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”. This takes a minute or two to save once changed is submitted. You will then need to restart openSUSE GNU/Linux to see the affect on your nvidia driver functionality.

I also find on my PCs with nVidia harward and the nvidia proprietary graphic driver that I need to blacklist the nouveau graphic driver when I want to use the proprietary nvidia driver. I blacklist this in /etc/modprobe.d/50-blacklist.conf, … but its possible your installation method for the nvidia driver (where I do not use that method and hence I am unfamiliar with it) may blacklist the nouveau driver somewhere else. There is a plethora of methods that users apply to blacklist the nouveau graphic driver (of which only any one is needed) which I believe is confusing to new users.


There are usually an option in Bios for disabling the built in graphics on Desktop computers and as oldcpu said blacklist the Nouveau driver in “/etc/modprobe.d/50-blacklist.conf”

Another thing is checking the powermizer in “nvidia-settings”, when you start “nvidia-settings” it also will inform you if it uses the nvidia driver.

In powermizer, change from “Adaptive” to “Prefer Maximum Performance” and see if that makes things smother graphic-wise.
That Adaptive setting makes nvidia graphics very uneven as it changes and not changes at apparently random times.

If it works you might wanna go to the nV News Forum and do a search for how to start in maximum performance level, think there is a good solution there.

Kind Regards Thermal…

I found the nVidia open source driver works far better than the closed source driver. Sometimes you just don’t have to install the proprietary drivers.

nVidia Corporation
Model: GeForce 8400M GT
2D driver: nouveau
3D driver: nouveau Gallium (7.11)

This performed far far better than the nVidia official ones.

Also I’m using a laptop and on installing nVidia’s original drivers my brightness buttons ceased to work. With nouveau drivers all my extra buttons work.

Interesting stuff. Is disabling kernel mode setting an on/off thing? Can I give it a try and revert easily if it makes things worse? About the nouveau driver being blacklisted, how can I check if it is indeed blacklisted? I didn’t consciously disable it.

The BIOS has an option for “auto” and “on” for my onboard graphics. I have it set for auto. Here is the output of my “/etc/modprobe.d/50-blacklist.conf”. Thank you for taking an interest.

# $Id$
# Listing a module here prevents modprobe from loading it via modalias (only
# aliases from /lib/modules/*/modules.alias). You may still load it explicitely.
# We blacklist some modules becaus they may harm on certain devices or they
# prevent other modules from grabbing the device.
# Syntax:  blacklist <driver name>
# See 'man modprobe'.

# uhci ... usb-uhci handles the same pci class
blacklist uhci
# usbcore ... module is loaded implicitly, ignore it otherwise
blacklist usbcore

# tulip ... de4x5, xircom_tulip_cb, dmfe (...) handle same devices
blacklist de4x5
# At least 2.4.3 and later xircom_tulip doesn't have that conflict
# xircom_tulip_cb
blacklist dmfe

# list all framebuffer drivers, some of them tend to crash during boot
# they are either compiled into the kernel, or vesafb is active
# X works fine without them, rcfbset can load them if really required
#  sed -e '/\/drivers\/video\/.*\.\(o\|ko\)$/{s@^.*/@@;s@\..*$@@;p};d'
blacklist aty128fb
blacklist atyfb
blacklist clgenfb
blacklist cyber2000fb
# cyblafb, bug 466280
blacklist cyblafb
blacklist encode-big5
blacklist encode-gb
blacklist encode-gbk
blacklist encode-jis
blacklist encode-kscm
blacklist fbcon-afb
blacklist fbcon-cfb2
blacklist fbcon-cfb4
blacklist fbcon-hga
blacklist fbcon-ilbm
blacklist fbcon-iplan2p2
blacklist fbcon-iplan2p4
blacklist fbcon-iplan2p8
blacklist fbcon-mac
blacklist fbcon-mfb
blacklist fbcon-vga
blacklist fbcon-vga-planes
blacklist fbgen
blacklist g450_pll
blacklist hgafb
blacklist i2c-matroxfb
blacklist i810fb
blacklist intelfbdrv
blacklist intelfbhw
blacklist matroxfb_accel
blacklist matroxfb_base
blacklist matroxfb_crtc2
blacklist matroxfb_DAC1064
blacklist matroxfb_g450
blacklist matroxfb_maven
blacklist matroxfb_misc
blacklist matroxfb_proc
blacklist matroxfb_Ti3026
blacklist mdacon
blacklist neofb
blacklist pm2fb
blacklist pm3fb
blacklist radeonfb
blacklist rivafb
blacklist sisfb
blacklist sstfb
blacklist tdfxfb
blacklist tridentfb
blacklist unikey
blacklist vga16fb
blacklist vgastate
blacklist vmware
# for kyrofb see Bug 35810
blacklist kyrofb
# list was not complete (bug 106715)
blacklist arcfb
blacklist backlight
blacklist lcd
blacklist cirrusfb
blacklist gx1fb
blacklist intelfb
blacklist macmodes
blacklist nvidiafb
blacklist s1d13xxxfb
blacklist savagefb
# additional modules since SLE11, bug 468964
blacklist arkfb
blacklist carminefb
blacklist gxfb
blacklist hecubafb
blacklist lxfb
blacklist s3fb
blacklist sm501fb
blacklist viafb
blacklist vmlfb
blacklist vt8623fb

# ISDN modules are load from /lib/udev/
blacklist fcusb
blacklist fcusb2
blacklist fxusb
blacklist fxusb_CZ
blacklist fcdslusb
blacklist fcdslusb2
blacklist fcdslusba
blacklist fcdslslusb
blacklist fcdslslusb2
blacklist e2220pc
blacklist e5520pc
blacklist bfusb
blacklist b1isa
blacklist b1pci
blacklist b1pcmcia
blacklist c4
blacklist t1isa
blacklist t1pci
blacklist divas
blacklist act2000
blacklist hfc_usb
blacklist hisax
blacklist hisax_fcpcipnp
blacklist hisax_st5481
blacklist hysdn
blacklist icn
blacklist pcbit
blacklist sc
blacklist tpam
blacklist fcpci
blacklist fcclassic
blacklist fcdsl
blacklist fcdsl2
# mISDN modules
blacklist hfcsusb
blacklist hfcpci
blacklist hfcmulti
blacklist l1oip
blacklist mISDN_dsp
blacklist mISDN_core

# OSS PCI sound modules
blacklist ad1889
blacklist ali5455
blacklist btaudio
blacklist cmpci
blacklist cs4281
blacklist emu10k1
blacklist es1370
blacklist es1371
blacklist esssolo1
blacklist forte
blacklist i810_audio
blacklist maestro
blacklist maestro3
blacklist nm256_audio
blacklist opl3sa2                 # Bug 219758
blacklist rme96xx
blacklist sonicvibes
blacklist trident
blacklist via82cxxx_audio
blacklist ymfpci

# If you really need firewire direct networking, then remove this entry
blacklist eth1394

# this is a debugging module which should only be loaded manually
blacklist evbug

# These mtd drivers should be loaded manually.
blacklist scb2_flash
blacklist ich2rom
blacklist pci
blacklist l440gx
blacklist amd76xrom

# job of rcdvb
blacklist snd_bt87x
blacklist snd-bt87x

# HP Touch Screen usb input driver. breaks all other mouse input devices
blacklist tsdev

blacklist slamr
blacklist slusb

# This module seems to be good for nothing. See bug 129301.
blacklist dpt_i2o

# This driver is obsolete and should never be loaded as default.
# See
blacklist eepro100

# This driver is obsolete and should never be loaded as default.
# See
blacklist sk98lin

# This driver is rarely needed and causes trouble when scanning devices.
# See:
blacklist stradis

# These devices have bt878 chip without PCI Subsystem ID. Without that info bttv
# does not know how to treat them properly. Therefore we disable autoloading of
# modules for these devices.
# See
# To enable your device create a hardware configuration file for your device.
# See man hwup for details.
# You will probably have to specify an option to identify your card. Have a
# look in /usr/src/linux/Documentation/video4linux/CARDLIST.bttv.
alias pci:v0000109Ed0000036Esv00000000sd00000000bc04sc00i00 bttv_skip_it
alias pci:v0000109Ed00000878sv00000000sd00000000bc04sc80i00 bttv_skip_it
install bttv_skip_it /bin/echo "module alias skipped (bt878 chip without PCI Subsystem ID)"

# For some bridges both intel-agp and i82875p_edac are loaded. If i82875p_edac
# is loaded first it will grab the device. Then intel-agp doesn't work.
# Therefore we disable automatic loading of 82875p_edac. (Bug 213840)
blacklist i82875p_edac
# Blacklist the IBM s390 module for I/O dynamic configuration support
# Bug bnc#478601
blacklist chsc_sch

"In powermizer, change from “Adaptive” to “Prefer Maximum Performance” and see if that makes things smother graphic-wise"
This is a great tip. I’ve know about it, but don’t always think about using the setting. I wish it would stay set.

I was surprised how well my display worked out of the box with the nouveau driver, however I have to use Gnome in fallback mode which is not acceptable to me. Have you been able to use the full Gnome Shell with the nouveau driver installed in your system?

Actually this is already set to “yes” by some default (not of my own).

On KMS: It’s set to “yes” by the NVIDIA install per rpm.
On blacklisting: /etc/modprobe.d/50-blacklist.conf is the place to blacklist nouveau. No other. Put the line at the end of the file, makes it easier to trace back changes you made to it.
Doesn’t the BIOS have an “OFF” option next to “AUTO” and “ON”?

To find out what’s being used on the desktop, start the desktop, open a teminal window and do:

glixinfo | head

linux-ppzo:~ # glixinfo | head
glixinfo: command not found
linux-ppzo:~ # 

Thank you.

That should be

glxinfo | head
kirk@linux-ppzo:~> glxinfo | head
name of display: :0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control, 
    GLX_EXT_swap_control, GLX_EXT_texture_from_pixmap, GLX_ARB_create_context, 
    GLX_ARB_create_context_profile, GLX_EXT_create_context_es2_profile, 

Right on. Now…what does all that mean? lol!

Here’s some more info that might be of use to you…

kirk@linux-ppzo:~> glxinfo | grep -i render
direct rendering: Yes
OpenGL renderer string: GeForce GT 430/PCI/SSE2
    GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image, 
    GL_NV_parameter_buffer_object2, GL_NV_path_rendering, 
    GL_NVX_conditional_render, GL_NVX_gpu_memory_info, GL_OES_depth24, 
    GL_OES_fbo_render_mipmap, GL_OES_get_program_binary, GL_OES_mapbuffer, 

It just means that 3D acceleration is working. What frame rates are reported by ‘glxgears’?

I don’t have that and I’m not sure how to get it.

Here’s a screenshot of some flash info watching a youtube vid at 480. Anything over 360 is not smooth at all.](

I don’t have that and I’m not sure how to get it.

Yes you do. Its provided by the same package that contains the ‘glxinfo’ utility. From a terminal, type


Here’s a screenshot of some flash info watching a youtube vid at 480. Anything over 360 is not smooth at all.

Is this streamed video you’re talking about, rather than local content? This might have more to do with your internet connection. Do mpeg files play ok?

You’re right. My internet speed will have an effect. However, I have fast internet speeds over 8Mbps. I did just uninstall the Novouex driver. It seemed to help a little overall performance. I can’t help but think I can squeeze some more juice out of this graphics card. I just don’t even have any benchmarks or anything like that.

I don’t use Gnome since Gnome 3 came out. I use KDE and to be honest I can’t believe I let this Desktop pass me by. KDE is far better than Gnome and highly stable. However, your question, yes I did try it out in Gnome 3.2 out curiosity, everything works perfectly, no fallback mode needed. I didn’t hang around long. Rapidly reboot into KDE. You see the problem is I love widgets and Gnome just doesn’t cut it with widgets unlike KDE.

But yeah the open source driver at least for me perform much better on both environments.