Is there some stability problem with Leap x.x?

I have an old MSI Winbook that’s been running SuSE 11.4 as a file server continuously for 10-20 years. (I’d have to look it up.) It’s rock steady.

What’s up with the newer distributions…Tumbleweed, Leap 12.x, 15.1, 15.2 ??? My experience is they range from unusable to just extremely unstable.

I’m currently using Leap 15.1 & 15.2 and they are guaranteed to crash, such that they cannot be brought back & must be reinstalled, MONTHLY!!

Can somebody tell me what might be going on with my systems? I’ve investigated, but I have absolutely no clue. It seems that encryption may have something to do with it. Also, my installation disk is over a year old so it seems to matter if I go slowly and run any updates at each step…I don’t see why either of those things should matter if all the updates are done at the end of the instal. (If I umount all encrypted disks & clear the cryptab file, things seem to go better. But if I shutdown, or a machine crashes while encrypted disks are still mounted, the probability is very high the machine will not reboot. Also, under 11.4, as the machine boots, if I don’t enter the encryption passphrases, I can just mount the disks when the boot is finished. Under Leap 15.x if I don’t enter the passphrase correctly during boot on the first try, a crash is likely.) SSDs cause trouble. exfat causes trouble…there’s no end.

Also, any time I do trace back odd things, they always trace back to Github which seems to be a nest of hackers allowed to add routines to the OS willy nilly. Every time I trace some error to Github the repository is full of some wacko pix, videos, facebook links & tweets.

The only common problem is something will go bad, I reboot, & I get the same message: **give root password for maintenance or press ctrl+d to continue **neither of which leads to any success. Why does Leap need a Recovery Mode? 11.4 has no Recovery Mode. Is 15.x prone to crash?

I have older systems with AMD chips, Mini-ITX boards, and also ASUS & Dell laptops. But I just bought a new Lenovo IdeaPad which seems to be the latest hdwr and it’s doing the same thing.

I’d stick to SuSE 11.4 but the versions of FireFox won’t access any secure sites any more.

Does anyone have a suggestion of where I should look for a solution? Please, no newbies. Don’t start asking me if I’ve turned my system off & back on. I know how to reset a system. I know how to configure a LAN. Under SuSE 11.4 my LAN had 8 machines, all controlled by vnc, & all the drives on each machine were mounted on all the other machines. With Leap I can’t even get smb to start.

I run a KDE desktop. It’s somewhat slow, but acceptable. Under SuSE release 12.x (I don’t remember…Leap or Tumbleweed) it was slower than molasses for copying files.

Any suggestions from anyone who has seen or solved these problems would be appreciated. I can’t believe SuSE would survive if everyone was having these problems, so it must be something I’m doing/not doing.

Leap 15.2 (and, before that, Leap 15.1) have been very stable here.

There was a similar recovery mode for 11.4. I guess you never ran into it. I have not run into that with 15.1 or 15.2.

Most commonly, that happens when there is a problem with a hard drive. Either it needs a manual “fsck”, or perhaps the drive itself is failing.

SLES 11.1 that I ran (over 11,000 machines) had recovery mode - almost every day I had to fix a box somewhere in the world due to power outage or other corruptions, in over 70% of the time an FSCK was the solution. 20% of the time it was a broken LVM mirror and the boot side was the issue so I had to manually boot off of the good LVM drive - it was hardware the rest of the time - bad memory, failed cpu, missing drives or users deleting required system files (hmm - where is (/bin or /etc or /sbin - oops someone deleted it.).

I have never encrypted the boot and root partitions. I have encrypted mounted file systems with sensitive data on them. I never put anything that I did not want to be accessed on the root partition.

I have 35 15.2 machines - 9 are laptops - 3 are desktops - 8 are USB bootable stick for repairing systems 4 are Legacy Bios and 4 are UEFI - the remaining are VirtualBox Virtual machines running on the 9 laptops.

Why are my recovery USB’s Legacy and UEFI - you cannot repair the grub2 stuff on a UEFI system from a Legacy Bios boot and UEFI will not boot on an Legacy Bios machine.

I practice recovering all 12 real hardware computers every quarter to make sure that they can be recovered.

Supporting 1000’s of computers - I had to figure out how to do bare-iron recoveries on NCR, HP, and IBM flavors of UNIX and then SLES 11.1. I got pretty good at it.

To determine if your hardware might be the issue - I would get your flavor (KDE) of Gecko Linux (it available as OpenSUSE 15.2 and Tumbleweed ready without an install) and run it from a USB drive. It will remember any changes you make - if it is stable - you have other issues. I would find a USB 3.0 SSD drive to try it from - they are sometimes faster than the internal hard drives.

Thank you nrickert & larryr. You’ll forgive me if I seemed to have an attitude but on all kinds of forums it’s been my experience that there are people who have ACTUALLY seen a problem. They may not have the solution but they can at least give relevant comment. There are other people who, like the drunk on the next bar stool (I tended bar about 20 yrs ago), just want to talk & have little of value to offer.

What follows is a lot of background. My current question is in the last paragraph or so, if you want to skip my story/drivel.

I’m not a computer professional but my ‘literacy’ began in the 1960s when, in 8th grade I was sent to a Saturday computer school at IIT in Chicago. At that time, we never saw the machines as they were the size of a building & under lock & key. All we dealt with were IBM punch cards. Basically, they taught us BASIC, gave us cards punched with instructions & data, we were to put the cards in order & turn them in. If the cards were in proper order, they ran & we got a print out. If not, we got the cards back & a chance to reorder them. For me, the concept of looping execution with if/then statements was irresistible.

In the 70s, when the Timex Sinclair came out for $100, I was hooked. Next was the Actrix, a Compaq suitcase clone the size of a typewriter. Screen & floppies in front, printer & modem cups on top. From there on all I could afford was used equip, which is why I have so much. I have so many machines because, years ago, each machine ran better & faster if I only used them for 1 or 2 processes each. Now I just separate data, video, & mail on different machines. The controlling machine on my desk is fast enough for random, intense multitasking…50-100 windows on 15 desktops at a time.

So now I’m 71 & short on patience sometimes.

At any rate, again thank you both for your replies. Your answers were helpful if only to establish you’re the type of people I’m looking for.

I’m quite surprised you say there is a recovery mode for 11.x. Either I never noticed or, because I never needed it, I don’t remember seeing it. But that is good to know. (Coming back from 3 paragraphs down, this seems to be a good place to insert the fact that, also I may not know because I think all of my 11.x machines are single boot so there is no boot menu showing the recovery mode. I apologize for not checking those machines now but those machines are so stable, they are located in odd places. To see the boot menu I’d have to reboot, & that can mean an awkward process because of the location of the machine. As I’ve said, those machines are rock solid. They run for years at a time without attention.)

Next, it has occurred to me that there might be a problem with drives, but if there is, it’s not hardware. I’ve had this problem with brand new drives, rotating disks & SSD, older drives also. But every time I’ve tested with smartctl, nothing fails. This has led me to wonder if there is some timing problem, machine language instruction problem, or OS glitch which causes a failure…but I have no evidence of this.

The next variable added to the New/Old x HDD/SSD mix is encryption. I too have always set the / & /home directories on one, unencrypted physical drive or partition & my data (basically, everything else) on a separate physical, encrypted drive or partition. The earliest reason I had for doing this was simply Windows upgrades…never because of crashes, though when I started the segregation, I realized it would be a benefit if something crashed.

My next thought is that something is happening with the OS as, in addition to the unrecoverable crashes, when I moved to SuSE 12.x or 15.x, I found I had an inability to mount external (on other machines on my LAN) drives on my controlling machine. Under 11.1-11.4 I was able to mount external drives on my controlling machine. This allowed me to write directly to the external data drive from the program I was using. Without mounting the drives, I have to save the data file, then copy it to the external machine. That winds up being Waaaaaaaaaaayy more that a doubling of effort. I can elaborate on that if you ask, but for now, take my word for it. It’s a serious pain. (I’ve since come to suspect some kind of ssh problem, but I haven’t had time to investigate this.)

This traced to the fact that, under 15.1 & 15.2, smb, the Samba daemon is not loading on my desk (controlling) machine. I have NO clue as to why it will not load.

Beyond that, I’m experiencing transient, varying changes. Things that come & go. For instance, Samba would work between some machines & not other. And it would change. Some machines today, others tomorrow. I imagine it was not exactly random, but try as I might, I could find no pattern to try & trace down.

Then suddenly I was able to access external machines in the Network folder. Turns out they were showing up as SFTP drives…which allow me to access the drives/data, but NOT mount them, which is why I have to copy the data files (mostly correspondence or spreadsheets) to my desk, work, then copy them back. That, I have an idea is some sort of SSH problem…either a key, or an implementation fault.

Most recently I’ve found an inability to copy files. When the users are the same, I can’t copy because I don’t get a dialog box to enter the user ID & password. When the user permissions are different, even if I change the permissions, I can’t copy. Again I think that’s because I’m not getting the ID/password dialog box. To cure this I have to reboot.

I generally leave all my machines running 24/7 because it takes 15 min just to start them all. I like to be able to walk into my spare bedroom & google something whenever I want.

I have done little in the way of examining logs after crashes. When I’ve tried, the logs are voluminous & when I’ve gone through them I found nothing…so I stopped doing it. Plus, I had no idea of what I was looking for, so it seemed a waste.

****** The one thing I found under Leap 15.1, along with “enter password for recovery or ctrl D to continue” is a “bad or missing mtab” message. I have not seen the missing mtab thing under 15.2. I have not found a way to fix the mtab problem. *******

This is now getting to the present. And I might add here, that, in the rare case I had an 11.x ext2 crash, I found that all I had to do was run fsck on the root partition & that fixed everything. Once they released ext4 (or whatever version it was), I almost never had a crash. I assumed the journaled file system almost completely took care of data corruption due to interrupted power crashes.

But under 15.x I have not been able to recover from a crash in any way. When I am able to fsck the root, it generally gives me the bad super block message, & using the recommended numbers gets nowhere.

My 11.4 machines are Gnome, which I found exactly what I needed. When Gnome dumped the classic desktop & went to 3.x I found Gnome totally useless & I switched to KDE Plasma with the animation effects turned off.
My desk/controlling machine is a Mini-ITX board, AMD A6-3650/Radeon x86-64, 8Gig memory, Seagate 320Gig + 2 WD 7.25Tb.

The machine I just bought is a Lenovo IdeaPad, Pentium 6405U, 4Gig memory, 1Tb SSD. Delightfully fast for a Walmart Black Friday $150 special…though I replaced the 218Gig SSD with a $150 1T SSD. I tried expanding the encryption for the first time to include /home but when that machine suffered the crash within hours of installation, I decided that, as I suspected, encrypting the home directory was just way more trouble that it’s worth.

I’m using LG GP50NB40 & SP80NB80 USB DVD burners.

I’m seriously thinking of just installing a dual boot 11.4 & 15.x on all my machines as reinstallations come up. I can do all the writing & spreadsheets I want on 11.4 & just boot to 15.x when I want to use FireFox. I have the feeling that I will find the reboots too time consuming & I would wind up with 2 machines on my desk. But the dual boot will work in the Lenovo which I bought for the road.

That’s all I can think of for now. (Probably waaaaay more than you wanted)

Hm, in fact it is. To be honest, even in your first post I had troubles to find the technical facts about your problem between the rest of the story. Please remind that this is in the technical help section of the forums. To stay attractive to those that
try to help others in their spare time, it is in your interest to be concise and technically descriptive when seeking help. We have sub-forums like General Chitchat and Soap box for things like general chitchat, etc.

PS. Even in the days of 11.4 the name was, and it still is openSUSE and not one of the wrong spellings you use.

My spelling?? My spelling? First, as I said above, I’m looking for people who have had/seen the problem I describe, & their experience with it or their solution to it. Not the people who just want to talk. I’m definitely NOT looking for someone to research my problem in detail from the bottom up. I’m just looking for anyone who already has a similar experience and can offer some help off the top of their head.

Let me tell you a story…long ago I used to refer to floppies as 3" or 5" when discussing things. The people who had something to contribute knew I was talking about 5.25" or 3.5" disks. They let it go, & contributed whatever significant info they had. The other people, who had never seen the problem, had no idea of what was trying to be solved, but wanted to be the center of attention nevertheless, would nit pick that my characterizations of floppy disks were off by a fraction of an inch. A fraction which was insignificant because there was no doubt about what was being referred to because after 8" floppies, there are only 2 left.

The reason I went into such a long winded story about my problem is, first, because of my age & the fact that I’m shown as a new contributor (even though I’ve seen more than one SuSE forum close down including the Novell forum when Novell used to own SuSE) people sometimes conclude that I’m 17 yrs old & have just bought my first ChromeBook, or that I’m too old to understand hip new software. Second, I’m an operator/user not a developer or programmer. The problems I have occurr within such broad circumstances I almost never have the luxury of making tiny changes one at a time to narrow down diagnostic possibilities. So I present those broad strokes hoping to (again) find someone who has encountered the same or a similar problem.

Come to think of it…it just came to me what misspelling you might be referring to. You mean when I use the lower case u in SuSE?? I’m from the US, but, among other things, I went to Ferienkurs in Salzburg in the summer of '69. If you’re Niederländer, I’m surprised you don’t know that SuSE is Software und System Entwicklung…small u. Not to mention that, in addition to openSUSE there’s SLES, SUSE SLE, I’m sorry I can’t keep track of all the different ways to refer to SuSE or the many exact sizes of floppy disks.

I’m 71 yrs old. If I had back all the time I’ve wasted explaining this to that second group of people, I’d probably be 52. I’m not looking for chit chat. I’m looking for a direction toward the solution to a very broad problem. A problem so broad & longstanding that I have absolutely no clue as to which direction to begin looking. A problem which actually seems to increase & grow broader, which is why I asked if there might be an OS problem with Leap 15.x. (or LEAP…or LeAP…or LeAp…whichever you prefer. Honestly, after I wrote those posts I did think I could have specified that I was using openSUSE but I’ve been assured by people who claim to know that the only difference be openSUSE & SLES is that one comes with paid support & the other is free.) I’d be happy if someone could even point me toward the exact, narrow problem, let alone the solution. If I knew the problem I could find the solution myself.

If you don’t know the answer, you don’t know…actually, I was already given the answer to the actual question I first asked: There is no particular stability problem with Leap x.x. Unfortunately, that doesn’t help me. I must keep looking.

Moved to General Chit-chat.

Thank you for that. I install all my OS as legacy for the same reasons. I’d generically say that legacy is more flexible. I’ve never found a particular need for UEFI. Also, your suggestion of booting from a USB drive is interesting. I’ve always found USB drives, even SSD drives to be slow. But I haven’t bought a USB SSD for quite a while and the SSD I just installed in the IdeaPad, touted as state of the art, seems to be quite fast. I’ll have to try that. You’re talking about a complete install from the install disk to a USB drive, not a USB drive with a copy of SuSE CD Live on it, correct? (I think you must be. I wouldn’t be able to permanently load any additional software onto a USB copy of CD Live, would I?)

If you mean that, it’s a MSI Wind Netbook, they were announced at the 2008 CeBit – 12 years ago – 1 GB or 2 GB of RAM and 80 GB to 250 GB disks …

If Leap 15.2, your installation disk has been written some time this year …

That message means that, the system has entered the systemd Rescue mode – you’ll need to enter the root user’s password and check the systemd Journal for the reason the system didn’t boot correctly …

Given the amount of RAM available – Leap 15.2 needs at least 1 GB of RAM – better 2 GB of RAM – you’ll have to be careful about the system you install on the box.

  • My suggestion is, because it’s a file server, an installation role of “Server” – no GUI …

Disk space – plus encryption – may I suggest that, the default Leap Btrfs file system should be avoided – stick to ext4 for the system and user partitions – I suspect that, XFS for the user partition will stretch the system’s resources.

Pay careful attention to the amount of disk being used for the /tmp/ and /var/ directories – if they run out of space, the system will become unstable …

From the openSUSE installation medium, run the Firmware and Memory tests …

You know, the more I think about it, the more I think that’s an outstanding suggestion. The reason is, I can easily have 2 or more of those USB installs. If one crashes, I can use the second immediately & also immediately overwrite an exact copy to the crashed drive as a repair. I wouldn’t have to reinstall the system. I could just copy an .iso from any available backup.

There might be a few considerations such as keeping website bookmarks current. But that should be trivial compared to constantly reinstalling systems from scratch.

It even seems like it might be a good idea to always install my OS on an external drive. In addition to being able to just copy an .iso rather than do an installation, it might even be easier to maintain systems with dual, triple or quadruple boot structures on external rather than internal drives. I’ll have to give that more thought. I don’t really need external drives all over the place. But I think it may be a very useful idea. Esp as I’ve been avoiding testing other Linux distros (esp Ubuntu) because I’ve thought my problems were all kernel related. Unless I’m mistaken, generally, all distros are using the same kernel, no? The differences are mainly in the desktop, no?

I could have sworn it was much older than that but I looked & the oldest files I can find are from 2008 so you must be correct. I’ve never done an exhaustive check but I regard MSI as a top brand. That machine has been running continuously since I got it. I put a 1T drive in it when I got it.

That message means that, the system has entered the systemd Rescue mode – you’ll need to enter the root user’s password and check the systemd Journal for the reason the system didn’t boot correctly …

How do I do that…“check the systemd Journal”? Is it a regular log file? Where & what name. I can find it if I know where and what to look for. I know I should have done this long ago. But usually I can tell what the problem is by what the machine does…so I’ve never gotten deeply into log files.

Given the amount of RAM available – Leap 15.2 needs at least 1 GB of RAM – better 2 GB of RAM – you’ll have to be careful about the system you install on the box.

  • My suggestion is, because it’s a file server, an installation role of “Server” – no GUI …

Disk space – plus encryption – may I suggest that, the default Leap Btrfs file system should be avoided – stick to ext4 for the system and user partitions – I suspect that, XFS for the user partition will stretch the system’s resources.

Pay careful attention to the amount of disk being used for the /tmp/ and /var/ directories – if they run out of space, the system will become unstable …

All my machines are 4-16 gig memory. I have few drives smaller than 1T. Usually my root partitions are 100 Gig or larger. And, yes, as soon as I started having these crashes I stopped testing Btrfs & XFS. Everything I have is ext4. And I generally don’t let my disks get more than 75% full. I usually keep 20-30+ gig empty.

From the openSUSE installation medium, run the Firmware and Memory tests …
Yes. I do if I suspect any problem.

The systemd Journal is inspected by “journalctl” – “journalctl --this-boot” for the system Journal of the current boot – “journalctl --list-boots” to list the system boots in the current Journal …

  • systemd maintains it’s Journals in a sub-directory of ‘/var/log/journal/’ – they’re binary files and can only usefully be inspected by means of “journalctl” …
  • If a user invokes “journalctl” they can only inspect the Journal entries related to that user’s sessions …
  • The Journal entries related to the system can only be inspected by the user “root” or, a member of one of the “systemd-journal”, “adm” and “wheel” user groups …


Given that, you’ve not been penny-pinching with disk space, consider setting up with separate partitions for /tmp/ and /var/ …

  • I’m currently running with about 4 GiB for /tmp/ and, 20 GiB for /var/ …
  • But, 1st check the systemd Journal for the reason why the system boot landed in the Rescue mode …

Thanks. I checked that. It took about 2.5 sec to see, “Please fix the “kio_sftp” KIO slave” which was meaningless to me. It took another 2.5 sec to find

“This is a known issue with Dolphin and ECDSA keys. OpenSSH in recent versions have moved to use ECDSA by default over RSA, and this works fine with most implementations that rely on OpenSSH’s “known hosts” file.”


In my original posts, I’m writing that SuSE 11.x works fine out of the box but I have LAN troubles with Leap 15.2, nobody thinks to mention that in 15.2 ssh doesn’t work properly & a moderator tells me that my question is chit chat, not technical & specific enough!!!

Personally I’d say that the current implementations of SuSE (I guess technically it’s only KDE) are buggy as heck. THERE’S A KNOWN ISSUE WITH DOLPHIN…THE OS FILE BROWSER!!! And this is just the tip of the iceberg I easily found in my first search!!!

But in the spirit of ‘Count your blessings’ I did get 2 good suggestions: journalctl & the tip about booting from an SSD.

Let me return a tip: It can be better to cry than to laugh. What that means is, it’s better to say, “There are bugs in the OS, here they are, & this is what to do about it.” than to say, “Nothing’s wrong.” and have people have nothing but problems, get disgusted, & dump your product.

I’ve suspected for quite some time now that there’s been something wrong with ssh in Leap x.x but I had no confirmation & it seemed too big a task to begin researching.

I see now I have no choice but to begin the task,no matter how onerous. But what this REALLY, REALLY, REALLY, REALLY confirms for me, is that when Microsoft bought into SuSE, it wasn’t because they were hoping to better the OS, or give people a better option than Windows. They did it to make more money, enslave more people to their paid OS, & throw as many monkey wrenches as they could into the emerging Linux community.

We may be getting new leadership in the US. But rest assured: Greed is still alive & well in the business community.

From the description of your problems, I’d have suspected your primary suspect is your disk drive although you say it isn’t…
Still, if you’ve been using your machine daily, I’d recommend it’s still suspect if it’s over 5 years old (and keep in mind that most consumer grade drives aren’t sold with factory warranties over 3 years).
If drives aren’t your problem, then the next thing to check is your memory. Particularly if your memory is the original installed in your system and depending on your environment, pull your RAM and clean the electrical contacts with a pencil eraser and re-install. As long as you have your machine open, you may want to clean the electrical contacts for your disk drive as well (if it’s easy access).
If you end up buying a new drive, of course consider an SSD, even if your Winbook fails you can transfer the drive to another machine either internally or as an external drive.

Next thing I’d suggest is to consider if you really need to encrypt your drives.
Some people misunderstand what kind of threats drive encryption protects you from… It won’t protect you from malware, viruses and other threats when your machine is running, it only protects you when the machine is powered off and your machine is stolen.
If you need that kind of protection, so be it but don’t encrypt if you don’t need that kind of protection.
Encrypting is just another layer where the Peter Principle can bite you… Extra exposure to potential problems.

As for your problems specifically with newer OS nowadays…
You should know that unlike the older OS you remember ran well, today’s OS is a lot less likely to cause problems than yesteryear.
Whereas in the old days there was a lot of reading and writing to disk, nowadays there is reading and not much writing… most of that writing to disk is now written to RAM.
And, that is perhaps a good reason to not run KDE Plasma if you have only 4GB of RAM, which might be enough but if you’re a relatively heavy User probably isn’t anymore and you may be writing to swap.

If you like KDE Plasma, consider installing LXQt as an alternate Desktop.
LXQt uses the same Qt framework most KDE Plasma apps use, so from within LXQt you’ll be able to keep using the same KDE apps.
The difference is that all those automated tasks running in the background in KDE won’t in LXQt, and you’ll also find fewer graphical effects by default, the net effect is that you’ll be able to do the same work you did before without many changes but as though you have a couple extra gigabytes of RAM in your machine.

Your Winbook has given you good service for many years, but it may be getting a bit tired…
Modify what is running on it, and you’ll help it give you several more years to come.


Yes, but – please take note of the timestamps on the Ubuntu forum and, the timestamps on the KDE Bug Report …

  • Timestamps related to the year 2015 and the year 2011 means that, the information is more than a little bit dated …

A further but, there’s a couple of CLI command executions mentioned in the Ubuntu forum entry:

ssh-keygen -f "$HOME/.ssh/known_hosts" -R server
ssh -o HostKeyAlgorithms=ssh-rsa user@server

In other words, for the affected users, the SSH keys have to be regenerated …
[HR][/HR]What happens for the case of a fresh, newly created, new user?

  • For a new, fresh, user, does Dolphin behave correctly for the case of a newly setup connection via SSH to the wanted target?

i alwas have some sort of bletooth problem with any of the openSUSE versions but no issue in stability

When you have a bluetooth problem, then please start a thread about it with technical relevant information. Just putting such a vague complaint here at the end of another discussion (that more or less finished already more then a month ago) will not really work.