Is there now a "Leave" delay in 11.3 KDE?

I upgraded from 11.2 to 11.3 x86 on a desktop Q6600 based system and find that it now has a 5 second delay between the click of “Shutdown” or “Restart” and the presentation of the confirmation.

Anyone know how to get rid of that? Is it configurable?


  • Bruce

Also just discovered that I can’t logout from KDE. The first time I hit “Logout” I get that 5 second delay but then it does nothing. Subsequent “Logout” clicks don’t even get the confirmation.

I have openSUSE 11.3 running on three computers and I do not see a five second delay in getting the confirmation screen while in KDE. Depending on what is loaded it may take more than five seconds to perform your request such as shutting down after the confirmation is made. I also see that even if you do not select the confirmation, the function happens anyway after 30 seconds of time by default in KDE.

Perhaps you could tell us more about your computer and installations. If you close all running applications before you leave openSUSE, does that help? Which desktop are you using?

Opps, just saw your second post. I would say that the KDE session is unable to close some program which is causing it to hang in some way. We need to know more about just what icons you you shown in the icon tray for instance. If I load the UPS application but don’t configure it properly, it can cause KDE to hang on shutdown. Same thing for video and sound if they don’t work right before you try to log-out. Any added info could be helpful.

Thank You,


Thanks very much for taking the time to reply. I’ve got nothing running when I attempt to “Leave”. Well, not exactly “nothing” as I notice that I’ve now got a “Nepomuk” indexing service running. Even on that I’ve been selecting the “Suspend File Indexing” prior to attempting to “Leave”.

I don’t know how to diagnose this. There is probably a KDE log file somewhere that says something about what is going on but I don’t know where that “somewhere” is. :frowning:

This is probably an artifact of having “Upgraded” my system rather than done a full re-install.

     - Bruce

Tell us about your video and audio setup. In openSUSE 11.3, the video configuration has changed. For instance the old sax2 has been removed. If you are loading a nVidia or Radion binary driver, several steps must be taken to reload that driver properly. Also, if you have elected to use a separate /home folder, you might want to consider a full openSUSE 11.3 installation, without reformatting /home. Due to several changes in openSUSE 11.3, I would not do an upgrade myself, though I am not saying it can’t work properly for you.

Thank You,

Yes I faced couple of similar issues when I had upgraded to 11.3 from my 11.2 installation… Backup your home dir and any other directories and try doing a clean install, to see if the problem exists…


That is pretty funny, you are telling me things I discovered the hard way after doing the upgrade. :slight_smile:

I have an Asus MB with an NVidia GeForce 9800GT. I was using the proprietary NVidia drivers under 11.2, when 11.3 first booted I got a console prompt and no X. Doing a “startx” as root showed that “nvidia” module would not load, searching /lib showed that there was no such module.

First thing I did was run “sax2”. Ha! No such command.
So I ran yast2 in console mode. No “Display” setup under “Hardware”.

** A r g h **

Fall back time. I noticed that /etc/X11/xorg.conf-nvidia-postun used the “nv” driver and I put that in place as xorg.conf.
That got X working enough that I could search these forums and discover that the NVidia repository is not there yet. Oh well. I’ll just stick with “nv” until the repository comes online. Or if I get really impatient I might install the NVidia drivers by hand. :slight_smile:

I do have a separate /home and so I might just do the full install. Right now I’m attempting another trick. I’m installing the Gnome desktop. Since I did not have Gnome installed prior to the upgrade it is going to be a fresh install (as it was not there to upgrade when I went to 11.3). Once I get that in place I’ll setup GDM as the default, reboot, and login to Gnome. I’ll then use that to uninstall KDE and then re-install it.

Wish me luck: it might work. If not, there is always the full install option. :wink:

- Bruce

Here is my standard nVidia video driver installation blurb for openSUSE 11.3.

Have you read the very fine article by oldcpu at:"

SDB:Configuring graphics cards - openSUSE

When I install the latest video driver during openSUSE installation, I am doing the following items:

  1. During the install, when you have the option to change your booting setup, I add nomodeset to the kernel load command for the normal load/start of openSUSE. This kernel startup option is already present for the Failsafe selection for openSUSE.
  2. During the first start of openSUSE, I download the latest nVidia Video driver to the downloads folder.
  3. I change/save the System/Kernel option NO_KMS_IN_INITRD from “No” to “Yes” in the /etc/sysconfig Editor in Yast.
  4. I do an update of openSUSE on the first run of openSUSE and then a restart/reboot.
  5. In grub OS selection I add the command line option “3” to the openSUSE start line so that I just go to the run level three terminal prompt.
  6. I login in as root and change to the /home/user/Downloads folder.
  7. I run/install the NVIDIA video driver using “sh ./” and answer all questions as appropriate for my system.
  8. Type in reboot at terminal prompt to restart the system with new video driver.

I hope this provides the help you need. Please let us know if you need to know more.

Thank You,

James you are amazing. That is a lot of time and effort you put into answering peoples questions and thoroughly at that!

For anyone else reading this thread later …

The Gnome->KDE reinstall was not a great idea. Turns out that Yast does not allow removing a pattern so uninstalling the KDE desktop is not as easy as installing the KDE desktop in the first place. I gave it a try by selecting listed KDE components for uninstall by hand. Somewhere along the way I uninstalled one too many things and got the system so messed up that even yast would not run. So I went the “install 11.3 from scratch” route. Fortunately I have a separate /home so that was not a big deal.

After I got the reinstall completed I still had the exact same issue as what I started this thread with. Turns out that there is something in my .kde or .kde4 that messes up the new KDE (I should have thought of that in the first place; I bet that the upgrade had been perfectly fine). When I renamed .kde and .kde4 out of the way the shell behaved fine. That is really too bad as it defeats a lot of what having a separate /home is all about: keeping one’s preferences and configuration.

Other issues were that the nouveau driver does not work well with the new Geforce 9800. Enabling effects hangs the system and/or composting automatically gets disabled. I have two displays, one each on the 9800’s DVI outputs. Each time I logged in I had to do a Configure Desktop->Display and then go set the second monitor to be “right of” DVI-0. There was no way I could get the system to remember this simple thing (even tried configuring it as root).

In the end I installed the NVidia proprietary drivers (had to first install kernel development package) and at least I’ve got the display working to my liking again. Now I need to see if I can figure out a good way of bringing back my old preferences from my saved .kde and .kde4 w/o once again hanging KDE.

James: once again thanks for your efforts … greatly appreciated!

 - Bruce

NightStorm I love to hear about a success story. If you found this information useful, don’t forget to give this thread a high rating which might flag it for others to read. Should you see someone that needs the information feel free give them a pointer to the thread or you can copy it in whole or part and send it to then. Have a great day and let us know if you need any other help.

Thank You,